Bug 298008 - crash with changing to static ip
Summary: crash with changing to static ip
Status: RESOLVED DUPLICATE of bug 298006
Alias: None
Product: solid
Classification: Unclassified
Component: libsolid-fstab (show other bugs)
Version: 4.9-git
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Mario Bensi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-12 23:52 UTC by Simon Andric
Modified: 2012-08-22 19:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Andric 2012-04-12 23:52:49 UTC
Application: krunner (0.1)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic-pae i686
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

tried to change my local network to static ip, kate, dolphin and plasma crashed...

symon

The crash can be reproduced every time.

-- Backtrace:
Application: Run Command Interface (kdeinit4), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb54ac740 (LWP 3598))]

Thread 2 (Thread 0xb036fb40 (LWP 3621)):
#0  0xb5785dcd in __GI_clock_gettime (clock_id=1, tp=0xb036ef70) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb6c48fcf in do_gettime (sec=0xb036efa0, frac=0xb036efa8) at tools/qelapsedtimer_unix.cpp:123
#2  0xb6c4904e in qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6d39a8b in QTimerInfoList::updateCurrentTime (this=0xafa02074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb6d39de9 in QTimerInfoList::timerWait (this=0xafa02074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb6d36e99 in timerSourcePrepareHelper (src=0xafa02040, timeout=0xb036f0cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6d36ffe in timerSourcePrepare (source=0xafa02040, timeout=0xb036f0cc) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb56cf762 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb56cff6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb56d01c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6d379de in QEventDispatcherGlib::processEvents (this=0xafa00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb6cfe4a5 in QEventLoop::processEvents (this=0xb036f238, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6cfe613 in QEventLoop::exec (this=0xb036f238, flags=...) at kernel/qeventloop.cpp:204
#13 0xb6bdf0f5 in QThread::exec (this=0x8705260) at thread/qthread.cpp:501
#14 0xb6cdc512 in QInotifyFileSystemWatcherEngine::run (this=0x8705260) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6be18ad in QThreadPrivate::start (arg=0x8705260) at thread/qthread_unix.cpp:298
#16 0xb6b5bd4c in start_thread (arg=0xb036fb40) at pthread_create.c:308
#17 0xb5d3face in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb54ac740 (LWP 3598)):
[KCrash Handler]
#7  0xb77cd424 in __kernel_vsyscall ()
#8  0xb5c831ef in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb5c86835 in __GI_abort () at abort.c:91
#10 0xb6bd53d7 in qt_message_output (msgType=QtFatalMsg, buf=0x8886058 "ASSERT: \"dev->backendObject()!=0\" in file /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp, line 201") at global/qglobal.cpp:2252
#11 0xb6bd5576 in qt_message (msgType=QtFatalMsg, msg=0xb6d7a034 "ASSERT: \"%s\" in file %s, line %d", ap=0xbf9729c4 "\241S\325\264\374P\325\264\311") at global/qglobal.cpp:2298
#12 0xb6bd59a2 in qFatal (msg=0xb6d7a034 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2481
#13 0xb6bd4f8e in qt_assert (assertion=0xb4d553a1 "dev->backendObject()!=0", file=0xb4d550fc "/build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp", line=201) at global/qglobal.cpp:1999
#14 0xb4ce3ede in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x871bca0, udi=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp:201
#15 0xb4ce469b in Solid::DeviceManagerPrivate::qt_static_metacall (_o=0x871bca0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf972b18) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/devicemanager_p.moc:55
#16 0xb6d1c259 in QMetaObject::activate (sender=0x86840e0, m=0xb4d9cc88, local_signal_index=1, argv=0xbf972b18) at kernel/qobject.cpp:3547
#17 0xb4cfc20a in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x86840e0, _t1=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/ifaces/devicemanager.moc:108
#18 0xb4d4e0e7 in Solid::Backends::Fstab::FstabManager::_k_updateDeviceList (this=0x86840e0) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabmanager.cpp:126
#19 0xb4d4de84 in Solid::Backends::Fstab::FstabManager::onFstabChanged (this=0x86840e0) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabmanager.cpp:110
#20 0xb4cde71f in Solid::Backends::Fstab::FstabManager::qt_static_metacall (_o=0x86840e0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf972c70) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabmanager.cpp:56
#21 0xb6d1c259 in QMetaObject::activate (sender=0x871bcc0, m=0xb4d9a1c0, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3547
#22 0xb4cdeeab in Solid::Backends::Fstab::FstabWatcher::fstabChanged (this=0x871bcc0) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabwatcher.cpp:113
#23 0xb4d51977 in Solid::Backends::Fstab::FstabWatcher::onFileChanged (this=0x871bcc0, path=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabwatcher.cpp:110
#24 0xb4cded0c in Solid::Backends::Fstab::FstabWatcher::qt_static_metacall (_o=0x871bcc0, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf972e38) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabwatcher.cpp:58
#25 0xb6d1c259 in QMetaObject::activate (sender=0x8705198, m=0xb6ea98f8, local_signal_index=0, argv=0xbf972e38) at kernel/qobject.cpp:3547
#26 0xb6ccd2ea in QFileSystemWatcher::fileChanged (this=0x8705198, _t1=...) at .moc/debug-shared/moc_qfilesystemwatcher.cpp:109
#27 0xb6ccc518 in QFileSystemWatcherPrivate::_q_fileChanged (this=0x87051f8, path=..., removed=false) at io/qfilesystemwatcher.cpp:346
#28 0xb6ccd14e in QFileSystemWatcher::qt_static_metacall (_o=0x8705198, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xafa02498) at .moc/debug-shared/moc_qfilesystemwatcher.cpp:59
#29 0xb6d1678e in QMetaCallEvent::placeMetaCall (this=0xafa024d8, object=0x8705198) at kernel/qobject.cpp:525
#30 0xb6d1782c in QObject::event (this=0x8705198, e=0xafa024d8) at kernel/qobject.cpp:1195
#31 0xb604e262 in QApplicationPrivate::notify_helper (this=0x86747c0, receiver=0x8705198, e=0xafa024d8) at kernel/qapplication.cpp:4554
#32 0xb604bb60 in QApplication::notify (this=0x866e4f8, receiver=0x8705198, e=0xafa024d8) at kernel/qapplication.cpp:3936
#33 0xb74f9742 in KApplication::notify (this=0x866e4f8, receiver=0x8705198, event=0xafa024d8) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kdeui/kernel/kapplication.cpp:311
#34 0xb6d009de in QCoreApplication::notifyInternal (this=0x866e4f8, receiver=0x8705198, event=0xafa024d8) at kernel/qcoreapplication.cpp:876
#35 0xb6d04145 in QCoreApplication::sendEvent (receiver=0x8705198, event=0xafa024d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 0xb6d018da in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8600a40) at kernel/qcoreapplication.cpp:1500
#37 0xb6d01597 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#38 0xb6d3808e in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 0xb6d37232 in postEventSourceDispatch (s=0x8675db0) at kernel/qeventdispatcher_glib.cpp:279
#40 0xb56cfcda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb56d00e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#42 0xb56d01c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#43 0xb6d379be in QEventDispatcherGlib::processEvents (this=0x8662ea0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0xb6117878 in QGuiEventDispatcherGlib::processEvents (this=0x8662ea0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0xb6cfe4a5 in QEventLoop::processEvents (this=0xbf9736cc, flags=...) at kernel/qeventloop.cpp:149
#46 0xb6cfe613 in QEventLoop::exec (this=0xbf9736cc, flags=...) at kernel/qeventloop.cpp:204
#47 0xb6d0105a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#48 0xb604b7d4 in QApplication::exec () at kernel/qapplication.cpp:3815
#49 0xb16df61e in kdemain (argc=1, argv=0x86448d0) at /build/buildd/project-neon-kde-workspace-2+git20120412+r46607/krunner/main.cpp:66
#50 0x0804d78f in launch (argc=1, _name=0x864fc0c "/opt/project-neon/bin/krunner", args=0x864fc2a "", cwd=0x0, envc=0, envs=0x864fc2e "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80530d5 "0") at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kinit/kinit.cpp:734
#51 0x0804e85d in handle_launcher_request (sock=8, who=0x8053370 "launcher") at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kinit/kinit.cpp:1226
#52 0x0804f055 in handle_requests (waitForPid=0) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kinit/kinit.cpp:1419
#53 0x08050983 in main (argc=4, argv=0xbf973e14, envp=0xbf973e28) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 287560.

Possible duplicates by query: bug 291961, bug 291369, bug 287560, bug 284718, bug 281086.

Reported using DrKonqi
Comment 1 Janek Bevendorff 2012-08-22 19:44:56 UTC

*** This bug has been marked as a duplicate of bug 298006 ***