Bug 298006 - again, same action - i was changing my local network to static ip
Summary: again, same action - i was changing my local network to static ip
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
: 298008 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-12 23:50 UTC by Simon Andric
Modified: 2013-02-12 02:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Andric 2012-04-12 23:50:17 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic-pae i686
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

and it crashed dolphin, and plasma. And i got 4 not same errors which im sending now...

symon

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb54ac740 (LWP 3540))]

Thread 2 (Thread 0xa9ed1b40 (LWP 3541)):
#0  0xb570f118 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb570f418 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb56cfa66 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb56d0002 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb56d01c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6d379de in QEventDispatcherGlib::processEvents (this=0xa9500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb6cfe4a5 in QEventLoop::processEvents (this=0xa9ed1238, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6cfe613 in QEventLoop::exec (this=0xa9ed1238, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6bdf0f5 in QThread::exec (this=0x914ab40) at thread/qthread.cpp:501
#9  0xb6cdc512 in QInotifyFileSystemWatcherEngine::run (this=0x914ab40) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6be18ad in QThreadPrivate::start (arg=0x914ab40) at thread/qthread_unix.cpp:298
#11 0xb6b5bd4c in start_thread (arg=0xa9ed1b40) at pthread_create.c:308
#12 0xb5d3face in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb54ac740 (LWP 3540)):
[KCrash Handler]
#7  0xb77cd424 in __kernel_vsyscall ()
#8  0xb5c831ef in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb5c86835 in __GI_abort () at abort.c:91
#10 0xb6bd53d7 in qt_message_output (msgType=QtFatalMsg, buf=0xa60e4c0 "ASSERT: \"dev->backendObject()!=0\" in file /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp, line 201") at global/qglobal.cpp:2252
#11 0xb6bd5576 in qt_message (msgType=QtFatalMsg, msg=0xb6d7a034 "ASSERT: \"%s\" in file %s, line %d", ap=0xbf972954 "\241S\325\264\374P\325\264\311") at global/qglobal.cpp:2298
#12 0xb6bd59a2 in qFatal (msg=0xb6d7a034 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2481
#13 0xb6bd4f8e in qt_assert (assertion=0xb4d553a1 "dev->backendObject()!=0", file=0xb4d550fc "/build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp", line=201) at global/qglobal.cpp:1999
#14 0xb4ce3ede in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x9153ef0, udi=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp:201
#15 0xb4ce469b in Solid::DeviceManagerPrivate::qt_static_metacall (_o=0x9153ef0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf972aa8) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/devicemanager_p.moc:55
#16 0xb6d1c259 in QMetaObject::activate (sender=0x9154888, m=0xb4d9cc88, local_signal_index=1, argv=0xbf972aa8) at kernel/qobject.cpp:3547
#17 0xb4cfc20a in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x9154888, _t1=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/ifaces/devicemanager.moc:108
#18 0xb4d4e0e7 in Solid::Backends::Fstab::FstabManager::_k_updateDeviceList (this=0x9154888) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabmanager.cpp:126
#19 0xb4d4de84 in Solid::Backends::Fstab::FstabManager::onFstabChanged (this=0x9154888) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabmanager.cpp:110
#20 0xb4cde71f in Solid::Backends::Fstab::FstabManager::qt_static_metacall (_o=0x9154888, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf972c00) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabmanager.cpp:56
#21 0xb6d1c259 in QMetaObject::activate (sender=0x86fdc58, m=0xb4d9a1c0, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3547
#22 0xb4cdeeab in Solid::Backends::Fstab::FstabWatcher::fstabChanged (this=0x86fdc58) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabwatcher.cpp:113
#23 0xb4d51977 in Solid::Backends::Fstab::FstabWatcher::onFileChanged (this=0x86fdc58, path=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabwatcher.cpp:110
#24 0xb4cded0c in Solid::Backends::Fstab::FstabWatcher::qt_static_metacall (_o=0x86fdc58, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbf972dc8) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabwatcher.cpp:58
#25 0xb6d1c259 in QMetaObject::activate (sender=0x914aa78, m=0xb6ea98f8, local_signal_index=0, argv=0xbf972dc8) at kernel/qobject.cpp:3547
#26 0xb6ccd2ea in QFileSystemWatcher::fileChanged (this=0x914aa78, _t1=...) at .moc/debug-shared/moc_qfilesystemwatcher.cpp:109
#27 0xb6ccc518 in QFileSystemWatcherPrivate::_q_fileChanged (this=0x914aad8, path=..., removed=false) at io/qfilesystemwatcher.cpp:346
#28 0xb6ccd14e in QFileSystemWatcher::qt_static_metacall (_o=0x914aa78, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xa9502460) at .moc/debug-shared/moc_qfilesystemwatcher.cpp:59
#29 0xb6d1678e in QMetaCallEvent::placeMetaCall (this=0xa9502490, object=0x914aa78) at kernel/qobject.cpp:525
#30 0xb6d1782c in QObject::event (this=0x914aa78, e=0xa9502490) at kernel/qobject.cpp:1195
#31 0xb604e262 in QApplicationPrivate::notify_helper (this=0x868b0d0, receiver=0x914aa78, e=0xa9502490) at kernel/qapplication.cpp:4554
#32 0xb604bb60 in QApplication::notify (this=0x8667c48, receiver=0x914aa78, e=0xa9502490) at kernel/qapplication.cpp:3936
#33 0xb74f9742 in KApplication::notify (this=0x8667c48, receiver=0x914aa78, event=0xa9502490) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kdeui/kernel/kapplication.cpp:311
#34 0xb6d009de in QCoreApplication::notifyInternal (this=0x8667c48, receiver=0x914aa78, event=0xa9502490) at kernel/qcoreapplication.cpp:876
#35 0xb6d04145 in QCoreApplication::sendEvent (receiver=0x914aa78, event=0xa9502490) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 0xb6d018da in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8600a40) at kernel/qcoreapplication.cpp:1500
#37 0xb6d01597 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#38 0xb6d3808e in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 0xb6d37232 in postEventSourceDispatch (s=0x868c300) at kernel/qeventdispatcher_glib.cpp:279
#40 0xb56cfcda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb56d00e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#42 0xb56d01c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#43 0xb6d379be in QEventDispatcherGlib::processEvents (this=0x866f898, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0xb6117878 in QGuiEventDispatcherGlib::processEvents (this=0x866f898, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0xb6cfe4a5 in QEventLoop::processEvents (this=0xbf97365c, flags=...) at kernel/qeventloop.cpp:149
#46 0xb6cfe613 in QEventLoop::exec (this=0xbf97365c, flags=...) at kernel/qeventloop.cpp:204
#47 0xb6d0105a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#48 0xb604b7d4 in QApplication::exec () at kernel/qapplication.cpp:3815
#49 0xb160effe in kdemain (argc=1, argv=0x86448d0) at /build/buildd/project-neon-kde-workspace-2+git20120412+r46607/plasma/desktop/shell/main.cpp:120
#50 0x0804d78f in launch (argc=1, _name=0x86447ac "/opt/project-neon/bin/plasma-desktop", args=0x86447d1 "", cwd=0x0, envc=0, envs=0x86447d5 "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80530d5 "0") at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kinit/kinit.cpp:734
#51 0x0804e85d in handle_launcher_request (sock=8, who=0x8053370 "launcher") at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kinit/kinit.cpp:1226
#52 0x0804f055 in handle_requests (waitForPid=0) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kinit/kinit.cpp:1419
#53 0x08050983 in main (argc=4, argv=0xbf973e14, envp=0xbf973e28) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 291961.

Possible duplicates by query: bug 297943, bug 291961, bug 291369, bug 288888, bug 287795.

Reported using DrKonqi
Comment 1 Janek Bevendorff 2012-08-22 19:44:56 UTC
*** Bug 298008 has been marked as a duplicate of this bug. ***
Comment 2 Alex Fiestas 2013-02-12 02:24:22 UTC
This has been fixed in 4.8.5 and newer.

If you are able to reproduce this bug with a newer release, please reopen this bug!

Thanks !