Bug 291369 - KDED crashes with newest Project Neon
Summary: KDED crashes with newest Project Neon
Status: RESOLVED NOT A BUG
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 13:41 UTC by Stephan Diestelhorst
Modified: 2012-01-12 14:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Diestelhorst 2012-01-12 13:41:28 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.7.98 (4.8 RC2+ (4.7.98)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Logging into a Project Neon session, after having used standard KDE 4.7.4 before.
Worked with yesterday's snapshot.

- Unusual behavior I noticed:

Desktop effects were not working. How can I check the proper activity version? Using the PLasma Neon (previous) session in kdm. Maybe that had some old (yesterday's?) stuff lurking somewhere.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0x7f57f75857a0 (LWP 12301))]

Thread 2 (Thread 0x7f57dabea700 (LWP 12314)):
#0  0x00007f57f13d8089 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f57f13d8dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f57f13d9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f57f604dbee in QEventDispatcherGlib::processEvents (this=0x2645f50, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f57f600f2a8 in QEventLoop::processEvents (this=0x7f57dabe9d40, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f57f600f432 in QEventLoop::exec (this=0x7f57dabe9d40, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f57f5edc2a7 in QThread::exec (this=0x25c3510) at thread/qthread.cpp:501
#7  0x00007f57f5fea6fb in QInotifyFileSystemWatcherEngine::run (this=0x25c3510) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f57f5edebd4 in QThreadPrivate::start (arg=0x25c3510) at thread/qthread_unix.cpp:298
#9  0x00007f57f5c3defc in start_thread (arg=0x7f57dabea700) at pthread_create.c:304
#10 0x00007f57f46c289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f57f75857a0 (LWP 12301)):
[KCrash Handler]
#6  0x00007f57f46173a5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f57f461ab0b in __GI_abort () at abort.c:92
#8  0x00007f57f5ed1a47 in qt_message_output (msgType=QtFatalMsg, buf=0x268edc8 "ASSERT failure in KConfigGroup::groupImpl: \"can not have an unnamed child group\", file /build/buildd/project-neon-kdelibs-2+git20120111+r92385/kdecore/config/kconfiggroup.cpp, line 516") at global/qglobal.cpp:2252
#9  0x00007f57f5ed1bdd in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7f57f6094ed0 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0x7fff887dcb68) at global/qglobal.cpp:2298
#10 0x00007f57f5ed236d in qFatal (msg=0x7f57f6094ed0 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2481
#11 0x00007f57f5ed164b in qt_assert_x (where=0x7f57f6631583 "KConfigGroup::groupImpl", what=0x7f57f66315a0 "can not have an unnamed child group", file=0x7f57f6631220 "/build/buildd/project-neon-kdelibs-2+git20120111+r92385/kdecore/config/kconfiggroup.cpp", line=516) at global/qglobal.cpp:2007
#12 0x00007f57f646f2ed in KConfigGroup::groupImpl (this=0x7fff887dcf80, aGroup=...) at /build/buildd/project-neon-kdelibs-2+git20120111+r92385/kdecore/config/kconfiggroup.cpp:516
#13 0x00007f57f646c374 in KConfigBase::group (this=0x7fff887dcf80, str=...) at /build/buildd/project-neon-kdelibs-2+git20120111+r92385/kdecore/config/kconfigbase.cpp:51
#14 0x00007f57dd7f5359 in PowerDevil::Core::loadProfile (this=0x258ad20, force=true) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/powerdevil/daemon/powerdevilcore.cpp:267
#15 0x00007f57dd7f4f89 in PowerDevil::Core::refreshStatus (this=0x258ad20) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/powerdevil/daemon/powerdevilcore.cpp:236
#16 0x00007f57dd7f44bd in PowerDevil::Core::onBackendReady (this=0x258ad20) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/powerdevil/daemon/powerdevilcore.cpp:153
#17 0x00007f57dd7f881a in PowerDevil::Core::qt_static_metacall (_o=0x258ad20, _c=QMetaObject::InvokeMetaMethod, _id=24, _a=0x7fff887dd890) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/obj-x86_64-linux-gnu/powerdevil/daemon/powerdevilcore.moc:145
#18 0x00007f57f602fdb2 in QMetaObject::activate (sender=0x25c8bf0, m=0x7f57dda1c360, local_signal_index=5, argv=0x0) at kernel/qobject.cpp:3547
#19 0x00007f57dd7f266f in PowerDevil::BackendInterface::backendReady (this=0x25c8bf0) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/obj-x86_64-linux-gnu/powerdevil/daemon/powerdevilbackendinterface.moc:160
#20 0x00007f57dd7f2072 in PowerDevil::BackendInterface::setBackendIsReady (this=0x25c8bf0, availableBrightnessControls=..., supportedSuspendMethods=...) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/powerdevil/daemon/powerdevilbackendinterface.cpp:120
#21 0x00007f57dda2e187 in PowerDevilUPowerBackend::init (this=0x25c8bf0) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/powerdevil/daemon/backends/upower/powerdevilupowerbackend.cpp:151
#22 0x00007f57dd7f3dcf in PowerDevil::Core::loadCore (this=0x258ad20, backend=0x25c8bf0) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/powerdevil/daemon/powerdevilcore.cpp:84
#23 0x00007f57dda299ed in KDEDPowerDevil::init (this=0x25cdf50) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/powerdevil/daemon/kdedpowerdevil.cpp:89
#24 0x00007f57dda29d97 in KDEDPowerDevil::qt_static_metacall (_o=0x25cdf50, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x25d1e20) at /build/buildd/project-neon-kde-workspace-2+git20120111+r45798/obj-x86_64-linux-gnu/powerdevil/daemon/kdedpowerdevil.moc:50
#25 0x00007f57f60297e5 in QMetaCallEvent::placeMetaCall (this=0x25d1e60, object=0x25cdf50) at kernel/qobject.cpp:525
#26 0x00007f57f602aa23 in QObject::event (this=0x25cdf50, e=0x25d1e60) at kernel/qobject.cpp:1195
#27 0x00007f57f4e887ea in QApplicationPrivate::notify_helper (this=0x243f540, receiver=0x25cdf50, e=0x25d1e60) at kernel/qapplication.cpp:4550
#28 0x00007f57f4e85e08 in QApplication::notify (this=0x7fff887decb0, receiver=0x25cdf50, e=0x25d1e60) at kernel/qapplication.cpp:3932
#29 0x00007f57f6ea183f in KApplication::notify (this=0x7fff887decb0, receiver=0x25cdf50, event=0x25d1e60) at /build/buildd/project-neon-kdelibs-2+git20120111+r92385/kdeui/kernel/kapplication.cpp:311
#30 0x00007f57f60119de in QCoreApplication::notifyInternal (this=0x7fff887decb0, receiver=0x25cdf50, event=0x25d1e60) at kernel/qcoreapplication.cpp:876
#31 0x00007f57f6015551 in QCoreApplication::sendEvent (receiver=0x25cdf50, event=0x25d1e60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#32 0x00007f57f60129f2 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x23b42b0) at kernel/qcoreapplication.cpp:1500
#33 0x00007f57f6012613 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#34 0x00007f57f604e31b in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#35 0x00007f57f604d2f4 in postEventSourceDispatch (s=0x2442ef0) at kernel/qeventdispatcher_glib.cpp:279
#36 0x00007f57f13d8a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f57f13d9258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007f57f13d9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f57f604dbcb in QEventDispatcherGlib::processEvents (this=0x23b67d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#40 0x00007f57f4f60e78 in QGuiEventDispatcherGlib::processEvents (this=0x23b67d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f57f600f2a8 in QEventLoop::processEvents (this=0x7fff887dec10, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f57f600f432 in QEventLoop::exec (this=0x7fff887dec10, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007f57f601205e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#44 0x00007f57f4e859f2 in QApplication::exec () at kernel/qapplication.cpp:3811
#45 0x00007f57e3916fb6 in kdemain (argc=1, argv=0x23f2bf0) at /build/buildd/project-neon-kdelibs-2+git20120111+r92385/kded/kded.cpp:924
#46 0x0000000000406d7f in launch (argc=1, _name=0x40da82 "kded4", args=0x0, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40d337 "0") at /build/buildd/project-neon-kdelibs-2+git20120111+r92385/kinit/kinit.cpp:734
#47 0x000000000040a07a in main (argc=4, argv=0x7fff887df528, envp=0x7fff887df550) at /build/buildd/project-neon-kdelibs-2+git20120111+r92385/kinit/kinit.cpp:1849

This bug may be a duplicate of or related to bug 287560.

Possible duplicates by query: bug 287560.

Reported using DrKonqi
Comment 1 Stephan Diestelhorst 2012-01-12 14:03:03 UTC
Seems to work again after system shutdown and restart. Might very well have been the session creep mentioned.