Bug 281086 - Knotify crashes after resuming
Summary: Knotify crashes after resuming
Status: RESOLVED DUPLICATE of bug 251356
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-31 07:08 UTC by René Serral
Modified: 2011-08-31 09:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Serral 2011-08-31 07:08:37 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.7.1 (4.7.1) (Compiled from sources)
Qt Version: 4.7.3
Operating System: Linux 3.0.0 i686
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:

When resuming my machine from disk using TuxOnICE sometimes I experience this crash. I didn't have any USB plugged at the moment of the crash though.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KNotify (knotify4), signal: Aborted
[Current thread is 1 (Thread 0xb50fca80 (LWP 5455))]

Thread 2 (Thread 0xb32d8b70 (LWP 5456)):
#0  0xb54ebe11 in *__GI_clock_gettime (clock_id=1, tp=0xb32d7ff8) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb6006565 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb60d8cc6 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb60d902a in ?? () from /usr/lib/libQtCore.so.4
#4  0xb60d7883 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb60d791d in ?? () from /usr/lib/libQtCore.so.4
#6  0xb56fe74e in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0xb56ff613 in ?? () from /lib/libglib-2.0.so.0
#8  0xb56ffce4 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0xb60d8357 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb60a90ed in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb60a9331 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#12 0xb5fac69b in QThread::exec() () from /usr/lib/libQtCore.so.4
#13 0xb6089c2d in ?? () from /usr/lib/libQtCore.so.4
#14 0xb5faf503 in ?? () from /usr/lib/libQtCore.so.4
#15 0xb5f29c39 in start_thread (arg=0xb32d8b70) at pthread_create.c:304
#16 0xb5d6396e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb50fca80 (LWP 5455)):
[KCrash Handler]
#7  0xb76e9424 in __kernel_vsyscall ()
#8  0xb5cc1911 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb5cc4d42 in *__GI_abort () at abort.c:92
#10 0xb5fa4626 in qt_message_output(QtMsgType, char const*) () from /usr/lib/libQtCore.so.4
#11 0xb5fa4a2b in ?? () from /usr/lib/libQtCore.so.4
#12 0xb5fa4b48 in qFatal(char const*, ...) () from /usr/lib/libQtCore.so.4
#13 0xb5fa4bd5 in qt_assert(char const*, char const*, int) () from /usr/lib/libQtCore.so.4
#14 0xb70f274e in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x8375ec0, udi=...) at /media/kdesvn/kde4svn/src/kdelibs/solid/solid/devicemanager.cpp:201
#15 0xb70f2f1b in Solid::DeviceManagerPrivate::qt_metacall (this=0x8375ec0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf9ef9c8) at /media/kdesvn/kde4svn/build/kdelibs/solid/solid/devicemanager_p.moc:80
#16 0xb60b047d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#17 0xb60bf1c0 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#18 0xb710987e in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x8375f38, _t1=...) at /media/kdesvn/kde4svn/build/kdelibs/solid/solid/ifaces/devicemanager.moc:94
#19 0xb7120915 in Solid::Backends::UDev::UDevManager::slotDeviceRemoved (this=0x8375f38, device=...) at /media/kdesvn/kde4svn/src/kdelibs/solid/solid/backends/udev/udevmanager.cpp:208
#20 0xb70ecbb6 in Solid::Backends::UDev::UDevManager::qt_metacall (this=0x8375f38, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf9efb08) at /media/kdesvn/kde4svn/build/kdelibs/solid/solid/moc_udevmanager.cpp:78
#21 0xb60b047d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#22 0xb60bf1c0 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#23 0xb71293cc in UdevQt::Client::deviceRemoved (this=0x83756b0, _t1=...) at /media/kdesvn/kde4svn/build/kdelibs/solid/solid/udevqt.moc:139
#24 0xb71287b1 in UdevQt::ClientPrivate::_uq_monitorReadyRead (this=0x83757d8, fd=10) at /media/kdesvn/kde4svn/src/kdelibs/solid/solid/backends/shared/udevqtclient.cpp:107
#25 0xb712925e in UdevQt::Client::qt_metacall (this=0x83756b0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbf9efc48) at /media/kdesvn/kde4svn/build/kdelibs/solid/solid/udevqt.moc:93
#26 0xb60b047d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#27 0xb60bf1c0 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#28 0xb610e075 in QSocketNotifier::activated(int) () from /usr/lib/libQtCore.so.4
#29 0xb60c658f in QSocketNotifier::event(QEvent*) () from /usr/lib/libQtCore.so.4
#30 0xb67257a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#31 0xb672ab32 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#32 0xb742aeb6 in KApplication::notify (this=0xbf9f0398, receiver=0x8375ad0, event=0xbf9f0094) at /media/kdesvn/kde4svn/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#33 0xb60aa0ce in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#34 0xb60d7a08 in ?? () from /usr/lib/libQtCore.so.4
#35 0xb56ff252 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0xb56ffa30 in ?? () from /lib/libglib-2.0.so.0
#37 0xb56ffce4 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0xb60d82f7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb67da6fa in ?? () from /usr/lib/libQtGui.so.4
#40 0xb60a90ed in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0xb60a9331 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#42 0xb60ada8a in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#43 0xb6723624 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#44 0x0805094b in main (argc=1, argv=0xbf9f0514) at /media/kdesvn/kde4svn/src/kde-runtime/knotify/main.cpp:73

This bug may be a duplicate of or related to bug 251356.

Possible duplicates by query: bug 273568, bug 262413, bug 251935, bug 251356.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-31 09:11:52 UTC

*** This bug has been marked as a duplicate of bug 251356 ***