Bug 297943 - Activity Manager Crashes
Summary: Activity Manager Crashes
Status: RESOLVED DUPLICATE of bug 290234
Alias: None
Product: plasma4
Classification: Unclassified
Component: activities (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-12 04:52 UTC by thanosk
Modified: 2012-04-12 06:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thanosk 2012-04-12 04:52:20 UTC
Application: kactivitymanagerd (1.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.3.1-3.fc16.i686.PAE i686
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
It crashed while I had opened dolphin and was browsing through a directory

-- Backtrace:
Application: KDE Activity Manager (kactivitymanagerd), signal: Aborted
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb75da780 (LWP 1940))]

Thread 2 (Thread 0xb53dfb40 (LWP 1953)):
[KCrash Handler]
#7  0xb77f4424 in __kernel_vsyscall ()
#8  0x4800198f in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0x480032d5 in __GI_abort () at abort.c:91
#10 0x435cbae2 in qt_message_output (msgType=QtFatalMsg, buf=0xb4a03800 "ASSERT failure in QMutexLocker: \"QMutex pointer is misaligned\", file /usr/include/QtCore/qmutex.h, line 107") at global/qglobal.cpp:2252
#11 0x435cbcdd in qt_message (msgType=QtFatalMsg, msg=0x43759224 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0xb53ded84 "/c\036E\022c\036E\365b\036Ek") at global/qglobal.cpp:2298
#12 0x435cbdf9 in qFatal (msg=0x43759224 "ASSERT failure in %s: \"%s\", file %s, line %d") at global/qglobal.cpp:2481
#13 0x435cbe3e in qt_assert_x (where=0x451e632f "QMutexLocker", what=0x451e6312 "QMutex pointer is misaligned", file=0x451e62f5 "/usr/include/QtCore/qmutex.h", line=107) at global/qglobal.cpp:2007
#14 0x45176ffa in QMutexLocker (m=0x5, this=0xb53dedf4) at /usr/include/QtCore/qmutex.h:106
#15 Soprano::Error::ErrorCache::clearError (this=0xb4a02768) at /usr/src/debug/soprano-2.7.4/soprano/error.cpp:238
#16 0x45177228 in Soprano::Error::ErrorCache::setError (this=0xb4a02768, error=...) at /usr/src/debug/soprano-2.7.4/soprano/error.cpp:225
#17 0x499a6cfa in Soprano::Client::DBusModel::executeQuery (this=0xb4a02760, query=..., language=Soprano::Query::QueryLanguageNone, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.4/client/dbus/dbusmodel.cpp:112
#18 0x4ae36617 in Nepomuk::MainModel::executeQuery (this=0x9b2cba0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/nepomukmainmodel.cpp:212
#19 0xb53e568d in activityResource (id=...) at /usr/src/debug/kactivities-4.8.1/service/plugins/nepomuk/NepomukCommon.cpp:49
#20 0xb53ecd53 in RankingsUpdateThread::run (this=0x9b542a8) at /usr/src/debug/kactivities-4.8.1/service/plugins/nepomuk/Rankings.cpp:104
#21 0x435d70b1 in QThreadPrivate::start (arg=0x9b542a8) at thread/qthread_unix.cpp:298
#22 0x481b5cd3 in start_thread (arg=0xb53dfb40) at pthread_create.c:309
#23 0x480c5a2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb75da780 (LWP 1940)):
#0  0xb77f4424 in __kernel_vsyscall ()
#1  0x480be2e1 in select () at ../sysdeps/unix/syscall-template.S:82
#2  0x4371bc3c in qt_safe_select (nfds=5, fdread=0xbfd2b308, fdwrite=0xbfd2b388, fdexcept=0x0, orig_timeout=0xbfd2b408) at kernel/qcore_unix.cpp:93
#3  0x49ddaec5 in QNativeSocketEnginePrivate::nativeSelect (this=0x99ff270, timeout=600000, checkRead=true, checkWrite=false, selectForRead=0xbfd2b4ce, selectForWrite=0xbfd2b4cf) at socket/qnativesocketengine_unix.cpp:1115
#4  0x49dd89e5 in QNativeSocketEngine::waitForReadOrWrite (this=0x9b22220, readyToRead=0xbfd2b4ce, readyToWrite=0xbfd2b4cf, checkRead=true, checkWrite=false, msecs=600000, timedOut=0x0) at socket/qnativesocketengine.cpp:1000
#5  0x49dcf157 in QAbstractSocket::waitForReadyRead (this=0x9b5aedc, msecs=600000) at socket/qabstractsocket.cpp:1888
#6  0x49ddd422 in QLocalSocket::waitForReadyRead (this=0x9b558f0, msecs=600000) at socket/qlocalsocket_unix.cpp:576
#7  0x4997faa6 in Soprano::Client::ClientConnection::executeQuery (this=0x9b413a0, modelId=2143433683, query=..., type=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.4/client/clientconnection.cpp:269
#8  0x49981639 in Soprano::Client::ClientModel::executeQuery (this=0x9b1d698, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.4/client/clientmodel.cpp:101
#9  0x4ae36617 in Nepomuk::MainModel::executeQuery (this=0x9b2cba0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/nepomukmainmodel.cpp:212
#10 0x4ae5362c in Nepomuk::Types::EntityPrivate::load (this=0x9b5e610) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/entity.cpp:76
#11 0x4ae577fb in Nepomuk::Types::ClassPrivate::load (this=0x9b5e610) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/class.cpp:54
#12 0x4ae52264 in Nepomuk::Types::EntityPrivate::init (this=0x9b5e610) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/entity.cpp:51
#13 0x4ae58afc in Nepomuk::Types::Class::isSubClassOf (this=0x9b20260, other=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/class.cpp:493
#14 0x4ae58b79 in Nepomuk::Types::Class::isSubClassOf (this=0xbfd2b8a8, other=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/types/class.cpp:501
#15 0x4ae1ea9c in Nepomuk::ResourceData::constHasType (this=0x9b51b10, uri=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:255
#16 0x4ae210c0 in Nepomuk::ResourceData::load (this=0x9b51b10) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:438
#17 0x4ae21851 in Nepomuk::ResourceData::property (this=0x9b51b10, uri=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resourcedata.cpp:265
#18 0x4ae3a7c2 in Nepomuk::Resource::property (this=0xbfd2bb00, uri=...) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resource.cpp:301
#19 0x4ae3a95b in Nepomuk::Resource::symbols (this=0xbfd2bb00) at /usr/src/debug/kdelibs-4.8.1/nepomuk/core/resource.cpp:841
#20 0x0804f424 in ActivityManager::ActivityIcon (this=0xbfd2c6b0, id=...) at /usr/src/debug/kactivities-4.8.1/service/ActivityManager.cpp:736
#21 0x0805de17 in ActivityManagerAdaptor::ActivityIcon (this=0x99febc0, id=...) at /usr/src/debug/kactivities-4.8.1/i686-redhat-linux-gnu/service/activitymanageradaptor.cpp:45
#22 0x0805e537 in qt_static_metacall (_a=0xbfd2bc8c, _id=8, _o=0x99febc0, _c=<optimized out>) at /usr/src/debug/kactivities-4.8.1/i686-redhat-linux-gnu/service/activitymanageradaptor.moc:186
#23 ActivityManagerAdaptor::qt_static_metacall (_o=0x99febc0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfd2bc8c) at /usr/src/debug/kactivities-4.8.1/i686-redhat-linux-gnu/service/activitymanageradaptor.moc:171
#24 0x0805e914 in ActivityManagerAdaptor::qt_metacall (this=0x99febc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd2bc8c) at /usr/src/debug/kactivities-4.8.1/i686-redhat-linux-gnu/service/activitymanageradaptor.moc:255
#25 0x439bb6a8 in QDBusConnectionPrivate::deliverCall (this=0x99f18f0, object=0x99febc0, msg=..., metaTypes=..., slotIdx=-514) at qdbusintegrator.cpp:947
#26 0x439bc8f8 in QDBusConnectionPrivate::activateCall (this=0x99f18f0, object=0x99febc0, flags=273, msg=...) at qdbusintegrator.cpp:857
#27 0x439bd0cd in QDBusConnectionPrivate::activateObject (this=0x99f18f0, node=..., msg=..., pathStartPos=-1076707872) at qdbusintegrator.cpp:1443
#28 0x439bd469 in QDBusActivateObjectEvent::placeMetaCall (this=0x99f6400) at qdbusintegrator.cpp:1537
#29 0x4370742b in QObject::event (this=0xbfd2c6b0, e=0x99f6400) at kernel/qobject.cpp:1195
#30 0x436ecc3b in QCoreApplication::event (this=0xbfd2c6b0, e=0x99f6400) at kernel/qcoreapplication.cpp:1688
#31 0x46e632fe in QApplication::event (this=0xbfd2c6b0, e=0x99f6400) at kernel/qapplication.cpp:2532
#32 0x46e5f134 in notify_helper (e=0x99f6400, receiver=0xbfd2c6b0, this=0x9a04aa0) at kernel/qapplication.cpp:4550
#33 QApplicationPrivate::notify_helper (this=0x9a04aa0, receiver=0xbfd2c6b0, e=0x99f6400) at kernel/qapplication.cpp:4522
#34 0x46e645d3 in QApplication::notify (this=0x99f6400, receiver=0xbfd2c6b0, e=0x99f6400) at kernel/qapplication.cpp:4279
#35 0x4f15e122 in KApplication::notify (this=0xbfd2c6b0, receiver=0xbfd2c6b0, event=0x99f6400) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#36 0x436ec5fe in QCoreApplication::notifyInternal (this=0xbfd2c6b0, receiver=0xbfd2c6b0, event=0x99f6400) at kernel/qcoreapplication.cpp:876
#37 0x436f0558 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x99d4a58) at kernel/qcoreapplication.cpp:1500
#39 0x436f088d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#40 0x4371eeb5 in sendPostedEvents () at kernel/qcoreapplication.h:236
#41 postEventSourceDispatch (s=0x99fb580) at kernel/qeventdispatcher_glib.cpp:279
#42 0x4825962f in g_main_dispatch (context=0x99fb4f0) at gmain.c:2441
#43 g_main_context_dispatch (context=0x99fb4f0) at gmain.c:3011
#44 0x48259d70 in g_main_context_iterate (context=0x99fb4f0, block=1210484752, dispatch=1, self=0x99f9e80) at gmain.c:3089
#45 0x4825a01f in g_main_context_iteration (context=0x99fb4f0, may_block=1) at gmain.c:3152
#46 0x4371f2b8 in QEventDispatcherGlib::processEvents (this=0x99d55c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#47 0x46f13a9b in QGuiEventDispatcherGlib::processEvents (this=0x99d55c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#48 0x436eb4ee in QEventLoop::processEvents (this=0xbfd2c614, flags=...) at kernel/qeventloop.cpp:149
#49 0x436eb799 in QEventLoop::exec (this=0xbfd2c614, flags=...) at kernel/qeventloop.cpp:204
#50 0x436f093b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#51 0x46e5cf35 in QApplication::exec () at kernel/qapplication.cpp:3811
#52 0x0804c62b in main (argc=1, argv=0xbfd2c7b4) at /usr/src/debug/kactivities-4.8.1/service/main.cpp:37

Possible duplicates by query: bug 291961, bug 291369, bug 288888, bug 287560, bug 287422.

Reported using DrKonqi
Comment 1 Ivan Čukić 2012-04-12 06:34:48 UTC

*** This bug has been marked as a duplicate of bug 290234 ***