Bug 297379 - Okular crashed whlie searching a large PDF
Summary: Okular crashed whlie searching a large PDF
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: 0.14.1
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 293542 299135 300196 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-03 12:25 UTC by Richard Weinberger
Modified: 2012-05-17 17:34 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Weinberger 2012-04-03 12:25:16 UTC
Application: okular (0.14.1)
KDE Platform Version: 4.8.1 (4.8.1) "release 2"
Qt Version: 4.8.0
Operating System: Linux 3.3.0-16-desktop i686
Distribution: "openSUSE 12.1 (i586)"

-- Information about the crash:
While searching in the large MPC5125 RM (http://cache.freescale.com/files/microcontrollers/doc/ref_manual/MPC5125RM.pdf?fpsp=1&WT_TYPE=Reference%20Manuals&WT_VENDOR=FREESCALE&WT_FILE_FORMAT=pdf&WT_ASSET=Documentation)
I've clicked at some nagivation links on the left side.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Okular (okular), signal: Segmentation fault
[KCrash Handler]
#6  Okular::Page::setTextPage (this=0x0, textPage=0xb0dff8c0) at /usr/src/debug/okular-4.8.1/core/page.cpp:476
#7  0xb3aed036 in Okular::GeneratorPrivate::textpageGenerationFinished (this=0x83a51f0) at /usr/src/debug/okular-4.8.1/core/generator.cpp:133
#8  0xb6128621 in QMetaCallEvent::placeMetaCall (this=0xb0d2db90, object=0x83a4b10) at kernel/qobject.cpp:525
#9  0xb613178b in QObject::event (this=0x83a4b10, e=0xb0d2db90) at kernel/qobject.cpp:1204
#10 0xb669d2f4 in notify_helper (e=0xb0d2db90, receiver=0x83a4b10, this=0x8078bd8) at kernel/qapplication.cpp:4550
#11 QApplicationPrivate::notify_helper (this=0x8078bd8, receiver=0x83a4b10, e=0xb0d2db90) at kernel/qapplication.cpp:4522
#12 0xb66a2703 in QApplication::notify (this=0xb0d2db90, receiver=0x83a4b10, e=0xb0d2db90) at kernel/qapplication.cpp:4279
#13 0xb7231881 in KApplication::notify (this=0xbfefd900, receiver=0x83a4b10, event=0xb0d2db90) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#14 0xb611689e in QCoreApplication::notifyInternal (this=0xbfefd900, receiver=0x83a4b10, event=0xb0d2db90) at kernel/qcoreapplication.cpp:876
#15 0xb611a518 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8059788) at kernel/qcoreapplication.cpp:1500
#17 0xb611a84c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#18 0xb6149154 in sendPostedEvents () at kernel/qcoreapplication.h:236
#19 postEventSourceDispatch (s=0x8075d80) at kernel/qeventdispatcher_glib.cpp:279
#20 0xb546fe7f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0xb54705b0 in ?? () from /usr/lib/libglib-2.0.so.0
#22 0xb547084a in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0xb6149547 in QEventDispatcherGlib::processEvents (this=0x80593b8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0xb675110a in QGuiEventDispatcherGlib::processEvents (this=0x80593b8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0xb611540d in QEventLoop::processEvents (this=0xbfefd874, flags=...) at kernel/qeventloop.cpp:149
#26 0xb61156a9 in QEventLoop::exec (this=0xbfefd874, flags=...) at kernel/qeventloop.cpp:204
#27 0xb611a8fa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0xb669b164 in QApplication::exec () at kernel/qapplication.cpp:3811
#29 0x0804e830 in main (argc=) at /usr/src/debug/okular-4.8.1/shell/main.cpp:85

This bug may be a duplicate of or related to bug 293542.

Possible duplicates by query: bug 293542.

Reported using DrKonqi
Comment 1 Albert Astals Cid 2012-04-05 22:52:44 UTC
Git commit c29ce712cf699e38a3a384fc69e5bf36cd26fd8e by Albert Astals Cid.
Committed on 06/04/2012 at 00:50.
Pushed by aacid into branch 'KDE/4.8'.

Do not set mTextPageReady to true

mTextPageReady is only used for threaded generation and this is a sync one so resetting it to true make very bad things happen
An improvement of this area is needed since it makes no sense canGenerateTextPage returns mTextPageReady when generateTextPage doesn't use itB
FIXED-IN: 4.8.3

M  +0    -1    core/generator.cpp

http://commits.kde.org/okular/c29ce712cf699e38a3a384fc69e5bf36cd26fd8e
Comment 2 Albert Astals Cid 2012-04-05 22:53:14 UTC
Git commit df5b9cd4a216e4522f42e808baceac71b515df77 by Albert Astals Cid.
Committed on 06/04/2012 at 00:50.
Pushed by aacid into branch 'master'.

Do not set mTextPageReady to true

mTextPageReady is only used for threaded generation and this is a sync one so resetting it to true make very bad things happen
An improvement of this area is needed since it makes no sense canGenerateTextPage returns mTextPageReady when generateTextPage doesn't use itB
FIXED-IN: 4.8.3
(cherry picked from commit c29ce712cf699e38a3a384fc69e5bf36cd26fd8e)

M  +0    -1    core/generator.cpp

http://commits.kde.org/okular/df5b9cd4a216e4522f42e808baceac71b515df77
Comment 3 Albert Astals Cid 2012-04-05 22:54:47 UTC
*** Bug 293542 has been marked as a duplicate of this bug. ***
Comment 4 Albert Astals Cid 2012-05-02 17:33:57 UTC
*** Bug 299135 has been marked as a duplicate of this bug. ***
Comment 5 Albert Astals Cid 2012-05-17 17:34:12 UTC
*** Bug 300196 has been marked as a duplicate of this bug. ***