Bug 293542 - Okular crashed while searching in PDF
Summary: Okular crashed while searching in PDF
Status: RESOLVED DUPLICATE of bug 297379
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: 0.14.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-07 16:19 UTC by Zilvinas Valinskas
Modified: 2012-04-05 22:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zilvinas Valinskas 2012-02-07 16:19:33 UTC
Application: okular (0.14.0)
KDE Platform Version: 4.8.00 (4.8.0
Qt Version: 4.8.0
Operating System: Linux 3.2.0-14-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

Okular crashed while  searching in PDF file.  It was a 802.11n-D4.0.pdf from IEEE.

-- Backtrace:
Application: Okular (okular), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  Okular::Page::setTextPage (this=0x0, textPage=0x7f90918f66d0) at ../core/page.cpp:476
#7  0x00007f909d3d3901 in Okular::GeneratorPrivate::textpageGenerationFinished (this=<optimized out>) at ../core/generator.cpp:133
#8  0x00007f90acba49c6 in QObject::event (this=0x12aa930, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f90ad5805e4 in notify_helper (e=0x7f9090003430, receiver=0x12aa930, this=0xb4c900) at kernel/qapplication.cpp:4555
#10 QApplicationPrivate::notify_helper (this=0xb4c900, receiver=0x12aa930, e=0x7f9090003430) at kernel/qapplication.cpp:4527
#11 0x00007f90ad585463 in QApplication::notify (this=0x7fff2270c650, receiver=0x12aa930, e=0x7f9090003430) at kernel/qapplication.cpp:4416
#12 0x00007f90ae2b8a46 in KApplication::notify (this=0x7fff2270c650, receiver=0x12aa930, event=0x7f9090003430) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f90acb8b41c in QCoreApplication::notifyInternal (this=0x7fff2270c650, receiver=0x12aa930, event=0x7f9090003430) at kernel/qcoreapplication.cpp:876
#14 0x00007f90acb8f1ea in sendEvent (event=0x7f9090003430, receiver=0x12aa930) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xb22670) at kernel/qcoreapplication.cpp:1500
#16 0x00007f90acbba513 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0xb4a600) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f90a9066b2a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f90a9066ef0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f90a9066fb4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f90acbba93f in QEventDispatcherGlib::processEvents (this=0xb23b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f90ad6283ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f90acb8a202 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f90acb8a457 in QEventLoop::exec (this=0x7fff2270c5e0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f90acb8f4e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x00000000004079c6 in main (argc=<optimized out>, argv=<optimized out>) at ../../shell/main.cpp:85

Possible duplicates by query: bug 232314.

Reported using DrKonqi
Comment 1 Albert Astals Cid 2012-02-07 17:48:50 UTC
Where you closing the file or doing something else other than searching? Can you reproduce the crash?
Comment 2 Zilvinas Valinskas 2012-02-07 18:22:12 UTC
Open PDF file, hit Cntrl-F , enter some string to search. F3, F3, shitf-F3 several times to go back. Then hit again Cntrl-F, entered some other text
and hit enter to start searching ... -> crash.

I can't reproduce it every time. It seems to more random then 100% reproducible bug.
Comment 3 Albert Astals Cid 2012-02-07 21:48:44 UTC
This is really strange, can you please do this?

Run okular in gdb, i.e. open a terminal and write
  gdb okular
and inside the gdb shell write
 run
once you make okular crash write
  thread apply all bt
And paste here what you get


Once you've done that also please do this
Run okular in valgrind, i.e. open a terminal and write
  valgrind okular
and once you make it crash please paste here the output of the valgrind command
Comment 4 Albert Astals Cid 2012-04-05 22:54:47 UTC

*** This bug has been marked as a duplicate of bug 297379 ***