Bug 300196 - Crash when changing page in the same time as seaching
Summary: Crash when changing page in the same time as seaching
Status: RESOLVED DUPLICATE of bug 297379
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-17 13:01 UTC by Laurent Claessens
Modified: 2012-05-17 17:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Claessens 2012-05-17 13:01:43 UTC
Application: konqueror (4.7.4 (4.7.4))
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-17-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I was searching a word in the document (DVI) using ctrl-F. In the same time it was searching, I clicked on the "miniature" on the left in order to change page.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c3710 (LWP 4936))]

Thread 4 (Thread 0xb66ceb70 (LWP 4980)):
#0  0x00b54dbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x002d32b4 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x030998bb in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0309a637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0309ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x04834b37 in QEventDispatcherGlib::processEvents (this=0x92757e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x048051dd in QEventLoop::processEvents (this=0xb66ce2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x04805421 in QEventLoop::exec (this=0xb66ce2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0470890b in QThread::exec (this=0x92887f8) at thread/qthread.cpp:498
#9  0x047e5e2d in QInotifyFileSystemWatcherEngine::run (this=0x92887f8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0470b7b3 in QThreadPrivate::start (arg=0x92887f8) at thread/qthread_unix.cpp:331
#11 0x00b52d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x002c546e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xb44f3b70 (LWP 5309)):
#0  0x0309ac2c in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x04834b37 in QEventDispatcherGlib::processEvents (this=0xb3b00468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#2  0x048051dd in QEventLoop::processEvents (this=0xb44f32b0, flags=...) at kernel/qeventloop.cpp:149
#3  0x04805421 in QEventLoop::exec (this=0xb44f32b0, flags=...) at kernel/qeventloop.cpp:201
#4  0x0470890b in QThread::exec (this=0x9217e38) at thread/qthread.cpp:498
#5  0x047e5e2d in QInotifyFileSystemWatcherEngine::run (this=0x9217e38) at io/qfilesystemwatcher_inotify.cpp:248
#6  0x0470b7b3 in QThreadPrivate::start (arg=0x9217e38) at thread/qthread_unix.cpp:331
#7  0x00b52d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x002c546e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xb3affb70 (LWP 5666)):
#0  0x0309a0cd in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x0309a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0309ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x04834b37 in QEventDispatcherGlib::processEvents (this=0x983cfa8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x048051dd in QEventLoop::processEvents (this=0xb3aff2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x04805421 in QEventLoop::exec (this=0xb3aff2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0470890b in QThread::exec (this=0x91f2f48) at thread/qthread.cpp:498
#7  0x047e5e2d in QInotifyFileSystemWatcherEngine::run (this=0x91f2f48) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0470b7b3 in QThreadPrivate::start (arg=0x91f2f48) at thread/qthread_unix.cpp:331
#9  0x00b52d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x002c546e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77c3710 (LWP 4936)):
[KCrash Handler]
#7  Okular::Page::setTextPage (this=0x0, textPage=0xa939460) at ../core/page.cpp:449
#8  0x02839f76 in Okular::GeneratorPrivate::textpageGenerationFinished (this=0x9c58b08) at ../core/generator.cpp:133
#9  0x0283b6b7 in Okular::Generator::qt_metacall (this=0x9bb2228, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xaeff7eb8) at ./generator.moc:98
#10 0x03e5f543 in DviGenerator::qt_metacall (this=0x9bb2228, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xaeff7eb8) at ./generator_dvi.moc:66
#11 0x0480cb7d in metacall (argv=0xaeff7eb8, idx=11, cl=QMetaObject::InvokeMetaMethod, object=0x9bb2228) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9bb2228, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xaeff7eb8) at kernel/qmetaobject.cpp:232
#13 0x04817685 in QMetaCallEvent::placeMetaCall (this=0xaef9f058, object=0x9bb2228) at kernel/qobject.cpp:535
#14 0x0481eb52 in QObject::event (this=0x9bb2228, e=0xaef9f058) at kernel/qobject.cpp:1217
#15 0x014d1d84 in notify_helper (e=0xaef9f058, receiver=0x9bb2228, this=0x8d2cb00) at kernel/qapplication.cpp:4486
#16 QApplicationPrivate::notify_helper (this=0x8d2cb00, receiver=0x9bb2228, e=0xaef9f058) at kernel/qapplication.cpp:4458
#17 0x014d7133 in QApplication::notify (this=0xaef9f058, receiver=0x9bb2228, e=0xaef9f058) at kernel/qapplication.cpp:3886
#18 0x01127971 in KApplication::notify (this=0xbfa0a75c, receiver=0x9bb2228, event=0xaef9f058) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x0480619e in QCoreApplication::notifyInternal (this=0xbfa0a75c, receiver=0x9bb2228, event=0xaef9f058) at kernel/qcoreapplication.cpp:787
#20 0x04809f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8d04520) at kernel/qcoreapplication.cpp:1428
#22 0x0480a0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#23 0x048346a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0x8d24980) at kernel/qeventdispatcher_glib.cpp:277
#25 0x0309a25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0x0309a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#27 0x0309ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#28 0x04834ada in QEventDispatcherGlib::processEvents (this=0x8d05248, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#29 0x01589e7a in QGuiEventDispatcherGlib::processEvents (this=0x8d05248, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x048051dd in QEventLoop::processEvents (this=0xbfa0a5e4, flags=...) at kernel/qeventloop.cpp:149
#31 0x04805421 in QEventLoop::exec (this=0xbfa0a5e4, flags=...) at kernel/qeventloop.cpp:201
#32 0x0480a19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#33 0x014cf924 in QApplication::exec () at kernel/qapplication.cpp:3760
#34 0x001c3bd5 in kdemain (argc=2, argv=0xbfa0aab4) at ../../../konqueror/src/konqmain.cpp:242
#35 0x0804850b in main (argc=2, argv=0xbfa0aab4) at konqueror_dummy.cpp:3

Reported using DrKonqi
Comment 1 Albert Astals Cid 2012-05-17 17:34:12 UTC

*** This bug has been marked as a duplicate of bug 297379 ***