Bug 299135 - crash
Summary: crash
Status: RESOLVED DUPLICATE of bug 297379
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-30 23:35 UTC by don-redhat-zx
Modified: 2012-05-02 17:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description don-redhat-zx 2012-04-30 23:35:23 UTC
Application: okular (0.14.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.3.2-6.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

searching

(How can I tell whether it's a duplicate without comparing the details of the bug report?)

-- Backtrace:
Application: Okular (okular), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x00007f31bc8bd5f6 in Okular::Page::setTextPage(Okular::TextPage*) () from /usr/lib64/libokularcore.so.1
#7  0x00007f31bc8ba8c1 in ?? () from /usr/lib64/libokularcore.so.1
#8  0x00000037fa3927a6 in QObject::event (this=0xc4eaa0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00000033629c9bc4 in notify_helper (e=0x7f31b40b5ae0, receiver=0xc4eaa0, this=0x83b250) at kernel/qapplication.cpp:4554
#10 QApplicationPrivate::notify_helper (this=0x83b250, receiver=0xc4eaa0, e=0x7f31b40b5ae0) at kernel/qapplication.cpp:4526
#11 0x00000033629cea43 in QApplication::notify (this=0x7fff224329d0, receiver=0xc4eaa0, e=0x7f31b40b5ae0) at kernel/qapplication.cpp:4415
#12 0x0000003364051f96 in KApplication::notify (this=0x7fff224329d0, receiver=0xc4eaa0, event=0x7f31b40b5ae0) at /usr/src/debug/kdelibs-4.8.2/kdeui/kernel/kapplication.cpp:311
#13 0x00000037fa3798dc in QCoreApplication::notifyInternal (this=0x7fff224329d0, receiver=0xc4eaa0, event=0x7f31b40b5ae0) at kernel/qcoreapplication.cpp:876
#14 0x00000037fa37d36a in sendEvent (event=0x7f31b40b5ae0, receiver=0xc4eaa0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8114d0) at kernel/qcoreapplication.cpp:1500
#16 0x00000037fa3a8193 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x83da10) at kernel/qeventdispatcher_glib.cpp:279
#18 0x000000302e644acd in g_main_dispatch (context=0x8384e0) at gmain.c:2441
#19 g_main_context_dispatch (context=0x8384e0) at gmain.c:3011
#20 0x000000302e6452c8 in g_main_context_iterate (context=0x8384e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#21 0x000000302e64549c in g_main_context_iteration (context=0x8384e0, may_block=1) at gmain.c:3152
#22 0x00000037fa3a85bf in QEventDispatcherGlib::processEvents (this=0x812990, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x0000003362a6c8ce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x00000037fa378a12 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x00000037fa378c67 in QEventLoop::exec (this=0x7fff22432960, flags=...) at kernel/qeventloop.cpp:204
#26 0x00000037fa37d665 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x0000000000407a26 in ?? ()
#28 0x000000302c62169d in __libc_start_main (main=0x407640, argc=6, ubp_av=0x7fff22432ea8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff22432e98) at libc-start.c:226
#29 0x0000000000408249 in _start ()

Possible duplicates by query: bug 298851, bug 297379, bug 293542.

Reported using DrKonqi
Comment 1 Albert Astals Cid 2012-05-02 17:33:57 UTC

*** This bug has been marked as a duplicate of bug 297379 ***