Bug 297109 - add configurable delay for reveal of auto-hide panel
Summary: add configurable delay for reveal of auto-hide panel
Status: RESOLVED DUPLICATE of bug 267277
Alias: None
Product: plasma4
Classification: Unclassified
Component: panel (show other bugs)
Version: 4.8.1
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-30 11:09 UTC by ceolesen
Modified: 2012-07-03 08:39 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ceolesen 2012-03-30 11:09:02 UTC
I have a panel configured with icons of apps to run along the top of the screen opposite the default panel of apps running at the bottom of the screen.
I have both these panels configured for auto-hide.
When I want to put the mouse on an item of the top menu of a window whose top edge is close to the top edge of the screen then I often accidentally push the mouse too far so it hits the top edge of the screen with the result that the auto-hide panel at the top instantly pops down. That's annoying.
I therefore wish for add of a configurable delay between hitting the screen edge with the mouse until the auto-hide panel pops out.
I also wish for the already existing delay between the mouse having been moved away from the panel and the panel auto hiding to be configurable because I want to set that delay to zero.
Also, there is a margin below the bottom edge of the top panel about half the width of the panel such that the panel does not auto hide as long the mouse is not outside that margin. I wish for that margin to be configurable because I want to set that margin to zero.


To reproduce

1. add a panel, place it along the top of the screen and configure it for auto hide.
2. concerning the delay before pop out of the auto-hide panel - then move the mouse to the top edge of the screen and observe that the panel pops down instantly. I wish for a delayed pop-down.
3. concerning the delay before auto hide of the auto-hide panel - then move the mouse from the top edge of the screen down quickly and observe the delay before the panel auto hides. I wish for that delay to be configurable so I can set it to zero.
4. concerning the margin before auto hide of the auto-hide panel - then place the mouse at the top edge of the screen, move it slowly downwards and observe that the panel does not auto hide until the mouse is about half the width of the panel below the bottom edge of the panel. I wish for that margin to be configurable so I can set it to zero.

Versions
Fedora 16 kernel 3.3.0-4.fc16.i686.PAE
KDE 4.8.1
Comment 1 apache 2012-07-02 17:18:08 UTC
The same as this duplicates
https://bugs.kde.org/show_bug.cgi?id=257173
https://bugs.kde.org/show_bug.cgi?id=300144
https://bugs.kde.org/show_bug.cgi?id=302888
Whether it concerns show or hide some options would be useful.
Comment 2 apache 2012-07-02 17:22:05 UTC
Also:
https://bugs.kde.org/show_bug.cgi?id=267277
Comment 3 Dotan Cohen 2012-07-03 08:39:18 UTC

*** This bug has been marked as a duplicate of bug 267277 ***