Bug 257173 - don't disturb users when showing the panel
Summary: don't disturb users when showing the panel
Status: RESOLVED DUPLICATE of bug 267277
Alias: None
Product: plasma4
Classification: Unclassified
Component: panel (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-17 18:06 UTC by Xavier Brochard
Modified: 2012-07-03 08:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Brochard 2010-11-17 18:06:40 UTC
Version:           unspecified (using KDE 4.5.2) 
OS:                Linux

This is a bug report against a little - but irritating - annoyance, that can be seen as a usability problem.

When I use the "automatic hiding" or "windows can recover" option of the panel, I'm allways get disturbed by the panel showing onto the screen each time the mouse goes near the screen border. It is also hiding too fast sometimes, when I'm moving the mouse along the border, but not enough near the border.
With maximised windows it is also an irritating problem, when you just wanted to click on the scroll bar or on an icon at the bottom bar.

Here's some ideas to reduce the annoyance:
- set a timer before showing or hiding the panel (or let the user configurate it);
- show the panel only if the mouse goes "outside" the screen or if the user insist;
- don't show the panel if the mouse is moving along the screen border;
- if the panel is smaller than the screen, show it / don't hide it while the mouse is along the screen border (better to make this optional);





Reproducible: Always
Comment 1 Dotan Cohen 2012-07-03 08:38:45 UTC

*** This bug has been marked as a duplicate of bug 267277 ***