Bug 300144 - add configurable delay for automatic show/hide of the panel
Summary: add configurable delay for automatic show/hide of the panel
Status: RESOLVED DUPLICATE of bug 267277
Alias: None
Product: plasma4
Classification: Unclassified
Component: containment-panel (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-16 15:41 UTC by Xavier Brochard
Modified: 2012-07-03 08:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Brochard 2012-05-16 15:41:11 UTC
I don't know if developpers have wide screens, but users mostly don't :-)
So, I use panel options for hiding / showing it (like Hide automatically, Windows can recover, ...). But panel allways show too fast for me: 
whenever the mouse is on the bottom (or the side, for vertical panels) of a full screen  window, the panel is shown. It is very irritating when all you want is scroll down or resizing the window.  
Similarly panel disappear very fast if I move the mouse a bit out of it. This was the same with Kicker in KDE 1, 2 and 3 ad I should have report this sooner, but...

I don't like to compare with other OS, but have a look at the MacOSX dock: there is a short delay to prevent the dock to be display when the mouse cursor is near the edge of the screen.

Please add a configurable delay to show/hide the panel.

Reproducible: Always
Comment 1 Xavier Brochard 2012-05-16 15:45:40 UTC
I'm ashamed, I've already submitted this but didn't find it. See also #257173 (obviously this is a duplicate).
Comment 2 Christoph Feck 2012-05-17 21:48:07 UTC
Thanks, indeed already reported as bug 257173.
Comment 3 apache 2012-07-02 16:45:34 UTC
Ups, I did it again:
https://bugs.kde.org/show_bug.cgi?id=302888
Sorry.
Comment 4 Dotan Cohen 2012-07-03 08:37:50 UTC

*** This bug has been marked as a duplicate of bug 267277 ***