Bug 294842 - Crash on startup
Summary: Crash on startup
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-26 06:39 UTC by David Tannock
Modified: 2012-02-26 07:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Tannock 2012-02-26 06:39:22 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
The program crashes every time I start it. I'm not experienced enough to compare backtraces of other reports about crashing on startup so I'm not sure if I've just duplicated a possible bug.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7875930 (LWP 5047))]

Thread 2 (Thread 0xb5a03b70 (LWP 5051)):
#0  0x02422f43 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x024238f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x02423c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00936b37 in QEventDispatcherGlib::processEvents (this=0xa066040, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x009071dd in QEventLoop::processEvents (this=0xb5a032b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00907421 in QEventLoop::exec (this=0xb5a032b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0080a90b in QThread::exec (this=0xa0a9a08) at thread/qthread.cpp:498
#7  0x008e7e2d in QInotifyFileSystemWatcherEngine::run (this=0xa0a9a08) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0080d7b3 in QThreadPrivate::start (arg=0xa0a9a08) at thread/qthread_unix.cpp:331
#9  0x03f75d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x004240ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7875930 (LWP 5047)):
[KCrash Handler]
#7  0x00861e11 in QtPrivate::QStringList_contains (that=0xbfdc95c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfdc95c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa006268) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa006268, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdc97e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0090eb7d in metacall (argv=0xbfdc97e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa006268) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa006268, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfdc97e4) at kernel/qmetaobject.cpp:232
#13 0x0091da6a in QMetaObject::activate (sender=0x9f7cb78, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9f7cb78) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9f7cb78, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdc9928) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0090eb7d in metacall (argv=0xbfdc9928, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9f7cb78) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9f7cb78, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfdc9928) at kernel/qmetaobject.cpp:232
#18 0x0091da6a in QMetaObject::activate (sender=0xa006268, m=0x80950c0, local_signal_index=0, argv=0xbfdc9928) at kernel/qobject.cpp:3278
#19 0x002337c5 in MuonMainWindow::backendReady (this=0xa006268, _t1=0xa0635d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00233933 in MuonMainWindow::initObject (this=0xa006268) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa006268) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa006268, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdc9a54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0090eb7d in metacall (argv=0xbfdc9a54, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa006268) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa006268, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfdc9a54) at kernel/qmetaobject.cpp:232
#25 0x0091da6a in QMetaObject::activate (sender=0xa07f7f8, m=0xa3e238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00925375 in QSingleShotTimer::timeout (this=0xa07f7f8) at .moc/release-shared/qtimer.moc:82
#27 0x0092542c in QSingleShotTimer::timerEvent (this=0xa07f7f8) at kernel/qtimer.cpp:308
#28 0x00920994 in QObject::event (this=0xa07f7f8, e=0xbfdc9e4c) at kernel/qobject.cpp:1181
#29 0x01505d84 in notify_helper (e=0xbfdc9e4c, receiver=0xa07f7f8, this=0x9f1dab8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9f1dab8, receiver=0xa07f7f8, e=0xbfdc9e4c) at kernel/qapplication.cpp:4458
#31 0x0150b133 in QApplication::notify (this=0xbfdc9e4c, receiver=0xa07f7f8, e=0xbfdc9e4c) at kernel/qapplication.cpp:3886
#32 0x0115b971 in KApplication::notify (this=0xbfdca160, receiver=0xa07f7f8, event=0xbfdc9e4c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0090819e in QCoreApplication::notifyInternal (this=0xbfdca160, receiver=0xa07f7f8, event=0xbfdc9e4c) at kernel/qcoreapplication.cpp:787
#34 0x00938c10 in sendEvent (event=0xbfdc9e4c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9f1984c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00936122 in timerSourceDispatch (source=0x9f19818) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0242325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02423990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02423c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00936ada in QEventDispatcherGlib::processEvents (this=0x9efb220, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x015bde7a in QGuiEventDispatcherGlib::processEvents (this=0x9efb220, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009071dd in QEventLoop::processEvents (this=0xbfdca0c4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00907421 in QEventLoop::exec (this=0xbfdca0c4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0090c19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01503924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294800, bug 294799, bug 294798, bug 294788, bug 294767.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-26 07:15:02 UTC

*** This bug has been marked as a duplicate of bug 291262 ***