Bug 294800 - Bug Muon logithèque
Summary: Bug Muon logithèque
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-25 10:38 UTC by benxjn
Modified: 2012-02-25 10:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description benxjn 2012-02-25 10:38:27 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Logithèqye Muon Indisponible

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77dc930 (LWP 3289))]

Thread 2 (Thread 0xb58bfb70 (LWP 3290)):
#0  0x0099e416 in __kernel_vsyscall ()
#1  0x0058840e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x05a8634b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x05a77896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x05a77c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00b33b37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0x00b041dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0x00b04421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0x00a0790b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0x00ae4e2d in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0x00a0a7b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0x00485d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x005970ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77dc930 (LWP 3289)):
[KCrash Handler]
#7  0x00a5ee11 in QtPrivate::QStringList_contains(QStringList const*, QString const&, Qt::CaseSensitivity) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfbd8644) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x987df28) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x987df28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbd8864) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00b0bb7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0x00b1aa6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#13 0x0805de57 in ApplicationBackend::appBackendReady (this=0x990ffa8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#14 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x990ffa8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbd89a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#15 0x00b0bb7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#16 0x00b1aa6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#17 0x00cc77c5 in MuonMainWindow::backendReady (this=0x987df28, _t1=0x982e558) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#18 0x00cc7933 in MuonMainWindow::initObject (this=0x987df28) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#19 0x080654fc in ApplicationWindow::initObject (this=0x987df28) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#20 0x0806a09f in ApplicationWindow::qt_metacall (this=0x987df28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbd8ad4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#21 0x00b0bb7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#22 0x00b1aa6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#23 0x00b22375 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#24 0x00b2242c in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#25 0x00b1d994 in QObject::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#26 0x02636d84 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#27 0x0263c133 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#28 0x00ee2971 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#29 0x00b0519e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#30 0x00b35c10 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#31 0x00b33122 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#32 0x05a7725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0x05a77990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0x05a77c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0x00b33ada in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#36 0x026eee7a in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#37 0x00b041dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#38 0x00b04421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#39 0x00b0919d in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#40 0x02634924 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#41 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294799, bug 294798, bug 294788, bug 294767, bug 294731.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-25 10:46:57 UTC

*** This bug has been marked as a duplicate of bug 291262 ***