Bug 294155 - Moun Software Center - Crashes on starting.
Summary: Moun Software Center - Crashes on starting.
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 15:22 UTC by Daniel
Modified: 2012-02-17 18:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.80 KB, text/plain)
2012-02-17 18:21 UTC, franz-golubich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2012-02-15 15:22:01 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Just restarted after installing some updates and since then Muon Software Center doesn't start.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb482e930 (LWP 1720))]

Thread 2 (Thread 0xb26e2b70 (LWP 1721)):
#0  0xb53aadbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb5e02f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb52c18bb in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb52c2637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb52c2c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb7329b37 in QEventDispatcherGlib::processEvents (this=0x97a1c18, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb72fa1dd in QEventLoop::processEvents (this=0xb26e22b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb72fa421 in QEventLoop::exec (this=0xb26e22b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb71fd90b in QThread::exec (this=0x9843060) at thread/qthread.cpp:498
#9  0xb72dae2d in QInotifyFileSystemWatcherEngine::run (this=0x9843060) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb72007b3 in QThreadPrivate::start (arg=0x9843060) at thread/qthread_unix.cpp:331
#11 0xb53a8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5df50ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb482e930 (LWP 1720)):
[KCrash Handler]
#7  0xb7254e11 in QtPrivate::QStringList_contains (that=0xbfee7914, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfee7914) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9829cf8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9829cf8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfee7b34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7301b7d in metacall (argv=0xbfee7b34, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9829cf8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9829cf8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfee7b34) at kernel/qmetaobject.cpp:232
#13 0xb7310a6a in QMetaObject::activate (sender=0x98be9b0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x98be9b0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x98be9b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfee7c78) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7301b7d in metacall (argv=0xbfee7c78, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x98be9b0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x98be9b0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfee7c78) at kernel/qmetaobject.cpp:232
#18 0xb7310a6a in QMetaObject::activate (sender=0x9829cf8, m=0x80950c0, local_signal_index=0, argv=0xbfee7c78) at kernel/qobject.cpp:3278
#19 0xb77717c5 in MuonMainWindow::backendReady (this=0x9829cf8, _t1=0x987a3f0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb7771933 in MuonMainWindow::initObject (this=0x9829cf8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9829cf8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9829cf8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfee7da4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7301b7d in metacall (argv=0xbfee7da4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9829cf8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9829cf8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfee7da4) at kernel/qmetaobject.cpp:232
#25 0xb7310a6a in QMetaObject::activate (sender=0x9890ce8, m=0xb7431238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7318375 in QSingleShotTimer::timeout (this=0x9890ce8) at .moc/release-shared/qtimer.moc:82
#27 0xb731842c in QSingleShotTimer::timerEvent (this=0x9890ce8) at kernel/qtimer.cpp:308
#28 0xb7313994 in QObject::event (this=0x9890ce8, e=0xbfee819c) at kernel/qobject.cpp:1181
#29 0xb60e1d84 in notify_helper (e=0xbfee819c, receiver=0x9890ce8, this=0x973c078) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x973c078, receiver=0x9890ce8, e=0xbfee819c) at kernel/qapplication.cpp:4458
#31 0xb60e7133 in QApplication::notify (this=0xbfee819c, receiver=0x9890ce8, e=0xbfee819c) at kernel/qapplication.cpp:3886
#32 0xb6f00971 in KApplication::notify (this=0xbfee84b0, receiver=0x9890ce8, event=0xbfee819c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb72fb19e in QCoreApplication::notifyInternal (this=0xbfee84b0, receiver=0x9890ce8, event=0xbfee819c) at kernel/qcoreapplication.cpp:787
#34 0xb732bc10 in sendEvent (event=0xbfee819c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9744274) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb7329122 in timerSourceDispatch (source=0x9744240) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb52c225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb52c2990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb52c2c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb7329ada in QEventDispatcherGlib::processEvents (this=0x971f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb6199e7a in QGuiEventDispatcherGlib::processEvents (this=0x971f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb72fa1dd in QEventLoop::processEvents (this=0xbfee8414, flags=...) at kernel/qeventloop.cpp:149
#43 0xb72fa421 in QEventLoop::exec (this=0xbfee8414, flags=...) at kernel/qeventloop.cpp:201
#44 0xb72ff19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb60df924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294153, bug 294150, bug 294106, bug 294101, bug 294068.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-15 15:38:33 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 franz-golubich 2012-02-17 18:21:52 UTC
Created attachment 68880 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Muon-Programmverwaltung gestartet, keine abhängigkeit zu irgendwelchelchen anderen prozessen auffindbar.

-- Backtrace (Reduced):
#7  0x004cbe11 in QtPrivate::QStringList_contains (that=0xbfab5a44, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfab5a44) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9dd2c20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9dd2c20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfab5c64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00578b7d in metacall (argv=0xbfab5c64, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9dd2c20) at kernel/qmetaobject.cpp:237