Bug 293809 - Plik wykonywalny: muon-installer PID: 3951 Sygnał: Segmentation fault (11)
Summary: Plik wykonywalny: muon-installer PID: 3951 Sygnał: Segmentation fault (11)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 21:27 UTC by Krzysztof
Modified: 2012-02-10 21:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysztof 2012-02-10 21:27:46 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- Custom settings of the application:

I installed that software updates offered me Muon center.

The crash can be reproduced every time.

-- Backtrace:
Application: Centrum oprogramowania Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7d5a96f780 (LWP 3565))]

Thread 2 (Thread 0x7f7d45d7e700 (LWP 3569)):
#0  0x00007f7d5753a773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7d53daff68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7d53db0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7d596f8f3e in QEventDispatcherGlib::processEvents (this=0xb76530, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f7d596cccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7d596ccef7 in QEventLoop::exec (this=0x7f7d45d7ddd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f7d595e427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f7d596afcbf in QInotifyFileSystemWatcherEngine::run (this=0xb7c6d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7d595e6d05 in QThreadPrivate::start (arg=0xb7c6d0) at thread/qthread_unix.cpp:331
#9  0x00007f7d54891efc in start_thread (arg=0x7f7d45d7e700) at pthread_create.c:304
#10 0x00007f7d5754689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7d5a96f780 (LWP 3565)):
[KCrash Handler]
#6  0x00007f7d59634a5e in QtPrivate::QStringList_contains (that=0x7fff9d9fe600, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff9d9fe600) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x9aee20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x9aee20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9d9febd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f7d596e0eba in QMetaObject::activate (sender=0x9afb80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x9afb80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9d9fed30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f7d596e0eba in QMetaObject::activate (sender=0x9aee20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9d9fed30) at kernel/qobject.cpp:3278
#13 0x00007f7d5a556e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x9f0210) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f7d5a556f8e in MuonMainWindow::initObject (this=0x9aee20) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x9aee20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x9aee20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9d9fee00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f7d596e0eba in QMetaObject::activate (sender=0xa36820, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f7d596e8f7f in QSingleShotTimer::timerEvent (this=0xa36820) at kernel/qtimer.cpp:308
#19 0x00007f7d596e4789 in QObject::event (this=0xa36820, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f7d57d07474 in notify_helper (e=0x7fff9d9ff370, receiver=0xa36820, this=0x830400) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x830400, receiver=0xa36820, e=0x7fff9d9ff370) at kernel/qapplication.cpp:4458
#22 0x00007f7d57d0c2e1 in QApplication::notify (this=0x7fff9d9ff670, receiver=0xa36820, e=0x7fff9d9ff370) at kernel/qapplication.cpp:4365
#23 0x00007f7d58eec466 in KApplication::notify (this=0x7fff9d9ff670, receiver=0xa36820, event=0x7fff9d9ff370) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f7d596cdafc in QCoreApplication::notifyInternal (this=0x7fff9d9ff670, receiver=0xa36820, event=0x7fff9d9ff370) at kernel/qcoreapplication.cpp:787
#25 0x00007f7d596fad62 in sendEvent (event=0x7fff9d9ff370, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x829a70) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f7d596f8514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f7d53dafa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f7d53db0258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f7d53db0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f7d596f8ed6 in QEventDispatcherGlib::processEvents (this=0x8036f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f7d57daf10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f7d596cccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f7d596ccef7 in QEventLoop::exec (this=0x7fff9d9ff600, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f7d596d1789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff9d9ff8e8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293798, bug 293796, bug 293772, bug 293752, bug 293747.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-10 21:29:47 UTC

*** This bug has been marked as a duplicate of bug 291262 ***