Bug 293798 - Logitheque moon ne démare pas
Summary: Logitheque moon ne démare pas
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 19:56 UTC by fabrice.forre
Modified: 2012-02-10 20:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabrice.forre 2012-02-10 19:56:05 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
la logiteque plante dès que je la lance, La fenètre apparaît durant 3 secondes puis le message bogue apparaît.

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1348490780 (LWP 3715))]

Thread 2 (Thread 0x7f1331563700 (LWP 3721)):
#0  __libc_enable_asynccancel () at ../nptl/sysdeps/unix/sysv/linux/x86_64/cancellation.S:66
#1  0x00007f1345056758 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:85
#2  0x00007f13418cbf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f13418cc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1347214f3e in QEventDispatcherGlib::processEvents (this=0xcfe790, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f13471e8cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f13471e8ef7 in QEventLoop::exec (this=0x7f1331562dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f134710027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f13471cbcbf in QInotifyFileSystemWatcherEngine::run (this=0xb7d4b0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f1347102d05 in QThreadPrivate::start (arg=0xb7d4b0) at thread/qthread_unix.cpp:331
#10 0x00007f13423adefc in start_thread (arg=0x7f1331563700) at pthread_create.c:304
#11 0x00007f134506289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1348490780 (LWP 3715)):
[KCrash Handler]
#6  0x00007f1347150a5e in QtPrivate::QStringList_contains (that=0x7fff701ef080, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff701ef080) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xb300c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xb300c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff701ef650) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f13471fceba in QMetaObject::activate (sender=0xae9090, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xae9090, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff701ef7b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f13471fceba in QMetaObject::activate (sender=0xb300c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff701ef7b0) at kernel/qobject.cpp:3278
#13 0x00007f1348072e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xb9fa60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f1348072f8e in MuonMainWindow::initObject (this=0xb300c0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xb300c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xb300c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff701ef880) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f13471fceba in QMetaObject::activate (sender=0xbb3f30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f1347204f7f in QSingleShotTimer::timerEvent (this=0xbb3f30) at kernel/qtimer.cpp:308
#19 0x00007f1347200789 in QObject::event (this=0xbb3f30, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f1345823474 in notify_helper (e=0x7fff701efdf0, receiver=0xbb3f30, this=0x9cec20) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x9cec20, receiver=0xbb3f30, e=0x7fff701efdf0) at kernel/qapplication.cpp:4458
#22 0x00007f13458282e1 in QApplication::notify (this=0x7fff701f00f0, receiver=0xbb3f30, e=0x7fff701efdf0) at kernel/qapplication.cpp:4365
#23 0x00007f1346a08466 in KApplication::notify (this=0x7fff701f00f0, receiver=0xbb3f30, event=0x7fff701efdf0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f13471e9afc in QCoreApplication::notifyInternal (this=0x7fff701f00f0, receiver=0xbb3f30, event=0x7fff701efdf0) at kernel/qcoreapplication.cpp:787
#25 0x00007f1347216d62 in sendEvent (event=0x7fff701efdf0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x9cae20) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f1347214538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f13418cba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f13418cc258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f13418cc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f1347214ed6 in QEventDispatcherGlib::processEvents (this=0x9a66f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f13458cb10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f13471e8cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f13471e8ef7 in QEventLoop::exec (this=0x7fff701f0080, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f13471ed789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff701f0368) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293796, bug 293772, bug 293752, bug 293747, bug 293690.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-10 20:04:01 UTC

*** This bug has been marked as a duplicate of bug 291262 ***