Bug 293752 - Muon Software Center crashes on loading
Summary: Muon Software Center crashes on loading
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 02:13 UTC by ucsdboy
Modified: 2012-02-10 04:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ucsdboy 2012-02-10 02:13:18 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
The program appears to crash repeatedly and predictably at loading.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff5a4ac1780 (LWP 5517))]

Thread 2 (Thread 0x7ff590096700 (LWP 5521)):
#0  0x00007ff5a1687773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff59defcf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff59defd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff5a3845f3e in QEventDispatcherGlib::processEvents (this=0xc2f060, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff5a3819cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff5a3819ef7 in QEventLoop::exec (this=0x7ff590095dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff5a373127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007ff5a37fccbf in QInotifyFileSystemWatcherEngine::run (this=0xdd6e00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff5a3733d05 in QThreadPrivate::start (arg=0xdd6e00) at thread/qthread_unix.cpp:331
#9  0x00007ff59e9deefc in start_thread (arg=0x7ff590096700) at pthread_create.c:304
#10 0x00007ff5a169389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff5a4ac1780 (LWP 5517)):
[KCrash Handler]
#6  0x00007ff5a3781a5e in QtPrivate::QStringList_contains (that=0x7fffbc045f80, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffbc045f80) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xbf4af0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xbf4af0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc046550) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007ff5a382deba in QMetaObject::activate (sender=0xca6f30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xca6f30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc0466b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007ff5a382deba in QMetaObject::activate (sender=0xbf4af0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbc0466b0) at kernel/qobject.cpp:3278
#13 0x00007ff5a46a3e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xc07c30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007ff5a46a3f8e in MuonMainWindow::initObject (this=0xbf4af0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xbf4af0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xbf4af0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc046780) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007ff5a382deba in QMetaObject::activate (sender=0xc974b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007ff5a3835f7f in QSingleShotTimer::timerEvent (this=0xc974b0) at kernel/qtimer.cpp:308
#19 0x00007ff5a3831789 in QObject::event (this=0xc974b0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007ff5a1e54474 in notify_helper (e=0x7fffbc046cf0, receiver=0xc974b0, this=0xab5450) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xab5450, receiver=0xc974b0, e=0x7fffbc046cf0) at kernel/qapplication.cpp:4458
#22 0x00007ff5a1e592e1 in QApplication::notify (this=0x7fffbc046ff0, receiver=0xc974b0, e=0x7fffbc046cf0) at kernel/qapplication.cpp:4365
#23 0x00007ff5a3039466 in KApplication::notify (this=0x7fffbc046ff0, receiver=0xc974b0, event=0x7fffbc046cf0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007ff5a381aafc in QCoreApplication::notifyInternal (this=0x7fffbc046ff0, receiver=0xc974b0, event=0x7fffbc046cf0) at kernel/qcoreapplication.cpp:787
#25 0x00007ff5a3847d62 in sendEvent (event=0x7fffbc046cf0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xab8dd0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007ff5a3845514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007ff59defca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ff59defd258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ff59defd429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007ff5a3845ed6 in QEventDispatcherGlib::processEvents (this=0xa916f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007ff5a1efc10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007ff5a3819cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007ff5a3819ef7 in QEventLoop::exec (this=0x7fffbc046f80, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007ff5a381e789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffbc047268) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293747, bug 293690, bug 293675, bug 293674, bug 293673.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-10 04:21:09 UTC

*** This bug has been marked as a duplicate of bug 291262 ***