Bug 293690 - Muon Software Center Crashes Upon Loading
Summary: Muon Software Center Crashes Upon Loading
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-09 06:46 UTC by Thomas Conrad
Modified: 2012-02-09 07:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Conrad 2012-02-09 06:46:28 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Had installed Gnash Shockwave plugin for Mozilla. Went to load the software center and a blank window appeared for a few seconds before crashing.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fec9d016780 (LWP 6765))]

Thread 2 (Thread 0x7fec88764700 (LWP 6766)):
#0  0x00007fec99be1773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fec96456f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fec96457429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fec9bd9ff3e in QEventDispatcherGlib::processEvents (this=0x9370f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fec9bd73cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fec9bd73ef7 in QEventLoop::exec (this=0x7fec88763dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fec9bc8b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fec9bd56cbf in QInotifyFileSystemWatcherEngine::run (this=0xaad9f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fec9bc8dd05 in QThreadPrivate::start (arg=0xaad9f0) at thread/qthread_unix.cpp:331
#9  0x00007fec96f38efc in start_thread (arg=0x7fec88764700) at pthread_create.c:304
#10 0x00007fec99bed89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fec9d016780 (LWP 6765)):
[KCrash Handler]
#6  0x00007fec9bcdba5e in QtPrivate::QStringList_contains (that=0x7fff1a90c4d0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff1a90c4d0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xa631b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xa631b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1a90caa0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fec9bd87eba in QMetaObject::activate (sender=0xb4cf40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xb4cf40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1a90cc00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fec9bd87eba in QMetaObject::activate (sender=0xa631b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1a90cc00) at kernel/qobject.cpp:3278
#13 0x00007fec9cbfde7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xb25c80) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fec9cbfdf8e in MuonMainWindow::initObject (this=0xa631b0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xa631b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xa631b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1a90ccd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fec9bd87eba in QMetaObject::activate (sender=0xb12240, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fec9bd8ff7f in QSingleShotTimer::timerEvent (this=0xb12240) at kernel/qtimer.cpp:308
#19 0x00007fec9bd8b789 in QObject::event (this=0xb12240, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fec9a3ae474 in notify_helper (e=0x7fff1a90d240, receiver=0xb12240, this=0x93ba70) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x93ba70, receiver=0xb12240, e=0x7fff1a90d240) at kernel/qapplication.cpp:4458
#22 0x00007fec9a3b32e1 in QApplication::notify (this=0x7fff1a90d540, receiver=0xb12240, e=0x7fff1a90d240) at kernel/qapplication.cpp:4365
#23 0x00007fec9b593466 in KApplication::notify (this=0x7fff1a90d540, receiver=0xb12240, event=0x7fff1a90d240) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fec9bd74afc in QCoreApplication::notifyInternal (this=0x7fff1a90d540, receiver=0xb12240, event=0x7fff1a90d240) at kernel/qcoreapplication.cpp:787
#25 0x00007fec9bda1d62 in sendEvent (event=0x7fff1a90d240, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x938310) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fec9bd9f514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fec96456a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fec96457258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fec96457429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fec9bd9fed6 in QEventDispatcherGlib::processEvents (this=0x9136f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fec9a45610e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fec9bd73cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fec9bd73ef7 in QEventLoop::exec (this=0x7fff1a90d4d0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fec9bd78789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff1a90d7b8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293675, bug 293674, bug 293673, bug 293642, bug 293629.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-09 07:18:12 UTC

*** This bug has been marked as a duplicate of bug 291262 ***