Bug 284139 - muon crashed during installation and switch window.
Summary: muon crashed during installation and switch window.
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: 1.2.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-15 22:42 UTC by Serjio
Modified: 2011-10-22 23:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serjio 2011-10-15 22:42:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
When you install Thunderbird (be downloaded), switched to firefox.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5e8d2e4780 (LWP 25384))]

Thread 2 (Thread 0x7f5e784d2700 (LWP 25388)):
#0  0x00007f5e89ebe773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5e86733f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5e86734429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5e8c07bf3e in QEventDispatcherGlib::processEvents (this=0xe6dd00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f5e8c04fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5e8c04fef7 in QEventLoop::exec (this=0x7f5e784d1dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f5e8bf6727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f5e8c032cbf in QInotifyFileSystemWatcherEngine::run (this=0xe55f20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f5e8bf69d05 in QThreadPrivate::start (arg=0xe55f20) at thread/qthread_unix.cpp:331
#9  0x00007f5e87215efc in start_thread (arg=0x7f5e784d2700) at pthread_create.c:304
#10 0x00007f5e89eca89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5e8d2e4780 (LWP 25384)):
[KCrash Handler]
#6  same_key (key0=..., h0=346165, this=0x0) at /usr/include/qt4/QtCore/qhash.h:225
#7  QHash<QByteArray, QByteArray>::findNode (this=<optimized out>, akey=..., ahp=0x0) at /usr/include/qt4/QtCore/qhash.h:885
#8  0x000000000041c893 in value (akey=<optimized out>, this=0x1de31a8) at /usr/include/qt4/QtCore/qhash.h:607
#9  Application::getField (this=0x1de31a0, field=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#10 0x000000000041d0dd in Application::untranslatedName (this=0x1de31a0) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#11 0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#12 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0xd95f80, job=0x246f630) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#13 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0xd95f80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8baea830) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#14 0x00007f5e8c063eba in QMetaObject::activate (sender=0x246f630, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8baea830) at kernel/qobject.cpp:3278
#15 0x00007f5e8b29f5b2 in KJob::result (this=<optimized out>, _t1=0x246f630) at ./kjob.moc:194
#16 0x00007f5e8b29f5f0 in KJob::emitResult (this=0x246f630) at ../../kdecore/jobs/kjob.cpp:312
#17 0x00007f5e8caf5a4a in KIO::FileCopyJob::slotResult (this=0x246f630, job=0x25d9f30) at ../../kio/kio/job.cpp:2440
#18 0x00007f5e8caf57f0 in KIO::FileCopyJob::qt_metacall (this=0x246f630, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8baea9a0) at ./jobclasses.moc:724
#19 0x00007f5e8c063eba in QMetaObject::activate (sender=0x25d9f30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8baea9a0) at kernel/qobject.cpp:3278
#20 0x00007f5e8b29f5b2 in KJob::result (this=<optimized out>, _t1=0x25d9f30) at ./kjob.moc:194
#21 0x00007f5e8b29f5f0 in KJob::emitResult (this=0x25d9f30) at ../../kdecore/jobs/kjob.cpp:312
#22 0x00007f5e8caee2c4 in KIO::SimpleJob::slotFinished (this=0x25d9f30) at ../../kio/kio/job.cpp:494
#23 0x00007f5e8caf5c9d in KIO::TransferJob::slotFinished (this=0x25d9f30) at ../../kio/kio/job.cpp:1081
#24 0x00007f5e8caf4601 in KIO::TransferJob::qt_metacall (this=0x25d9f30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8baead50) at ./jobclasses.moc:369
#25 0x00007f5e8c063eba in QMetaObject::activate (sender=0xdc3060, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00007f5e8cb9a9c1 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#27 0x00007f5e8cb97875 in KIO::SlaveInterface::dispatch (this=0xdc3060) at ../../kio/kio/slaveinterface.cpp:88
#28 0x00007f5e8cb8aace in KIO::Slave::gotInput (this=0xdc3060) at ../../kio/kio/slave.cpp:344
#29 0x00007f5e8cb8b22c in KIO::Slave::qt_metacall (this=0xdc3060, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8baeb180) at ./slave.moc:82
#30 0x00007f5e8c063eba in QMetaObject::activate (sender=0xe462e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#31 0x00007f5e8cabf3a7 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#32 KIO::ConnectionPrivate::dequeue (this=0xe4eb50) at ../../kio/kio/connection.cpp:71
#33 0x00007f5e8cabf44d in KIO::Connection::qt_metacall (this=0xe462e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x24923e0) at ./connection.moc:79
#34 0x00007f5e8c067a5e in QObject::event (this=0xe462e0, e=<optimized out>) at kernel/qobject.cpp:1217
#35 0x00007f5e8a68b424 in notify_helper (e=0x24a2370, receiver=0xe462e0, this=0xc426e0) at kernel/qapplication.cpp:4486
#36 QApplicationPrivate::notify_helper (this=0xc426e0, receiver=0xe462e0, e=0x24a2370) at kernel/qapplication.cpp:4458
#37 0x00007f5e8a690291 in QApplication::notify (this=0x7fff8baed710, receiver=0xe462e0, e=0x24a2370) at kernel/qapplication.cpp:4365
#38 0x00007f5e8b86f126 in KApplication::notify (this=0x7fff8baed710, receiver=0xe462e0, event=0x24a2370) at ../../kdeui/kernel/kapplication.cpp:311
#39 0x00007f5e8c050afc in QCoreApplication::notifyInternal (this=0x7fff8baed710, receiver=0xe462e0, event=0x24a2370) at kernel/qcoreapplication.cpp:787
#40 0x00007f5e8c05451f in sendEvent (event=0x24a2370, receiver=0xe462e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xc17be0) at kernel/qcoreapplication.cpp:1428
#42 0x00007f5e8c07ba73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#44 0x00007f5e86733a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f5e86734258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f5e86734429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007f5e8c07bed6 in QEventDispatcherGlib::processEvents (this=0xc196f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#48 0x00007f5e8a73307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007f5e8c05492f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:979
#50 0x00007f5e8c7ddcf3 in QApt::CacheBuildProgress::Update (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:36
#51 0x00007f5e87c94020 in pkgDepCache::Update(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#52 0x00007f5e87c9923e in pkgDepCache::Init(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#53 0x00007f5e87cc31fd in pkgCacheFile::BuildDepCache(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#54 0x00007f5e87cc327a in pkgCacheFile::Open(OpProgress*, bool) () from /usr/lib/libapt-pkg.so.4.11
#55 0x00007f5e8c7ddab7 in QApt::Cache::open (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:85
#56 0x00007f5e8c7d8e22 in QApt::Backend::reloadCache (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/backend.cpp:184
#57 0x0000000000420dbb in ApplicationBackend::reload (this=0xe78610) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:118
#58 0x0000000000420ff5 in ApplicationBackend::workerEvent (this=0xe78610, event=<optimized out>) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:179
#59 0x000000000041c383 in ApplicationBackend::qt_metacall (this=0xe78610, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8baec890) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:113
#60 0x00007f5e8c063eba in QMetaObject::activate (sender=0xe54ee0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8baec890) at kernel/qobject.cpp:3278
#61 0x00007f5e8c7f3f41 in QApt::Backend::workerEvent (this=<optimized out>, _t1=QApt::CommitChangesFinished) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:244
#62 0x00007f5e8c7f419c in QApt::Backend::qt_metacall (this=0xe54ee0, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0x7fff8baec9a0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:204
#63 0x00007f5e8c063eba in QMetaObject::activate (sender=0xe0d180, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8baec9a0) at kernel/qobject.cpp:3278
#64 0x00007f5e8c7f4ae1 in OrgKubuntuQaptworkerInterface::workerEvent (this=<optimized out>, _t1=6) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:228
#65 0x00007f5e8c7f4ee5 in OrgKubuntuQaptworkerInterface::qt_metacall (this=0xe0d180, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fff8baece80) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:131
#66 0x00007f5e882060e9 in QDBusConnectionPrivate::deliverCall (this=0xe4ce30, object=0xe0d180, msg=..., metaTypes=..., slotIdx=13) at qdbusintegrator.cpp:942
#67 0x00007f5e8820f38f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#68 0x00007f5e8c067a5e in QObject::event (this=0xe0d180, e=<optimized out>) at kernel/qobject.cpp:1217
#69 0x00007f5e8a68b424 in notify_helper (e=0x2513890, receiver=0xe0d180, this=0xc426e0) at kernel/qapplication.cpp:4486
#70 QApplicationPrivate::notify_helper (this=0xc426e0, receiver=0xe0d180, e=0x2513890) at kernel/qapplication.cpp:4458
#71 0x00007f5e8a690291 in QApplication::notify (this=0x7fff8baed710, receiver=0xe0d180, e=0x2513890) at kernel/qapplication.cpp:4365
#72 0x00007f5e8b86f126 in KApplication::notify (this=0x7fff8baed710, receiver=0xe0d180, event=0x2513890) at ../../kdeui/kernel/kapplication.cpp:311
#73 0x00007f5e8c050afc in QCoreApplication::notifyInternal (this=0x7fff8baed710, receiver=0xe0d180, event=0x2513890) at kernel/qcoreapplication.cpp:787
#74 0x00007f5e8c05451f in sendEvent (event=0x2513890, receiver=0xe0d180) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#75 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xc17be0) at kernel/qcoreapplication.cpp:1428
#76 0x00007f5e8c07ba73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#77 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#78 0x00007f5e86733a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#79 0x00007f5e86734258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#80 0x00007f5e86734429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#81 0x00007f5e8c07bed6 in QEventDispatcherGlib::processEvents (this=0xc196f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#82 0x00007f5e8a73307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#83 0x00007f5e8c04fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#84 0x00007f5e8c04fef7 in QEventLoop::exec (this=0x7fff8baed6a0, flags=...) at kernel/qeventloop.cpp:201
#85 0x00007f5e8c054789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#86 0x000000000041bd67 in main (argc=5, argv=0x7fff8baed988) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Jonathan Thomas 2011-10-22 23:16:52 UTC

*** This bug has been marked as a duplicate of bug 283728 ***