Bug 284817 - Fail when download application
Summary: Fail when download application
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: 1.2.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-23 21:23 UTC by Zimennik
Modified: 2011-10-25 11:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zimennik 2011-10-23 21:23:22 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Just trying to download two application at once. _________

The crash does not seem to be reproducible.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7831930 (LWP 4510))]

Thread 2 (Thread 0xb55fcb70 (LWP 4514)):
#0  0x06a2056d in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x06a20c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x009deb37 in QEventDispatcherGlib::processEvents (this=0x82488e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0x009af1dd in QEventLoop::processEvents (this=0xb55fc2b0, flags=...) at kernel/qeventloop.cpp:149
#4  0x009af421 in QEventLoop::exec (this=0xb55fc2b0, flags=...) at kernel/qeventloop.cpp:201
#5  0x008b290b in QThread::exec (this=0x81fc738) at thread/qthread.cpp:498
#6  0x0098fe2d in QInotifyFileSystemWatcherEngine::run (this=0x81fc738) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x008b57b3 in QThreadPrivate::start (arg=0x81fc738) at thread/qthread_unix.cpp:331
#8  0x00b1bd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0x01fa70ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7831930 (LWP 4510)):
[KCrash Handler]
#7  same_key (key0=..., h0=346165, this=0x0) at /usr/include/qt4/QtCore/qhash.h:225
#8  QHash<QByteArray, QByteArray>::findNode (this=0x844839c, akey=..., ahp=0x0) at /usr/include/qt4/QtCore/qhash.h:885
#9  0x0805e7ab in value (akey=..., this=0x844839c) at /usr/include/qt4/QtCore/qhash.h:607
#10 Application::getField (this=0x8448398, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#11 0x0805f0d7 in Application::untranslatedName (this=0x8448398) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#12 0x0805f29d in Application::name (this=0x8448398) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#13 0x08083b74 in ReviewsBackend::reviewsFetched (this=0x821bee8, job=0x9a0aec0) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#14 0x0805e465 in ReviewsBackend::qt_metacall (this=0x821bee8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9c5d58) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#15 0x009b6b7d in metacall (argv=0xbf9c5d58, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x821bee8) at kernel/qmetaobject.cpp:237
#16 QMetaObject::metacall (object=0x821bee8, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbf9c5d58) at kernel/qmetaobject.cpp:232
#17 0x009c5a6a in QMetaObject::activate (sender=0x9a0aec0, m=0xe4a58c, local_signal_index=3, argv=0xbf9c5d58) at kernel/qobject.cpp:3278
#18 0x00c9ca05 in KJob::result (this=0x9a0aec0, _t1=0x9a0aec0) at ./kjob.moc:194
#19 0x00c9ca58 in KJob::emitResult (this=0x9a0aec0) at ../../kdecore/jobs/kjob.cpp:312
#20 0x0056f05c in KIO::FileCopyJob::slotResult (this=0x9a0aec0, job=0x97247c0) at ../../kio/kio/job.cpp:2440
#21 0x0056eded in KIO::FileCopyJob::qt_metacall (this=0x9a0aec0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9c5ed8) at ./jobclasses.moc:724
#22 0x009b6b7d in metacall (argv=0xbf9c5ed8, idx=32, cl=QMetaObject::InvokeMetaMethod, object=0x9a0aec0) at kernel/qmetaobject.cpp:237
#23 QMetaObject::metacall (object=0x9a0aec0, cl=QMetaObject::InvokeMetaMethod, idx=32, argv=0xbf9c5ed8) at kernel/qmetaobject.cpp:232
#24 0x009c5a6a in QMetaObject::activate (sender=0x97247c0, m=0xe4a58c, local_signal_index=3, argv=0xbf9c5ed8) at kernel/qobject.cpp:3278
#25 0x00c9ca05 in KJob::result (this=0x97247c0, _t1=0x97247c0) at ./kjob.moc:194
#26 0x00c9ca58 in KJob::emitResult (this=0x97247c0) at ../../kdecore/jobs/kjob.cpp:312
#27 0x00566738 in KIO::SimpleJob::slotFinished (this=0x97247c0) at ../../kio/kio/job.cpp:494
#28 0x0056f2bd in KIO::TransferJob::slotFinished (this=0x97247c0) at ../../kio/kio/job.cpp:1081
#29 0x0056d8f4 in KIO::TransferJob::qt_metacall (this=0x97247c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9c6174) at ./jobclasses.moc:369
#30 0x009b6b7d in metacall (argv=0xbf9c6174, idx=47, cl=QMetaObject::InvokeMetaMethod, object=0x97247c0) at kernel/qmetaobject.cpp:237
#31 QMetaObject::metacall (object=0x97247c0, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbf9c6174) at kernel/qmetaobject.cpp:232
#32 0x009c5a6a in QMetaObject::activate (sender=0x8b09b20, m=0x7416a0, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3278
#33 0x00621b95 in KIO::SlaveInterface::finished (this=0x8b09b20) at ./slaveinterface.moc:171
#34 0x00624a19 in KIO::SlaveInterface::dispatch (this=0x8b09b20, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#35 0x0062117a in KIO::SlaveInterface::dispatch (this=0x8b09b20) at ../../kio/kio/slaveinterface.cpp:88
#36 0x006127a8 in KIO::Slave::gotInput (this=0x8b09b20) at ../../kio/kio/slave.cpp:344
#37 0x0061301c in KIO::Slave::qt_metacall (this=0x8b09b20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9c6454) at ./slave.moc:82
#38 0x009b6b7d in metacall (argv=0xbf9c6454, idx=30, cl=QMetaObject::InvokeMetaMethod, object=0x8b09b20) at kernel/qmetaobject.cpp:237
#39 QMetaObject::metacall (object=0x8b09b20, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbf9c6454) at kernel/qmetaobject.cpp:232
#40 0x009c5a6a in QMetaObject::activate (sender=0x902bb80, m=0x73e508, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#41 0x00531cd5 in KIO::Connection::readyRead (this=0x902bb80) at ./connection.moc:92
#42 0x0053250a in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#43 KIO::ConnectionPrivate::dequeue (this=0x84ffeb0) at ../../kio/kio/connection.cpp:71
#44 0x005325df in KIO::Connection::qt_metacall (this=0x902bb80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x8a42a40) at ./connection.moc:79
#45 0x009b6b7d in metacall (argv=0x8a42a40, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x902bb80) at kernel/qmetaobject.cpp:237
#46 QMetaObject::metacall (object=0x902bb80, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0x8a42a40) at kernel/qmetaobject.cpp:232
#47 0x009c1685 in QMetaCallEvent::placeMetaCall (this=0x8c2e678, object=0x902bb80) at kernel/qobject.cpp:535
#48 0x009c8b52 in QObject::event (this=0x902bb80, e=0x8c2e678) at kernel/qobject.cpp:1217
#49 0x04b4bd54 in notify_helper (e=0x8c2e678, receiver=0x902bb80, this=0x80c3868) at kernel/qapplication.cpp:4486
#50 QApplicationPrivate::notify_helper (this=0x80c3868, receiver=0x902bb80, e=0x8c2e678) at kernel/qapplication.cpp:4458
#51 0x04b51103 in QApplication::notify (this=0x8c2e678, receiver=0x902bb80, e=0x8c2e678) at kernel/qapplication.cpp:3886
#52 0x01136721 in KApplication::notify (this=0xbf9c8280, receiver=0x902bb80, event=0x8c2e678) at ../../kdeui/kernel/kapplication.cpp:311
#53 0x009b019e in QCoreApplication::notifyInternal (this=0xbf9c8280, receiver=0x902bb80, event=0x8c2e678) at kernel/qcoreapplication.cpp:787
#54 0x009b3f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80a5300) at kernel/qcoreapplication.cpp:1428
#56 0x009b40ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#57 0x009de6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#58 postEventSourceDispatch (s=0x80cab70) at kernel/qeventdispatcher_glib.cpp:277
#59 0x06a2025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#60 0x06a20990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#61 0x06a20c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#62 0x009deada in QEventDispatcherGlib::processEvents (this=0x80a6238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#63 0x04c03e3a in QGuiEventDispatcherGlib::processEvents (this=0x80a6238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#64 0x009b4383 in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:979
#65 0x00b605c3 in QApt::CacheBuildProgress::Update (this=0x82488a4) at /build/buildd/qapt-1.2.1/src/cache.cpp:36
#66 0x070d0216 in OpProgress::Progress(unsigned long) () from /usr/lib/libapt-pkg.so.4.11
#67 0x070ebd1f in pkgDepCache::Init(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#68 0x07117e69 in pkgCacheFile::BuildDepCache(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#69 0x07117f04 in pkgCacheFile::Open(OpProgress*, bool) () from /usr/lib/libapt-pkg.so.4.11
#70 0x00b6033d in QApt::Cache::open (this=0x81c5ab8) at /build/buildd/qapt-1.2.1/src/cache.cpp:85
#71 0x00b5b10a in QApt::Backend::reloadCache (this=0x81bdab8) at /build/buildd/qapt-1.2.1/src/backend.cpp:184
#72 0x080630cb in ApplicationBackend::reload (this=0x8120b78) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:118
#73 0x08063385 in ApplicationBackend::workerEvent (this=0x8120b78, event=QApt::CommitChangesFinished) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:179
#74 0x0805e23d in ApplicationBackend::qt_metacall (this=0x8120b78, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9c77c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:113
#75 0x009b6b7d in metacall (argv=0xbf9c77c8, idx=16, cl=QMetaObject::InvokeMetaMethod, object=0x8120b78) at kernel/qmetaobject.cpp:237
#76 QMetaObject::metacall (object=0x8120b78, cl=QMetaObject::InvokeMetaMethod, idx=16, argv=0xbf9c77c8) at kernel/qmetaobject.cpp:232
#77 0x009c5a6a in QMetaObject::activate (sender=0x81bdab8, m=0xb87cb8, local_signal_index=4, argv=0xbf9c77c8) at kernel/qobject.cpp:3278
#78 0x00b77c65 in QApt::Backend::workerEvent (this=0x81bdab8, _t1=QApt::CommitChangesFinished) at /build/buildd/qapt-1.2.1/obj-i686-linux-gnu/src/moc_backend.cxx:244
#79 0x00b54789 in QApt::Backend::emitWorkerEvent (this=0x81bdab8, event=6) at /build/buildd/qapt-1.2.1/src/backend.cpp:1323
#80 0x00b77f6e in QApt::Backend::qt_metacall (this=0x81bdab8, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0xbf9c7908) at /build/buildd/qapt-1.2.1/obj-i686-linux-gnu/src/moc_backend.cxx:204
#81 0x009b6b7d in metacall (argv=0xbf9c7908, idx=44, cl=QMetaObject::InvokeMetaMethod, object=0x81bdab8) at kernel/qmetaobject.cpp:237
#82 QMetaObject::metacall (object=0x81bdab8, cl=QMetaObject::InvokeMetaMethod, idx=44, argv=0xbf9c7908) at kernel/qmetaobject.cpp:232
#83 0x009c5a6a in QMetaObject::activate (sender=0x820a728, m=0xb87e38, local_signal_index=8, argv=0xbf9c7908) at kernel/qobject.cpp:3278
#84 0x00b78cb5 in OrgKubuntuQaptworkerInterface::workerEvent (this=0x820a728, _t1=6) at /build/buildd/qapt-1.2.1/obj-i686-linux-gnu/src/workerdbus.moc:228
#85 0x00b791af in OrgKubuntuQaptworkerInterface::qt_metacall (this=0x820a728, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf9c7b4c) at /build/buildd/qapt-1.2.1/obj-i686-linux-gnu/src/workerdbus.moc:131
#86 0x0767ed87 in QDBusConnectionPrivate::deliverCall (this=0x8200ea0, object=0x820a728, msg=..., metaTypes=..., slotIdx=0) at qdbusintegrator.cpp:942
#87 0x07688c26 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8a03e70, object=0x820a728) at qdbusintegrator_p.h:103
#88 0x009c8b52 in QObject::event (this=0x820a728, e=0x8a03e70) at kernel/qobject.cpp:1217
#89 0x04b4bd54 in notify_helper (e=0x8a03e70, receiver=0x820a728, this=0x80c3868) at kernel/qapplication.cpp:4486
#90 QApplicationPrivate::notify_helper (this=0x80c3868, receiver=0x820a728, e=0x8a03e70) at kernel/qapplication.cpp:4458
#91 0x04b51103 in QApplication::notify (this=0x8a03e70, receiver=0x820a728, e=0x8a03e70) at kernel/qapplication.cpp:3886
#92 0x01136721 in KApplication::notify (this=0xbf9c8280, receiver=0x820a728, event=0x8a03e70) at ../../kdeui/kernel/kapplication.cpp:311
#93 0x009b019e in QCoreApplication::notifyInternal (this=0xbf9c8280, receiver=0x820a728, event=0x8a03e70) at kernel/qcoreapplication.cpp:787
#94 0x009b3f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#95 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80a5300) at kernel/qcoreapplication.cpp:1428
#96 0x009b40ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#97 0x009de6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#98 postEventSourceDispatch (s=0x80cab70) at kernel/qeventdispatcher_glib.cpp:277
#99 0x06a2025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#100 0x06a20990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#101 0x06a20c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#102 0x009deada in QEventDispatcherGlib::processEvents (this=0x80a6238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#103 0x04c03e3a in QGuiEventDispatcherGlib::processEvents (this=0x80a6238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#104 0x009af1dd in QEventLoop::processEvents (this=0xbf9c81e4, flags=...) at kernel/qeventloop.cpp:149
#105 0x009af421 in QEventLoop::exec (this=0xbf9c81e4, flags=...) at kernel/qeventloop.cpp:201
#106 0x009b419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#107 0x04b498f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#108 0x0805db86 in main (argc=304367761, argv=0x19) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Jonathan Thomas 2011-10-25 11:15:27 UTC

*** This bug has been marked as a duplicate of bug 283728 ***