Bug 293261 - Kontact crashes when opening email
Summary: Kontact crashes when opening email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 01:13 UTC by Donald J. Stewart
Modified: 2012-02-04 08:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Donald J. Stewart 2012-02-04 01:13:48 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.6-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

opening a link from Kontact -- started to bring up Konqueror, and crashed...

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb35550d760 (LWP 30220))]

Thread 3 (Thread 0x7fb33e005700 (LWP 30221)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb351d0a1c4 in scavengerThread (this=0x7fb3526f3100) at wtf/FastMalloc.cpp:2495
#2  WTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fb3526f3100) at wtf/FastMalloc.cpp:1618
#3  0x00007fb34d32eccc in start_thread (arg=0x7fb33e005700) at pthread_create.c:301
#4  0x00007fb352a4807d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fb33d704700 (LWP 30222)):
#0  0x00007fff7d5ff8de in ?? ()
#1  0x00007fb34c8767c3 in *__GI_clock_gettime (clock_id=1, tp=0x7fb33d703b60) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007fb353d7c502 in do_gettime (frac=<optimized out>, sec=<optimized out>) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fb353e5284d in QTimerInfoList::updateCurrentTime (this=0x9b0860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fb353e52b95 in QTimerInfoList::timerWait (this=0x9b0860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fb353e5166c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fb33d703c8c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fb353e5170d in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fb34c596e06 in g_main_context_prepare (context=0x9af130, priority=0x7fb33d703cfc) at gmain.c:2762
#9  0x00007fb34c597bf9 in g_main_context_iterate (context=0x9af130, block=1, dispatch=1, self=<optimized out>) at gmain.c:3069
#10 0x00007fb34c598221 in g_main_context_iteration (context=0x9af130, may_block=1) at gmain.c:3152
#11 0x00007fb353e51ec6 in QEventDispatcherGlib::processEvents (this=0x9af050, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fb353e22752 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fb353e22a05 in QEventLoop::exec (this=0x7fb33d703e20, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fb353d22d15 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007fb353d25327 in QThreadPrivate::start (arg=0x9ae890) at thread/qthread_unix.cpp:298
#16 0x00007fb34d32eccc in start_thread (arg=0x7fb33d704700) at pthread_create.c:301
#17 0x00007fb352a4807d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fb35550d760 (LWP 30220)):
[KCrash Handler]
#6  0x00007fb34e2640cb in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x298ee90, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fb34e2e5395 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x298ee90, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fb353e37f7e in QObject::event (this=0x298ee90, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fb3531ce014 in QApplicationPrivate::notify_helper (this=0x7feb50, receiver=0x298ee90, e=0x24e3ca0) at kernel/qapplication.cpp:4550
#10 0x00007fb3531d2b7f in QApplication::notify (this=<optimized out>, receiver=0x298ee90, e=0x24e3ca0) at kernel/qapplication.cpp:4411
#11 0x00007fb3548b5376 in KApplication::notify (this=0x7fff7d5aafa0, receiver=0x298ee90, event=0x24e3ca0) at /var/tmp/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/kdeui/kernel/kapplication.cpp:311
#12 0x00007fb353e236e3 in QCoreApplication::notifyInternal (this=0x7fff7d5aafa0, receiver=0x298ee90, event=0x24e3ca0) at kernel/qcoreapplication.cpp:876
#13 0x00007fb353e26c0f in sendEvent (event=0x24e3ca0, receiver=0x298ee90) at kernel/qcoreapplication.h:231
#14 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x7d3670) at kernel/qcoreapplication.cpp:1500
#15 0x00007fb353e51ce3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#17 0x00007fb34c597862 in g_main_dispatch (context=0x7ffc20) at gmain.c:2441
#18 g_main_context_dispatch (context=0x7ffc20) at gmain.c:3011
#19 0x00007fb34c598040 in g_main_context_iterate (context=0x7ffc20, block=1, dispatch=1, self=<optimized out>) at gmain.c:3089
#20 0x00007fb34c598221 in g_main_context_iteration (context=0x7ffc20, may_block=1) at gmain.c:3152
#21 0x00007fb353e51e6f in QEventDispatcherGlib::processEvents (this=0x7fe730, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fb353271c3e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fb353e22752 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fb353e22a05 in QEventLoop::exec (this=0x7fff7d5aaef0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fb353e27093 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000404497 in main (argc=1, argv=0x7fff7d5ab5c8) at /var/tmp/portage/kde-base/kontact-4.8.0/work/kontact-4.8.0/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 293003, bug 292815, bug 292500, bug 289879, bug 288942.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-02-04 08:59:57 UTC
Please look at in bug report already reported.
it's duplicate.

*** This bug has been marked as a duplicate of bug 286307 ***