Bug 293003 - Kontact / kmail 4.8 crash when changing inbox directory
Summary: Kontact / kmail 4.8 crash when changing inbox directory
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 21:32 UTC by Denny
Modified: 2012-01-31 22:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denny 2012-01-31 21:32:21 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 "release 462"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I finished reading new emails in one inbox and switching to the next inbox with new emails.

- Unusual behavior I noticed:
nothing really. Was using the app the usual way.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f02f89e6760 (LWP 7716))]

Thread 8 (Thread 0x7f02e03a9700 (LWP 7718)):
#0  0x00007f02f0872e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f02f51fec12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f02f51fec49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f02f086ef05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f02f5eee63d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f02dfa90700 (LWP 7719)):
#0  0x00007f02f5ee5523 in poll () from /lib64/libc.so.6
#1  0x00007f02f035fa98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f02f035ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f02f665c956 in QEventDispatcherGlib::processEvents (this=0x7f02d80008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f02f662c682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f02f662c8d7 in QEventLoop::exec (this=0x7f02dfa8fe20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f02f652d537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f02f653055b in QThreadPrivate::start (arg=0x7c5610) at thread/qthread_unix.cpp:298
#8  0x00007f02f086ef05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f02f5eee63d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f0292377700 (LWP 9018)):
#0  0x00007f02f08731eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f02f65309cf in wait (time=30000, this=0x11e22a0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x11e2218, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f02f6523ddf in QThreadPoolThread::run (this=0x1207570) at concurrent/qthreadpool.cpp:141
#4  0x00007f02f653055b in QThreadPrivate::start (arg=0x1207570) at thread/qthread_unix.cpp:298
#5  0x00007f02f086ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f02f5eee63d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f027096e700 (LWP 9020)):
#0  0x00007f02f08731eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f02f65309cf in wait (time=30000, this=0x3ad28f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x3adada8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f02f6523ddf in QThreadPoolThread::run (this=0x3ab4620) at concurrent/qthreadpool.cpp:141
#4  0x00007f02f653055b in QThreadPrivate::start (arg=0x3ab4620) at thread/qthread_unix.cpp:298
#5  0x00007f02f086ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f02f5eee63d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f0290b61700 (LWP 9024)):
#0  0x00007f02f08731eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f02f65309cf in wait (time=30000, this=0x7f02800060c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f0280006068, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f02f6523ddf in QThreadPoolThread::run (this=0x7f028000a320) at concurrent/qthreadpool.cpp:141
#4  0x00007f02f653055b in QThreadPrivate::start (arg=0x7f028000a320) at thread/qthread_unix.cpp:298
#5  0x00007f02f086ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f02f5eee63d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f02895bb700 (LWP 9026)):
#0  0x00007f02f08731eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f02f65309cf in wait (time=30000, this=0x7f02800060c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f0280006068, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f02f6523ddf in QThreadPoolThread::run (this=0x7f0280006340) at concurrent/qthreadpool.cpp:141
#4  0x00007f02f653055b in QThreadPrivate::start (arg=0x7f0280006340) at thread/qthread_unix.cpp:298
#5  0x00007f02f086ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f02f5eee63d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f027016d700 (LWP 9028)):
#0  0x00007f02f08731eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f02f65309cf in wait (time=30000, this=0x7f02800060c0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f0280006068, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f02f6523ddf in QThreadPoolThread::run (this=0x7f028c4104f0) at concurrent/qthreadpool.cpp:141
#4  0x00007f02f653055b in QThreadPrivate::start (arg=0x7f028c4104f0) at thread/qthread_unix.cpp:298
#5  0x00007f02f086ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f02f5eee63d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f02f89e6760 (LWP 7716)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x58034f0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f02f1839379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x58034f0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f02f6646926 in QObject::event (this=0x58034f0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f02f7040e84 in notify_helper (e=0x7f02780128a0, receiver=0x58034f0, this=0x63e200) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x63e200, receiver=0x58034f0, e=0x7f02780128a0) at kernel/qapplication.cpp:4522
#11 0x00007f02f7045d03 in QApplication::notify (this=0x7fff8afd0600, receiver=0x58034f0, e=0x7f02780128a0) at kernel/qapplication.cpp:4411
#12 0x00007f02f7d84786 in KApplication::notify (this=0x7fff8afd0600, receiver=0x58034f0, event=0x7f02780128a0) at /usr/src/debug/kdelibs-4.8.0/kdeui/kernel/kapplication.cpp:311
#13 0x00007f02f662d89c in QCoreApplication::notifyInternal (this=0x7fff8afd0600, receiver=0x58034f0, event=0x7f02780128a0) at kernel/qcoreapplication.cpp:876
#14 0x00007f02f663113a in sendEvent (event=0x7f02780128a0, receiver=0x58034f0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#16 0x00007f02f665c4c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f02f035f58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f02f035fd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f02f035ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f02f665c8ef in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f02f70e42de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f02f662c682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f02f662c8d7 in QEventLoop::exec (this=0x7fff8afd0590, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f02f6631435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007f02f5e3623d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 292815, bug 292500, bug 289879, bug 288942, bug 288935.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-01-31 22:59:38 UTC

*** This bug has been marked as a duplicate of bug 286307 ***