Bug 292815 - kontakt crashes
Summary: kontakt crashes
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-29 17:57 UTC by rudolfwetzels
Modified: 2012-01-31 15:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.17 KB, text/plain)
2012-01-29 18:57 UTC, rudolfwetzels
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rudolfwetzels 2012-01-29 17:57:48 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 "release 462" (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I opened a gelöcht mails and then, after holes because if the program is to open the next mail it from crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fadeaf46760 (LWP 3289))]

Thread 9 (Thread 0x7fadd2e5d700 (LWP 3290)):
#0  0x00007fade2dd4e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fade7760c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fade7760c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fade2dd0f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fade845063d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fadd2544700 (LWP 3291)):
#0  0x00007fade8447523 in poll () from /lib64/libc.so.6
#1  0x00007fade28c1a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fade28c1f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fade8bbe956 in QEventDispatcherGlib::processEvents (this=0x7fadcc0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fade8b8e682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fade8b8e8d7 in QEventLoop::exec (this=0x7fadd2543e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fade8a8f537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fade8a9255b in QThreadPrivate::start (arg=0x7b9990) at thread/qthread_unix.cpp:298
#8  0x00007fade2dd0f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fade845063d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fad853ae700 (LWP 3295)):
#0  0x00007fade2dd51eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fade8a929cf in wait (time=30000, this=0xd2e4f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xd2e468, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fade8a85ddf in QThreadPoolThread::run (this=0xd41870) at concurrent/qthreadpool.cpp:141
#4  0x00007fade8a9255b in QThreadPrivate::start (arg=0xd41870) at thread/qthread_unix.cpp:298
#5  0x00007fade2dd0f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fade845063d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fad7fdf0700 (LWP 3302)):
#0  0x00007fade2dd51eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fade8a929cf in wait (time=30000, this=0x11ae900) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x10f6ed8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fade8a85ddf in QThreadPoolThread::run (this=0x1113540) at concurrent/qthreadpool.cpp:141
#4  0x00007fade8a9255b in QThreadPrivate::start (arg=0x1113540) at thread/qthread_unix.cpp:298
#5  0x00007fade2dd0f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fade845063d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fad7df7c700 (LWP 3305)):
#0  0x00007fade2dd51eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fade8a929cf in wait (time=30000, this=0x7fad700060f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fad70006098, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fade8a85ddf in QThreadPoolThread::run (this=0x7fad70006340) at concurrent/qthreadpool.cpp:141
#4  0x00007fade8a9255b in QThreadPrivate::start (arg=0x7fad70006340) at thread/qthread_unix.cpp:298
#5  0x00007fade2dd0f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fade845063d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fad7cc71700 (LWP 3308)):
#0  0x00007fade2dd51eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fade8a929cf in wait (time=30000, this=0x7fad700060f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fad70006098, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fade8a85ddf in QThreadPoolThread::run (this=0x7fad7000a260) at concurrent/qthreadpool.cpp:141
#4  0x00007fade8a9255b in QThreadPrivate::start (arg=0x7fad7000a260) at thread/qthread_unix.cpp:298
#5  0x00007fade2dd0f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fade845063d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fad6ffff700 (LWP 3319)):
#0  0x00007fade2dd51eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fade8a929cf in wait (time=30000, this=0x7fad700060f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fad70006098, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fade8a85ddf in QThreadPoolThread::run (this=0x7fad70008970) at concurrent/qthreadpool.cpp:141
#4  0x00007fade8a9255b in QThreadPrivate::start (arg=0x7fad70008970) at thread/qthread_unix.cpp:298
#5  0x00007fade2dd0f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fade845063d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fad6f7fe700 (LWP 3336)):
#0  0x00007fade2dd51eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fade8a929cf in wait (time=30000, this=0x7fad700060f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fad70006098, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fade8a85ddf in QThreadPoolThread::run (this=0x7fad70014a40) at concurrent/qthreadpool.cpp:141
#4  0x00007fade8a9255b in QThreadPrivate::start (arg=0x7fad70014a40) at thread/qthread_unix.cpp:298
#5  0x00007fade2dd0f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fade845063d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fadeaf46760 (LWP 3289)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x1e84360, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fade3d9b379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x1e84360, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fade8ba8926 in QObject::event (this=0x1e84360, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007fade95a2e84 in notify_helper (e=0x7fad7000f1d0, receiver=0x1e84360, this=0x639620) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x639620, receiver=0x1e84360, e=0x7fad7000f1d0) at kernel/qapplication.cpp:4522
#11 0x00007fade95a7d03 in QApplication::notify (this=0x7fffcc7bef00, receiver=0x1e84360, e=0x7fad7000f1d0) at kernel/qapplication.cpp:4411
#12 0x00007fadea2e6786 in KApplication::notify (this=0x7fffcc7bef00, receiver=0x1e84360, event=0x7fad7000f1d0) at /usr/src/debug/kdelibs-4.8.0/kdeui/kernel/kapplication.cpp:311
#13 0x00007fade8b8f89c in QCoreApplication::notifyInternal (this=0x7fffcc7bef00, receiver=0x1e84360, event=0x7fad7000f1d0) at kernel/qcoreapplication.cpp:876
#14 0x00007fade8b9313a in sendEvent (event=0x7fad7000f1d0, receiver=0x1e84360) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#16 0x00007fade8bbe4c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fade28c158d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007fade28c1d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007fade28c1f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fade8bbe8ef in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fade96462de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fade8b8e682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fade8b8e8d7 in QEventLoop::exec (this=0x7fffcc7bee90, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fade8b93435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007fade839823d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 292500, bug 289879, bug 288942, bug 288935, bug 288604.

Reported using DrKonqi
Comment 1 rudolfwetzels 2012-01-29 18:57:45 UTC
Created attachment 68310 [details]
New crash information added by DrKonqi

kontact (4.8.0) on KDE Platform 4.8.00 (4.8.0 "release 462" using Qt 4.8.0

- What I was doing when the application crashed:Open the mail from a contact locks up. Lidl advertising.

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x13434e0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f6b6917f379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x13434e0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f6b6df8c926 in QObject::event (this=0x13434e0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f6b6e986e84 in notify_helper (e=0x7f6af4020600, receiver=0x13434e0, this=0x639620) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x639620, receiver=0x13434e0, e=0x7f6af4020600) at kernel/qapplication.cpp:4522
Comment 2 Christophe Giboudeaux 2012-01-31 15:05:57 UTC

*** This bug has been marked as a duplicate of bug 286307 ***