Bug 293320 - Amarok doesn't scrobble long songs between albums
Summary: Amarok doesn't scrobble long songs between albums
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Services/Last.fm (show other bugs)
Version: 2.5.0
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 20:06 UTC by johannesmyth
Modified: 2012-11-21 23:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johannesmyth 2012-02-04 20:06:51 UTC
Version:           2.5.0 (using KDE 4.8.0) 
OS:                Linux

When the last song of an album or the first song of the next album is long (7 minutes or more), the scrobbler ignores either, despite the "playing now" in the profile page.

Reproducible: Always

Steps to Reproduce:
1. Pick two songs longer than 7 minutes from different albums
2. Play till the end
3. See one of them not scrobbled
4. Rage

Actual Results:  
Long songs being ignored

Expected Results:  
All songs must be scrobbled regardless

Using phonon-backend-gstreamer; didn't test with the VLC backend.

Amarok also doesn't send the "playing now" data when two long songs from the same album are played consecutively (both are scrobbled; one unnoticed). Tried to start over with new config files and a new database (rm -rf ~/.kde4/share/apps/amarok) to no avail.
Comment 1 Matěj Laitl 2012-11-21 23:19:04 UTC
Git commit 2fc6c25ee0f2eff758432c101ff82c87bc04a9e8 by Matěj Laitl.
Committed on 16/11/2012 at 19:03.
Pushed by laitl into branch 'master'.

StatSyncing: ChangeLog and BUG: tags for the final merge

This is a cummulative ChangeLog for my GSoC 2012 project, statistics
synchronization.

Individual commits responsible for the changes are earlier, but under
the same git merge.

FEATURES:
  * Track dragging support in Unique Tracks tab of the Synchronize Statistics action;
    allows you to do a "diff" between collections and transfer missing tracks.
  * Amarok now scrobbles tracks in streams if the stream correctly updates
    meta-data.
  * When scrobbling to Last.fm, Amarok announces suggested tag corrections.
  * Ability to scrobble recently played tracks from iPod (and the like) to Last.fm.
  * Synchronization of labels and rating between Last.fm and Amarok collections;
    play count can be synchronized one-way from Last.fm to Amarok.
  * Statistics synchronization between collections, supports rating, first / last
    played time, play count and labels.

CHANGES:
  * Configure Amarok dialog gets new Metadata tab to grab some weight from the
    Collection tab and to configure statistics synchronization.

BUGFIXES:
  * Better Last.fm scrobbling behaviour and error reporting due to rewrite,
    should fix long-standing problems.
  * Update stream meta-data correctly even with phonon-gstreamer back-end.
Related: bug 240732, bug 309697, bug 206249, bug 285820
FIXED-IN: 2.7
DIGEST: Amarok statistics synchronization GSoC project merged with many features
        and improvements, please see http://strohel.blogspot.com/search/label/gsoc
        for more info and a bunch of screen shots.
GUI: Added statistics synchronization dialogs, split and one more config dialog tab

M  +15   -0    ChangeLog

http://commits.kde.org/amarok/2fc6c25ee0f2eff758432c101ff82c87bc04a9e8