Bug 240732 - Scrobbling behavior inconstent for streamed and saved podcasts
Summary: Scrobbling behavior inconstent for streamed and saved podcasts
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Services/Last.fm (show other bugs)
Version: 2.4.1
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-04 15:51 UTC by Andreas Ermler
Modified: 2012-11-21 23:19 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Ermler 2010-06-04 15:51:20 UTC
Version:           2.3.1 (using KDE 4.4.3) 
OS:                Linux

The last.fm scrobbling behavior is inconsistent for streamed and saved podcasts. If the podcast is saved on downloaded and then played it it submitted to last.fm, if it is streamed it's not.

Reproducible: Didn't try

Steps to Reproduce:
- Activate last.fm service with "Submit tracks"
- Subscribe to podcast
- Play episode without downloading
- Download episode and play

Actual Results:  
Streamed episode is not submitted to last.fm, downloaded episode is submitted.

Expected Results:  
Either both should be submitted or none of the two. The desired behavior is a different issue, maybe it could be an option.
Comment 1 Myriam Schweingruber 2011-05-07 09:39:50 UTC
Could you please test with a newer Amarok version? Current is Amarok 2.4.0 and 2.4.1 is to be released tomorrow.
Comment 2 Myriam Schweingruber 2011-06-16 14:14:49 UTC
Any news on this? Without feedback within 2 weeks I will close this as solved.
Comment 3 Andreas Ermler 2011-06-16 14:54:19 UTC
Sorry, can't test this right now, don't have an internet connection at home where I use Amarok. Will be able to test it in the beginning of July.
Comment 4 Myriam Schweingruber 2011-06-16 15:36:58 UTC
Thank you for the fast feedback :) I will leave this open for now then.
Comment 5 Andreas Ermler 2011-07-02 20:45:22 UTC
Okay, I tested it [with this podcast: http://podcast.wdr.de/radio/wdr2kabarett.xml] and Amarok 2.4.1, my results:
- Download and playing: Episode is added to last.fm
- Streaming: When I start playing the episode it's appearing on last.fm, but just for around 30 seconds, after that it disappears and even when it finished playing it's not added to last.fm
So, the behavior is still inconsistent.
Comment 6 Myriam Schweingruber 2011-07-03 19:02:50 UTC
Thank you for the feedback.
Comment 7 Matěj Laitl 2012-11-21 23:19:01 UTC
Git commit 2fc6c25ee0f2eff758432c101ff82c87bc04a9e8 by Matěj Laitl.
Committed on 16/11/2012 at 19:03.
Pushed by laitl into branch 'master'.

StatSyncing: ChangeLog and BUG: tags for the final merge

This is a cummulative ChangeLog for my GSoC 2012 project, statistics
synchronization.

Individual commits responsible for the changes are earlier, but under
the same git merge.

FEATURES:
  * Track dragging support in Unique Tracks tab of the Synchronize Statistics action;
    allows you to do a "diff" between collections and transfer missing tracks.
  * Amarok now scrobbles tracks in streams if the stream correctly updates
    meta-data.
  * When scrobbling to Last.fm, Amarok announces suggested tag corrections.
  * Ability to scrobble recently played tracks from iPod (and the like) to Last.fm.
  * Synchronization of labels and rating between Last.fm and Amarok collections;
    play count can be synchronized one-way from Last.fm to Amarok.
  * Statistics synchronization between collections, supports rating, first / last
    played time, play count and labels.

CHANGES:
  * Configure Amarok dialog gets new Metadata tab to grab some weight from the
    Collection tab and to configure statistics synchronization.

BUGFIXES:
  * Better Last.fm scrobbling behaviour and error reporting due to rewrite,
    should fix long-standing problems.
  * Update stream meta-data correctly even with phonon-gstreamer back-end.
Related: bug 309697, bug 206249, bug 293320, bug 285820
FIXED-IN: 2.7
DIGEST: Amarok statistics synchronization GSoC project merged with many features
        and improvements, please see http://strohel.blogspot.com/search/label/gsoc
        for more info and a bunch of screen shots.
GUI: Added statistics synchronization dialogs, split and one more config dialog tab

M  +15   -0    ChangeLog

http://commits.kde.org/amarok/2fc6c25ee0f2eff758432c101ff82c87bc04a9e8