Bug 206249 - Statistics Synchronization from Last.fm to Amarok
Summary: Statistics Synchronization from Last.fm to Amarok
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Services/Last.fm (show other bugs)
Version: 2.6.0
Platform: Gentoo Packages Linux
: NOR wishlist with 80 votes (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords:
: 214775 244585 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-04 14:31 UTC by optiluca@gmail.com
Modified: 2012-11-21 23:19 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description optiluca@gmail.com 2009-09-04 14:31:58 UTC
Version:           2.1.1 (using KDE 4.3.0)
OS:                Linux
Installed from:    Gentoo Packages

Hi.  I have been using Amarok 2.x for the past months, and a selection of bugs (which are luckily being addressed for 2.2 from what I understand) has rendered my statistics completely useless, as I've had to wipe the database numerous times.  The only place where an accurate collection of stats exists is last.fm, which I have been using since Amarok 1.4.x. Would it be possible to implement a "reverse scrobbling" feature, where last.fm stats are transferred to amarok's database?  I have found a script that used to do this on Amarok 1.4 http://kde-apps.org/content/show.php/Last+Sync?content=65784, so I know it is technically viable.  An option could be added to the "import collection" button, in addition to Amarok 1.4 and iTunes.

Thanks in Advance

Luca
Comment 1 Myriam Schweingruber 2010-09-15 19:26:46 UTC
*** Bug 244585 has been marked as a duplicate of this bug. ***
Comment 2 Mieszko Ślusarczyk 2010-12-30 15:46:29 UTC
It would be really nice to sync statisctics with last.fm.
In my example last.fm represents my playcount at best;)
Comment 3 Felis 2011-09-01 18:57:21 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Matěj Laitl 2012-10-15 11:57:14 UTC
Implemented by my GSoC [1], to be merged soon to Amarok master for 2.7.

[1] http://strohel.blogspot.com/search/label/gsoc
Comment 5 Matěj Laitl 2012-11-05 23:48:34 UTC
*** Bug 214775 has been marked as a duplicate of this bug. ***
Comment 6 Matěj Laitl 2012-11-21 23:19:01 UTC
Git commit 2fc6c25ee0f2eff758432c101ff82c87bc04a9e8 by Matěj Laitl.
Committed on 16/11/2012 at 19:03.
Pushed by laitl into branch 'master'.

StatSyncing: ChangeLog and BUG: tags for the final merge

This is a cummulative ChangeLog for my GSoC 2012 project, statistics
synchronization.

Individual commits responsible for the changes are earlier, but under
the same git merge.

FEATURES:
  * Track dragging support in Unique Tracks tab of the Synchronize Statistics action;
    allows you to do a "diff" between collections and transfer missing tracks.
  * Amarok now scrobbles tracks in streams if the stream correctly updates
    meta-data.
  * When scrobbling to Last.fm, Amarok announces suggested tag corrections.
  * Ability to scrobble recently played tracks from iPod (and the like) to Last.fm.
  * Synchronization of labels and rating between Last.fm and Amarok collections;
    play count can be synchronized one-way from Last.fm to Amarok.
  * Statistics synchronization between collections, supports rating, first / last
    played time, play count and labels.

CHANGES:
  * Configure Amarok dialog gets new Metadata tab to grab some weight from the
    Collection tab and to configure statistics synchronization.

BUGFIXES:
  * Better Last.fm scrobbling behaviour and error reporting due to rewrite,
    should fix long-standing problems.
  * Update stream meta-data correctly even with phonon-gstreamer back-end.
Related: bug 240732, bug 309697, bug 293320, bug 285820
FIXED-IN: 2.7
DIGEST: Amarok statistics synchronization GSoC project merged with many features
        and improvements, please see http://strohel.blogspot.com/search/label/gsoc
        for more info and a bunch of screen shots.
GUI: Added statistics synchronization dialogs, split and one more config dialog tab

M  +15   -0    ChangeLog

http://commits.kde.org/amarok/2fc6c25ee0f2eff758432c101ff82c87bc04a9e8