Bug 285820 - Cannot scrobble or like songs that are recently added to my collection
Summary: Cannot scrobble or like songs that are recently added to my collection
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Services/Last.fm (show other bugs)
Version: 2.4.3
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-05 14:35 UTC by Shamajotsi
Modified: 2012-11-21 23:19 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shamajotsi 2011-11-05 14:35:22 UTC
Version:           2.4.3 (using KDE 4.7.2) 
OS:                Linux

As strange as it may sound, since I installed Kubuntu 11.10 on my computer and moved all my music to my new Home folder, with Amarok I can only scrobble and like the music that I already have. When I listen to music that I have added to my collection since then, my scrobbling history does not change and the list of liked songs does not change either.

Reproducible: Always

Steps to Reproduce:
I haven't done anything specific that may have caused this. All I did was just to freshly install Kubuntu 11.10, which comes with Amarok, update it when it says that I should, and edit the settings for the Last.fm plug-in.


Expected Results:  
I expected to be able to scrobble and like songs that are recently added to my collection with Amarok.

OS: Linux (i686) release 3.0.0-12-generic
Compiler: gcc
Comment 1 Aakash 2012-01-01 17:50:20 UTC
Hi there, 
Can you please elaborate by the term "like the songs", perhaps what you meant was to rate them starwise?
Comment 2 Myriam Schweingruber 2012-01-02 00:05:40 UTC
(In reply to comment #1)
> Hi there, 
> Can you please elaborate by the term "like the songs", perhaps what you meant
> was to rate them starwise?

To "Like" a track is to click on the heart button, this is independent from rating and an option of last.fm. You need to check if a track you liked shows up in your list on last.fm
Comment 3 Aakash 2012-01-02 03:40:52 UTC
(In reply to comment #2)
Thanks, for the info. I was unaware about the "like" functionality. I shall test it accordingly.
Comment 4 Matěj Laitl 2012-11-21 23:19:04 UTC
Git commit 2fc6c25ee0f2eff758432c101ff82c87bc04a9e8 by Matěj Laitl.
Committed on 16/11/2012 at 19:03.
Pushed by laitl into branch 'master'.

StatSyncing: ChangeLog and BUG: tags for the final merge

This is a cummulative ChangeLog for my GSoC 2012 project, statistics
synchronization.

Individual commits responsible for the changes are earlier, but under
the same git merge.

FEATURES:
  * Track dragging support in Unique Tracks tab of the Synchronize Statistics action;
    allows you to do a "diff" between collections and transfer missing tracks.
  * Amarok now scrobbles tracks in streams if the stream correctly updates
    meta-data.
  * When scrobbling to Last.fm, Amarok announces suggested tag corrections.
  * Ability to scrobble recently played tracks from iPod (and the like) to Last.fm.
  * Synchronization of labels and rating between Last.fm and Amarok collections;
    play count can be synchronized one-way from Last.fm to Amarok.
  * Statistics synchronization between collections, supports rating, first / last
    played time, play count and labels.

CHANGES:
  * Configure Amarok dialog gets new Metadata tab to grab some weight from the
    Collection tab and to configure statistics synchronization.

BUGFIXES:
  * Better Last.fm scrobbling behaviour and error reporting due to rewrite,
    should fix long-standing problems.
  * Update stream meta-data correctly even with phonon-gstreamer back-end.
Related: bug 240732, bug 309697, bug 206249, bug 293320
FIXED-IN: 2.7
DIGEST: Amarok statistics synchronization GSoC project merged with many features
        and improvements, please see http://strohel.blogspot.com/search/label/gsoc
        for more info and a bunch of screen shots.
GUI: Added statistics synchronization dialogs, split and one more config dialog tab

M  +15   -0    ChangeLog

http://commits.kde.org/amarok/2fc6c25ee0f2eff758432c101ff82c87bc04a9e8