Bug 293222 - Muon software center disapears seconds after opening
Summary: Muon software center disapears seconds after opening
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-03 16:58 UTC by Vic
Modified: 2012-02-04 02:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vic 2012-02-03 16:58:11 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Opening Muon no other applications running this happens every time, unable to install any sofware at this time.
Kubuntu downloaded and installed from iso file burnt to disc

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78cb930 (LWP 1846))]

Thread 2 (Thread 0xb5bfcb70 (LWP 1847)):
#0  0x00b1ad44 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00c6af54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x05915c4f in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x006fab37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#4  0x006cb1dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#5  0x006cb421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0x005ce90b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0x006abe2d in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0x005d17b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0x00b17d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00c5d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78cb930 (LWP 1846)):
[KCrash Handler]
#7  0x00625e11 in QtPrivate::QStringList_contains(QStringList const*, QString const&, Qt::CaseSensitivity) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf83c1a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9f50bc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9f50bc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf83c3c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x006d2b7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0x006e1a6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#13 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9fc3dc0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#14 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9fc3dc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf83c508) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#15 0x006d2b7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#16 0x006e1a6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#17 0x005327c5 in MuonMainWindow::backendReady (this=0x9f50bc0, _t1=0x9f6d640) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#18 0x00532933 in MuonMainWindow::initObject (this=0x9f50bc0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#19 0x080654fc in ApplicationWindow::initObject (this=0x9f50bc0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#20 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9f50bc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf83c634) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#21 0x006d2b7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#22 0x006e1a6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#23 0x006e9375 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#24 0x006e942c in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#25 0x006e4994 in QObject::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#26 0x013f2d84 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#27 0x013f8133 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#28 0x01048971 in KApplication::notify (this=0xbf83cd40, receiver=0x9fc3728, event=0xbf83ca2c) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x006cc19e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#30 0x006fcc10 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#31 0x006fa122 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#32 0x0591525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0x05915990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0x05915c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0x006faada in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#36 0x014aae7a in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#37 0x006cb1dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#38 0x006cb421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#39 0x006d019d in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#40 0x013f0924 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#41 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 293170, bug 293153, bug 293118, bug 293113, bug 293102.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-04 02:59:15 UTC

*** This bug has been marked as a duplicate of bug 291262 ***