Bug 288935 - now with 4.7.4
Summary: now with 4.7.4
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-14 02:45 UTC by Sérgio Basto
Modified: 2011-12-14 09:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sérgio Basto 2011-12-14 02:45:53 UTC
Application: kontact (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.4-1.rhbz590880.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

SPAM check , not so easy to crash but still crash, still easy to crash with kpartswebkit and flash plugin 11 64-bits.
but could be only in my computer.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fd396bf5840 (LWP 5257))]

Thread 3 (Thread 0x7fd38bfdf700 (LWP 5258)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003d105973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3d10f90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003d105974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x000000374f607d90 in start_thread (arg=0x7fd38bfdf700) at pthread_create.c:309
#4  0x000000374eeef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fd38b6de700 (LWP 5259)):
#0  0x000000374eee6a43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003751e44f88 in g_main_context_poll (n_fds=1, fds=0x7fd3840013e0, priority=<optimized out>, timeout=511, context=0x7fd3840009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7fd3840009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x0000003751e4544c in g_main_context_iteration (context=0x7fd3840009a0, may_block=1) at gmain.c:3136
#4  0x00000037583a6896 in QEventDispatcherGlib::processEvents (this=0x7fd3840008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003758376c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003758376ed7 in QEventLoop::exec (this=0x7fd38b6ddd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003758278ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000375827bb1b in QThreadPrivate::start (arg=0xba8050) at thread/qthread_unix.cpp:298
#9  0x000000374f607d90 in start_thread (arg=0x7fd38b6de700) at pthread_create.c:309
#10 0x000000374eeef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fd396bf5840 (LWP 5257)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x11fccf00, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x0000003d0a8f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x11fccf00, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00000037583909e6 in QObject::event (this=0x11fccf00, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x00000037599c96f4 in notify_helper (e=0x7fd3300078c0, receiver=0x11fccf00, this=0xa182e0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0xa182e0, receiver=0x11fccf00, e=0x7fd3300078c0) at kernel/qapplication.cpp:4490
#11 0x00000037599ce573 in QApplication::notify (this=0x7fff05ed4b20, receiver=0x11fccf00, e=0x7fd3300078c0) at kernel/qapplication.cpp:4379
#12 0x0000003d0b850766 in KApplication::notify (this=0x7fff05ed4b20, receiver=0x11fccf00, event=0x7fd3300078c0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x0000003758377b4c in QCoreApplication::notifyInternal (this=0x7fff05ed4b20, receiver=0x11fccf00, event=0x7fd3300078c0) at kernel/qcoreapplication.cpp:876
#14 0x000000375837b5da in sendEvent (event=0x7fd3300078c0, receiver=0x11fccf00) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9ed050) at kernel/qcoreapplication.cpp:1500
#16 0x00000037583a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0xa215b0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x0000003751e44a7d in g_main_dispatch (context=0xa214c0) at gmain.c:2425
#19 g_main_context_dispatch (context=0xa214c0) at gmain.c:2995
#20 0x0000003751e45278 in g_main_context_iterate (context=0xa214c0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x0000003751e4544c in g_main_context_iteration (context=0xa214c0, may_block=1) at gmain.c:3136
#22 0x00000037583a682f in QEventDispatcherGlib::processEvents (this=0x9ee510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x0000003759a6c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003758376c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003758376ed7 in QEventLoop::exec (this=0x7fff05ed4ab0, flags=...) at kernel/qeventloop.cpp:204
#26 0x000000375837b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fff05ed5148) at /usr/src/debug/kdepim-4.7.4/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 283657.

Possible duplicates by query: bug 288604, bug 288504, bug 288423, bug 288362, bug 288324.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-14 09:15:19 UTC
Please, try to find more explicit titles for your bug reports.

*** This bug has been marked as a duplicate of bug 286307 ***