Bug 292320 - KCrash: Application 'muon-installer' crashing
Summary: KCrash: Application 'muon-installer' crashing
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-24 12:34 UTC by tormen
Modified: 2012-01-24 12:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tormen 2012-01-24 12:34:19 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Info by terminal - muon-installer
tormen@midnight:~$ KCrash: Application 'muon-installer' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/tormen/.kde/socket-midnight/kdeinit4__0
QSocketNotifier: Invalid socket 9 and type 'Read', disabling

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa468f2f780 (LWP 18860))]

Thread 2 (Thread 0x7fa4543ae700 (LWP 18861)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fa4543adaf0 in ?? ()
#2  0x00007fffac9ff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7fa468f2f780 (LWP 18860)):
[KCrash Handler]
#6  0x00007fa467bf7a5e in QtPrivate::QStringList_contains (that=0x7fffac8d3cd0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffac8d3cd0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1088850) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1088850, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffac8d42a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fa467ca3eba in QMetaObject::activate (sender=0x10cf6b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x10cf6b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffac8d4400) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fa467ca3eba in QMetaObject::activate (sender=0x1088850, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffac8d4400) at kernel/qobject.cpp:3278
#13 0x00007fa468b16e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1114ed0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fa468b16f8e in MuonMainWindow::initObject (this=0x1088850) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1088850) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1088850, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffac8d44d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fa467ca3eba in QMetaObject::activate (sender=0x112d500, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fa467cabf7f in QSingleShotTimer::timerEvent (this=0x112d500) at kernel/qtimer.cpp:308
#19 0x00007fa467ca7789 in QObject::event (this=0x112d500, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fa4662cb424 in notify_helper (e=0x7fffac8d4a40, receiver=0x112d500, this=0xf5e1e0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xf5e1e0, receiver=0x112d500, e=0x7fffac8d4a40) at kernel/qapplication.cpp:4458
#22 0x00007fa4662d0291 in QApplication::notify (this=0x7fffac8d4d40, receiver=0x112d500, e=0x7fffac8d4a40) at kernel/qapplication.cpp:4365
#23 0x00007fa4674af126 in KApplication::notify (this=0x7fffac8d4d40, receiver=0x112d500, event=0x7fffac8d4a40) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fa467c90afc in QCoreApplication::notifyInternal (this=0x7fffac8d4d40, receiver=0x112d500, event=0x7fffac8d4a40) at kernel/qcoreapplication.cpp:787
#25 0x00007fa467cbdd62 in sendEvent (event=0x7fffac8d4a40, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xf599d0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fa467cbb514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fa462373a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fa462374258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fa462374429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fa467cbbed6 in QEventDispatcherGlib::processEvents (this=0xf346f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fa46637307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fa467c8fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fa467c8fef7 in QEventLoop::exec (this=0x7fffac8d4cd0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fa467c94789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffac8d4fb8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 292311.

Possible duplicates by query: bug 292311, bug 292276, bug 292264, bug 292243, bug 292237.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-24 12:58:54 UTC

*** This bug has been marked as a duplicate of bug 291262 ***