Bug 292276 - Muon Software Center crashes before finishing to load.
Summary: Muon Software Center crashes before finishing to load.
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-23 16:17 UTC by jgarfolo
Modified: 2012-01-23 20:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.04 KB, text/plain)
2012-01-23 20:16 UTC, Ian Proudler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jgarfolo 2012-01-23 16:17:54 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was not doing anything else. I opened the software center and waited for it to load. The gui window displayed at first unpopulated, then after about a second or two it closes and gives an error message.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76f2930 (LWP 1737))]

Thread 2 (Thread 0xb5859b70 (LWP 1741)):
#0  0x00dbadc6 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x0132bf14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x01546b9b in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01547664 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01547c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00b17b37 in QEventDispatcherGlib::processEvents (this=0x9089518, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00ae81dd in QEventLoop::processEvents (this=0xb58592b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00ae8421 in QEventLoop::exec (this=0xb58592b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x009eb90b in QThread::exec (this=0x903c620) at thread/qthread.cpp:498
#9  0x00ac8e2d in QInotifyFileSystemWatcherEngine::run (this=0x903c620) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x009ee7b3 in QThreadPrivate::start (arg=0x903c620) at thread/qthread_unix.cpp:331
#11 0x00db8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0131e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76f2930 (LWP 1737)):
[KCrash Handler]
#7  0x00a42e11 in QtPrivate::QStringList_contains (that=0xbfa41de4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa41de4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8ff6848) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8ff6848, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa42004) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00aefb7d in metacall (argv=0xbfa42004, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8ff6848) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8ff6848, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfa42004) at kernel/qmetaobject.cpp:232
#13 0x00afea6a in QMetaObject::activate (sender=0x90814d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x90814d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x90814d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa42148) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00aefb7d in metacall (argv=0xbfa42148, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x90814d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x90814d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfa42148) at kernel/qmetaobject.cpp:232
#18 0x00afea6a in QMetaObject::activate (sender=0x8ff6848, m=0x80950c0, local_signal_index=0, argv=0xbfa42148) at kernel/qobject.cpp:3278
#19 0x001f87c5 in MuonMainWindow::backendReady (this=0x8ff6848, _t1=0x8ff6818) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x001f8933 in MuonMainWindow::initObject (this=0x8ff6848) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8ff6848) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8ff6848, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa42274) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00aefb7d in metacall (argv=0xbfa42274, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8ff6848) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8ff6848, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfa42274) at kernel/qmetaobject.cpp:232
#25 0x00afea6a in QMetaObject::activate (sender=0x905f828, m=0xc1f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00b06375 in QSingleShotTimer::timeout (this=0x905f828) at .moc/release-shared/qtimer.moc:82
#27 0x00b0642c in QSingleShotTimer::timerEvent (this=0x905f828) at kernel/qtimer.cpp:308
#28 0x00b01994 in QObject::event (this=0x905f828, e=0xbfa4266c) at kernel/qobject.cpp:1181
#29 0x06e4dd54 in notify_helper (e=0xbfa4266c, receiver=0x905f828, this=0x8f04fa0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8f04fa0, receiver=0x905f828, e=0xbfa4266c) at kernel/qapplication.cpp:4458
#31 0x06e53103 in QApplication::notify (this=0xbfa4266c, receiver=0x905f828, e=0xbfa4266c) at kernel/qapplication.cpp:3886
#32 0x00ff9971 in KApplication::notify (this=0xbfa42980, receiver=0x905f828, event=0xbfa4266c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00ae919e in QCoreApplication::notifyInternal (this=0xbfa42980, receiver=0x905f828, event=0xbfa4266c) at kernel/qcoreapplication.cpp:787
#34 0x00b19c10 in sendEvent (event=0xbfa4266c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8f010b4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00b17122 in timerSourceDispatch (source=0x8f01080) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0154725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01547990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01547c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00b17ada in QEventDispatcherGlib::processEvents (this=0x8ee3238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x06f05e3a in QGuiEventDispatcherGlib::processEvents (this=0x8ee3238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00ae81dd in QEventLoop::processEvents (this=0xbfa428e4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00ae8421 in QEventLoop::exec (this=0xbfa428e4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00aed19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x06e4b8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292264, bug 292243, bug 292237, bug 292212, bug 292180.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-23 16:19:45 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Ian Proudler 2012-01-23 20:16:37 UTC
Created attachment 68118 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
I opened the muon software centre application and it crashed.

-- Backtrace (Reduced):
#6  0x00007f95f0a76a5e in QtPrivate::QStringList_contains (that=0x7fff2fb3a9b0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff2fb3a9b0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xca9500) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xca9500, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2fb3af80) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xe039b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2fb3b0e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109