Bug 292237 - cannot start muon application
Summary: cannot start muon application
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 22:32 UTC by ard
Modified: 2012-01-23 19:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.16 KB, text/plain)
2012-01-22 22:52 UTC, Sante
Details
New crash information added by DrKonqi (6.57 KB, text/plain)
2012-01-23 19:49 UTC, MpMp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ard 2012-01-22 22:32:13 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: hej, just opened the application for the first time. It never opens, not even after repeated tries.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon programvarucentral (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa364949780 (LWP 3303))]

Thread 2 (Thread 0x7fa34fd4d700 (LWP 3304)):
#0  0x00007fa35e8721fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x209b3f8) at pthread_mutex_unlock.c:290
#2  0x00007fa35dd8bf3f in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa35dd8cdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa35dd8d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa3636d4f3e in QEventDispatcherGlib::processEvents (this=0x1faa7d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007fa3636a8cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fa3636a8ef7 in QEventLoop::exec (this=0x7fa34fd4cdd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007fa3635c027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007fa36368bcbf in QInotifyFileSystemWatcherEngine::run (this=0x1fc7340) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fa3635c2d05 in QThreadPrivate::start (arg=0x1fc7340) at thread/qthread_unix.cpp:331
#11 0x00007fa35e86eefc in start_thread (arg=0x7fa34fd4d700) at pthread_create.c:304
#12 0x00007fa36152389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa364949780 (LWP 3303)):
[KCrash Handler]
#6  0x00007fa363610a5e in QtPrivate::QStringList_contains (that=0x7fff685788d0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff685788d0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1fd16e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1fd16e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff68578ea0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fa3636bceba in QMetaObject::activate (sender=0x218d6b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x218d6b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff68579000) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fa3636bceba in QMetaObject::activate (sender=0x1fd16e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff68579000) at kernel/qobject.cpp:3278
#13 0x00007fa36452fe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1ff9710) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fa36452ff8e in MuonMainWindow::initObject (this=0x1fd16e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1fd16e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1fd16e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff685790d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fa3636bceba in QMetaObject::activate (sender=0x2037530, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fa3636c4f7f in QSingleShotTimer::timerEvent (this=0x2037530) at kernel/qtimer.cpp:308
#19 0x00007fa3636c0789 in QObject::event (this=0x2037530, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fa361ce4424 in notify_helper (e=0x7fff68579640, receiver=0x2037530, this=0x1e64050) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1e64050, receiver=0x2037530, e=0x7fff68579640) at kernel/qapplication.cpp:4458
#22 0x00007fa361ce9291 in QApplication::notify (this=0x7fff68579940, receiver=0x2037530, e=0x7fff68579640) at kernel/qapplication.cpp:4365
#23 0x00007fa362ec8126 in KApplication::notify (this=0x7fff68579940, receiver=0x2037530, event=0x7fff68579640) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fa3636a9afc in QCoreApplication::notifyInternal (this=0x7fff68579940, receiver=0x2037530, event=0x7fff68579640) at kernel/qcoreapplication.cpp:787
#25 0x00007fa3636d6d62 in sendEvent (event=0x7fff68579640, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1e69470) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fa3636d4514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fa35dd8ca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fa35dd8d258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fa35dd8d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fa3636d4ed6 in QEventDispatcherGlib::processEvents (this=0x1e3f6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fa361d8c07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fa3636a8cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fa3636a8ef7 in QEventLoop::exec (this=0x7fff685798d0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fa3636ad789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff68579bb8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292212, bug 292180, bug 292179, bug 292178, bug 292167.

Reported using DrKonqi
Comment 1 Sante 2012-01-22 22:52:24 UTC
Created attachment 68101 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: just loaded the applicatio end Muon Software Center never started

-- Backtrace (Reduced):
#6  0x00007f5a6d953a5e in QtPrivate::QStringList_contains (that=0x7fffbbdd4b50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffbbdd4b50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x125ccd0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x125ccd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbbdd5120) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x12d0b40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbbdd5280) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 2 Jekyll Wu 2012-01-23 00:26:11 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 3 MpMp 2012-01-23 19:49:47 UTC
Created attachment 68117 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

Muon crashes at startup, without any suggestions.

-- Backtrace (Reduced):
#7  0x00a61e11 in QtPrivate::QStringList_contains (that=0xbfabda04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfabda04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8a7efa8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8a7efa8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfabdc24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00b0eb7d in metacall (argv=0xbfabdc24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8a7efa8) at kernel/qmetaobject.cpp:237