Bug 292264 - Muon software crash
Summary: Muon software crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-23 11:30 UTC by Marise
Modified: 2012-01-23 11:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marise 2012-01-23 11:30:41 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Nothing. I have just open the application. The desk was clean.

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7715930 (LWP 2248))]

Thread 2 (Thread 0xb56e5b70 (LWP 2249)):
#0  0x00487d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x008157d5 in do_gettime (frac=0xb56e5020, sec=0xb56e5018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x008e84b6 in QTimerInfoList::updateCurrentTime (this=0x8552dcc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x008e880a in QTimerInfoList::timerWait (this=0x8552dcc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x008e7053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb56e512c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x008e70ed in timerSourcePrepare (source=0x8552d98, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x039ea88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x039eb637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x039ebc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x008e7b37 in QEventDispatcherGlib::processEvents (this=0x8416e08, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x008b81dd in QEventLoop::processEvents (this=0xb56e52b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x008b8421 in QEventLoop::exec (this=0xb56e52b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x007bb90b in QThread::exec (this=0x84fe6d8) at thread/qthread.cpp:498
#14 0x00898e2d in QInotifyFileSystemWatcherEngine::run (this=0x84fe6d8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x007be7b3 in QThreadPrivate::start (arg=0x84fe6d8) at thread/qthread_unix.cpp:331
#16 0x009fad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00b5e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7715930 (LWP 2248)):
[KCrash Handler]
#7  0x00812e11 in QtPrivate::QStringList_contains (that=0xbf987d44, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf987d44) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x84b39a8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x84b39a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf987f64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x008bfb7d in metacall (argv=0xbf987f64, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x84b39a8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x84b39a8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf987f64) at kernel/qmetaobject.cpp:232
#13 0x008cea6a in QMetaObject::activate (sender=0x8519480, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8519480) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8519480, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9880a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x008bfb7d in metacall (argv=0xbf9880a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8519480) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8519480, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9880a8) at kernel/qmetaobject.cpp:232
#18 0x008cea6a in QMetaObject::activate (sender=0x84b39a8, m=0x80950c0, local_signal_index=0, argv=0xbf9880a8) at kernel/qobject.cpp:3278
#19 0x0033d7c5 in MuonMainWindow::backendReady (this=0x84b39a8, _t1=0x84d70e0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0033d933 in MuonMainWindow::initObject (this=0x84b39a8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x84b39a8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x84b39a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9881d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x008bfb7d in metacall (argv=0xbf9881d4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x84b39a8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x84b39a8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9881d4) at kernel/qmetaobject.cpp:232
#25 0x008cea6a in QMetaObject::activate (sender=0x85278c0, m=0x9ef238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x008d6375 in QSingleShotTimer::timeout (this=0x85278c0) at .moc/release-shared/qtimer.moc:82
#27 0x008d642c in QSingleShotTimer::timerEvent (this=0x85278c0) at kernel/qtimer.cpp:308
#28 0x008d1994 in QObject::event (this=0x85278c0, e=0xbf9885cc) at kernel/qobject.cpp:1181
#29 0x07667d54 in notify_helper (e=0xbf9885cc, receiver=0x85278c0, this=0x83bc2b8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x83bc2b8, receiver=0x85278c0, e=0xbf9885cc) at kernel/qapplication.cpp:4458
#31 0x0766d103 in QApplication::notify (this=0xbf9885cc, receiver=0x85278c0, e=0xbf9885cc) at kernel/qapplication.cpp:3886
#32 0x01195681 in KApplication::notify (this=0xbf9888e0, receiver=0x85278c0, event=0xbf9885cc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x008b919e in QCoreApplication::notifyInternal (this=0xbf9888e0, receiver=0x85278c0, event=0xbf9885cc) at kernel/qcoreapplication.cpp:787
#34 0x008e9c10 in sendEvent (event=0xbf9885cc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x83bd934) at kernel/qeventdispatcher_unix.cpp:603
#36 0x008e7122 in timerSourceDispatch (source=0x83bd900) at kernel/qeventdispatcher_glib.cpp:184
#37 0x039eb25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x039eb990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x039ebc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x008e7ada in QEventDispatcherGlib::processEvents (this=0x839f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0771fe3a in QGuiEventDispatcherGlib::processEvents (this=0x839f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x008b81dd in QEventLoop::processEvents (this=0xbf988844, flags=...) at kernel/qeventloop.cpp:149
#43 0x008b8421 in QEventLoop::exec (this=0xbf988844, flags=...) at kernel/qeventloop.cpp:201
#44 0x008bd19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x076658f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292243, bug 292237, bug 292212, bug 292180, bug 292179.

Reported using DrKonqi
Comment 1 Thijs 2012-01-23 11:48:53 UTC

*** This bug has been marked as a duplicate of bug 291262 ***