Bug 292212 - Muon crashed since Virtual Box Extension Pack has been installed
Summary: Muon crashed since Virtual Box Extension Pack has been installed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 19:01 UTC by Ben Mueller-Gehr
Modified: 2012-01-23 02:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.69 KB, text/plain)
2012-01-22 21:09 UTC, rossburkepile
Details
New crash information added by DrKonqi (6.69 KB, text/plain)
2012-01-22 21:09 UTC, rossburkepile
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Mueller-Gehr 2012-01-22 19:01:25 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Muon crashed since Virtual Box Extension Pack has been installed

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb48ed930 (LWP 2699))]

Thread 2 (Thread 0xb1d86b70 (LWP 2703)):
#0  0xb7875424 in __kernel_vsyscall ()
#1  0xb5ea540e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb539034b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb5381896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5381c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb73e7b37 in QEventDispatcherGlib::processEvents (this=0x93ebe28, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb73b81dd in QEventLoop::processEvents (this=0xb1d862b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb73b8421 in QEventLoop::exec (this=0xb1d862b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb72bb90b in QThread::exec (this=0x927de68) at thread/qthread.cpp:498
#9  0xb7398e2d in QInotifyFileSystemWatcherEngine::run (this=0x927de68) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb72be7b3 in QThreadPrivate::start (arg=0x927de68) at thread/qthread_unix.cpp:331
#11 0xb5467d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5eb40ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb48ed930 (LWP 2699)):
[KCrash Handler]
#7  0xb7312e11 in QtPrivate::QStringList_contains (that=0xbfe6ba94, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe6ba94) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x93655f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x93655f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe6bcb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb73bfb7d in metacall (argv=0xbfe6bcb4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x93655f0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x93655f0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe6bcb4) at kernel/qmetaobject.cpp:232
#13 0xb73cea6a in QMetaObject::activate (sender=0x93d0f28, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x93d0f28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x93d0f28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe6bdf8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb73bfb7d in metacall (argv=0xbfe6bdf8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x93d0f28) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x93d0f28, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe6bdf8) at kernel/qmetaobject.cpp:232
#18 0xb73cea6a in QMetaObject::activate (sender=0x93655f0, m=0x80950c0, local_signal_index=0, argv=0xbfe6bdf8) at kernel/qobject.cpp:3278
#19 0xb782d7c5 in MuonMainWindow::backendReady (this=0x93655f0, _t1=0x9367900) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb782d933 in MuonMainWindow::initObject (this=0x93655f0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x93655f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x93655f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe6bf24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb73bfb7d in metacall (argv=0xbfe6bf24, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x93655f0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x93655f0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe6bf24) at kernel/qmetaobject.cpp:232
#25 0xb73cea6a in QMetaObject::activate (sender=0x93b1378, m=0xb74ef238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb73d6375 in QSingleShotTimer::timeout (this=0x93b1378) at .moc/release-shared/qtimer.moc:82
#27 0xb73d642c in QSingleShotTimer::timerEvent (this=0x93b1378) at kernel/qtimer.cpp:308
#28 0xb73d1994 in QObject::event (this=0x93b1378, e=0xbfe6c31c) at kernel/qobject.cpp:1181
#29 0xb61a0d54 in notify_helper (e=0xbfe6c31c, receiver=0x93b1378, this=0x92528e0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x92528e0, receiver=0x93b1378, e=0xbfe6c31c) at kernel/qapplication.cpp:4458
#31 0xb61a6103 in QApplication::notify (this=0xbfe6c31c, receiver=0x93b1378, e=0xbfe6c31c) at kernel/qapplication.cpp:3886
#32 0xb6fbf681 in KApplication::notify (this=0xbfe6c630, receiver=0x93b1378, event=0xbfe6c31c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb73b919e in QCoreApplication::notifyInternal (this=0xbfe6c630, receiver=0x93b1378, event=0xbfe6c31c) at kernel/qcoreapplication.cpp:787
#34 0xb73e9c10 in sendEvent (event=0xbfe6c31c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x925027c) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb73e7155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x92502b0) at kernel/qeventdispatcher_glib.cpp:231
#38 0xb538125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb5381990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb5381c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb73e7ada in QEventDispatcherGlib::processEvents (this=0x9230238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0xb6258e3a in QGuiEventDispatcherGlib::processEvents (this=0x9230238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0xb73b81dd in QEventLoop::processEvents (this=0xbfe6c594, flags=...) at kernel/qeventloop.cpp:149
#44 0xb73b8421 in QEventLoop::exec (this=0xbfe6c594, flags=...) at kernel/qeventloop.cpp:201
#45 0xb73bd19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0xb619e8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292180, bug 292179, bug 292178, bug 292167, bug 292151.

Reported using DrKonqi
Comment 1 rossburkepile 2012-01-22 21:09:47 UTC
Created attachment 68096 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: attempting open the software center.  have rebooted and still crashes every time I open.  Thoughts?

-- Backtrace (Reduced):
#7  0x006c8e11 in QtPrivate::QStringList_contains (that=0xbfd11004, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd11004) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x92185f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x92185f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd11224) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00775b7d in metacall (argv=0xbfd11224, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x92185f0) at kernel/qmetaobject.cpp:237
Comment 2 rossburkepile 2012-01-22 21:09:47 UTC
Created attachment 68097 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: attempting open the software center.  have rebooted and still crashes every time I open.  Thoughts?

-- Backtrace (Reduced):
#7  0x006c8e11 in QtPrivate::QStringList_contains (that=0xbfd11004, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd11004) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x92185f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x92185f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd11224) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00775b7d in metacall (argv=0xbfd11224, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x92185f0) at kernel/qmetaobject.cpp:237
Comment 3 Jekyll Wu 2012-01-23 02:14:00 UTC

*** This bug has been marked as a duplicate of bug 291262 ***