Bug 292178 - muon fostware centre crashes upon open
Summary: muon fostware centre crashes upon open
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 10:40 UTC by micknobett
Modified: 2012-01-22 13:46 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.62 KB, text/plain)
2012-01-22 13:46 UTC, Fabien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description micknobett 2012-01-22 10:40:05 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
just logged in.
gives a PID installer, segmentation fault.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8a2c694780 (LWP 1869))]

Thread 2 (Thread 0x7f8a17de4700 (LWP 1870)):
#0  0x00007f8a29262773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8a25ad7f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8a25ad8429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8a2b41ff3e in QEventDispatcherGlib::processEvents (this=0x19d37e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f8a2b3f3cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8a2b3f3ef7 in QEventLoop::exec (this=0x7f8a17de3dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f8a2b30b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f8a2b3d6cbf in QInotifyFileSystemWatcherEngine::run (this=0x1905f50) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8a2b30dd05 in QThreadPrivate::start (arg=0x1905f50) at thread/qthread_unix.cpp:331
#9  0x00007f8a265b9efc in start_thread (arg=0x7f8a17de4700) at pthread_create.c:304
#10 0x00007f8a2926e89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8a2c694780 (LWP 1869)):
[KCrash Handler]
#6  0x00007f8a2b35ba5e in QtPrivate::QStringList_contains (that=0x7fff54e60470, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff54e60470) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x19bfb00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x19bfb00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff54e60a40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f8a2b407eba in QMetaObject::activate (sender=0x1b8a620, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1b8a620, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff54e60ba0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f8a2b407eba in QMetaObject::activate (sender=0x19bfb00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff54e60ba0) at kernel/qobject.cpp:3278
#13 0x00007f8a2c27ae7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x19cfcc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f8a2c27af8e in MuonMainWindow::initObject (this=0x19bfb00) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x19bfb00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x19bfb00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff54e60c70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f8a2b407eba in QMetaObject::activate (sender=0x1a31bb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f8a2b40ff7f in QSingleShotTimer::timerEvent (this=0x1a31bb0) at kernel/qtimer.cpp:308
#19 0x00007f8a2b40b789 in QObject::event (this=0x1a31bb0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f8a29a2f424 in notify_helper (e=0x7fff54e611e0, receiver=0x1a31bb0, this=0x1862070) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1862070, receiver=0x1a31bb0, e=0x7fff54e611e0) at kernel/qapplication.cpp:4458
#22 0x00007f8a29a34291 in QApplication::notify (this=0x7fff54e614e0, receiver=0x1a31bb0, e=0x7fff54e611e0) at kernel/qapplication.cpp:4365
#23 0x00007f8a2ac13126 in KApplication::notify (this=0x7fff54e614e0, receiver=0x1a31bb0, event=0x7fff54e611e0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f8a2b3f4afc in QCoreApplication::notifyInternal (this=0x7fff54e614e0, receiver=0x1a31bb0, event=0x7fff54e611e0) at kernel/qcoreapplication.cpp:787
#25 0x00007f8a2b421d62 in sendEvent (event=0x7fff54e611e0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x185e640) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f8a2b41f514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f8a25ad7a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f8a25ad8258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f8a25ad8429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f8a2b41fed6 in QEventDispatcherGlib::processEvents (this=0x183a6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f8a29ad707e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f8a2b3f3cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f8a2b3f3ef7 in QEventLoop::exec (this=0x7fff54e61470, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f8a2b3f8789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff54e61758) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 292151.

Possible duplicates by query: bug 292167, bug 292151, bug 292149, bug 292124, bug 292123.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-22 10:46:50 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Fabien 2012-01-22 13:46:13 UTC
Created attachment 68089 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

Muon doesn't crash if launched from konsole.

-- Backtrace (Reduced):
#7  0xb727fe11 in QtPrivate::QStringList_contains (that=0xbfc7b8b4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc7b8b4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9e0a2f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9e0a2f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc7bad4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb732cb7d in metacall (argv=0xbfc7bad4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9e0a2f8) at kernel/qmetaobject.cpp:237