Bug 292167 - Muon Software Center constantly crashing
Summary: Muon Software Center constantly crashing
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 08:18 UTC by Vassilis
Modified: 2012-01-22 08:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vassilis 2012-01-22 08:18:12 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
When  run muon software center I have a blank window for some seconds until I have a crash report

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2b9911b780 (LWP 2171))]

Thread 2 (Thread 0x7f2b84482700 (LWP 2174)):
#0  __pthread_mutex_lock (mutex=0x7f2b7c0009a8) at pthread_mutex_lock.c:54
#1  0x00007f2b92561361 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2b92561e6a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2b92562429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2b97ea9f3e in QEventDispatcherGlib::processEvents (this=0x7f2b7c0008b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f2b97e7dcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f2b97e7def7 in QEventLoop::exec (this=0x7f2b84481dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f2b97d9527f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f2b97e60cbf in QInotifyFileSystemWatcherEngine::run (this=0x23c5530) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f2b97d97d05 in QThreadPrivate::start (arg=0x23c5530) at thread/qthread_unix.cpp:331
#10 0x00007f2b93043efc in start_thread (arg=0x7f2b84482700) at pthread_create.c:304
#11 0x00007f2b95cf889d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2b9911b780 (LWP 2171)):
[KCrash Handler]
#6  0x00007f2b97de5a5e in QtPrivate::QStringList_contains (that=0x7ffff1da9a30, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7ffff1da9a30) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2352f70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2352f70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff1daa000) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f2b97e91eba in QMetaObject::activate (sender=0x2400250, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2400250, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff1daa160) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f2b97e91eba in QMetaObject::activate (sender=0x2352f70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff1daa160) at kernel/qobject.cpp:3278
#13 0x00007f2b98d04e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x2409d30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f2b98d04f8e in MuonMainWindow::initObject (this=0x2352f70) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2352f70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2352f70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff1daa230) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f2b97e91eba in QMetaObject::activate (sender=0x240c290, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f2b97e99f7f in QSingleShotTimer::timerEvent (this=0x240c290) at kernel/qtimer.cpp:308
#19 0x00007f2b97e95789 in QObject::event (this=0x240c290, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f2b964b9424 in notify_helper (e=0x7ffff1daa7a0, receiver=0x240c290, this=0x2205600) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2205600, receiver=0x240c290, e=0x7ffff1daa7a0) at kernel/qapplication.cpp:4458
#22 0x00007f2b964be291 in QApplication::notify (this=0x7ffff1daaaa0, receiver=0x240c290, e=0x7ffff1daa7a0) at kernel/qapplication.cpp:4365
#23 0x00007f2b9769d126 in KApplication::notify (this=0x7ffff1daaaa0, receiver=0x240c290, event=0x7ffff1daa7a0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f2b97e7eafc in QCoreApplication::notifyInternal (this=0x7ffff1daaaa0, receiver=0x240c290, event=0x7ffff1daa7a0) at kernel/qcoreapplication.cpp:787
#25 0x00007f2b97eabd62 in sendEvent (event=0x7ffff1daa7a0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x21fe290) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f2b97ea9514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f2b92561a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f2b92562258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f2b92562429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f2b97ea9ed6 in QEventDispatcherGlib::processEvents (this=0x21d86f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f2b9656107e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f2b97e7dcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f2b97e7def7 in QEventLoop::exec (this=0x7ffff1daaa30, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f2b97e82789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7ffff1daad18) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292151, bug 292149, bug 292124, bug 292123, bug 292116.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-22 08:51:01 UTC

*** This bug has been marked as a duplicate of bug 291262 ***