Bug 292151 - Muon Crashes every time i start it
Summary: Muon Crashes every time i start it
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 03:17 UTC by Cyber Moore
Modified: 2012-01-22 03:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyber Moore 2012-01-22 03:17:31 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:  Ijust installed Kubuntu 11.10 32bit onto a Dell Latitude 2100.  When I try to start it to install needed applicatioins it crashes every time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb787b930 (LWP 22257))]

Thread 2 (Thread 0xb5c10b70 (LWP 22260)):
#0  0x00ae5d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x002b57d5 in do_gettime (frac=0xb5c10020, sec=0xb5c10018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x003884b6 in QTimerInfoList::updateCurrentTime (this=0x9f2dee4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0038880a in QTimerInfoList::timerWait (this=0x9f2dee4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00387053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5c1012c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x003870ed in timerSourcePrepare (source=0x9f2deb0, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0434188c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x04342637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x04342c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00387b37 in QEventDispatcherGlib::processEvents (this=0x9e24e08, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x003581dd in QEventLoop::processEvents (this=0xb5c102b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00358421 in QEventLoop::exec (this=0xb5c102b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0025b90b in QThread::exec (this=0x9e75208) at thread/qthread.cpp:498
#14 0x00338e2d in QInotifyFileSystemWatcherEngine::run (this=0x9e75208) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0025e7b3 in QThreadPrivate::start (arg=0x9e75208) at thread/qthread_unix.cpp:331
#16 0x00acdd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x009ad0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb787b930 (LWP 22257)):
[KCrash Handler]
#7  0x002b2e11 in QtPrivate::QStringList_contains (that=0xbfee7f64, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfee7f64) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9ddc270) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9ddc270, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfee8184) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0035fb7d in metacall (argv=0xbfee8184, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9ddc270) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9ddc270, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfee8184) at kernel/qmetaobject.cpp:232
#13 0x0036ea6a in QMetaObject::activate (sender=0x9e2bf38, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9e2bf38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9e2bf38, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfee82c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0035fb7d in metacall (argv=0xbfee82c8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9e2bf38) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9e2bf38, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfee82c8) at kernel/qmetaobject.cpp:232
#18 0x0036ea6a in QMetaObject::activate (sender=0x9ddc270, m=0x80950c0, local_signal_index=0, argv=0xbfee82c8) at kernel/qobject.cpp:3278
#19 0x00baa7c5 in MuonMainWindow::backendReady (this=0x9ddc270, _t1=0x9e26c80) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00baa933 in MuonMainWindow::initObject (this=0x9ddc270) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9ddc270) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9ddc270, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfee83f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0035fb7d in metacall (argv=0xbfee83f4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9ddc270) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9ddc270, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfee83f4) at kernel/qmetaobject.cpp:232
#25 0x0036ea6a in QMetaObject::activate (sender=0x9e45220, m=0x48f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00376375 in QSingleShotTimer::timeout (this=0x9e45220) at .moc/release-shared/qtimer.moc:82
#27 0x0037642c in QSingleShotTimer::timerEvent (this=0x9e45220) at kernel/qtimer.cpp:308
#28 0x00371994 in QObject::event (this=0x9e45220, e=0xbfee87ec) at kernel/qobject.cpp:1181
#29 0x090d8d54 in notify_helper (e=0xbfee87ec, receiver=0x9e45220, this=0x9cefdc8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9cefdc8, receiver=0x9e45220, e=0xbfee87ec) at kernel/qapplication.cpp:4458
#31 0x090de103 in QApplication::notify (this=0xbfee87ec, receiver=0x9e45220, e=0xbfee87ec) at kernel/qapplication.cpp:3886
#32 0x00f39681 in KApplication::notify (this=0xbfee8b00, receiver=0x9e45220, event=0xbfee87ec) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0035919e in QCoreApplication::notifyInternal (this=0xbfee8b00, receiver=0x9e45220, event=0xbfee87ec) at kernel/qcoreapplication.cpp:787
#34 0x00389c10 in sendEvent (event=0xbfee87ec, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9ceca9c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00387122 in timerSourceDispatch (source=0x9ceca68) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0434225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x04342990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x04342c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00387ada in QEventDispatcherGlib::processEvents (this=0x9cce238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x09190e3a in QGuiEventDispatcherGlib::processEvents (this=0x9cce238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x003581dd in QEventLoop::processEvents (this=0xbfee8a64, flags=...) at kernel/qeventloop.cpp:149
#43 0x00358421 in QEventLoop::exec (this=0xbfee8a64, flags=...) at kernel/qeventloop.cpp:201
#44 0x0035d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x090d68f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292149, bug 292124, bug 292123, bug 292116, bug 292093.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-22 03:27:23 UTC

*** This bug has been marked as a duplicate of bug 291262 ***