Bug 291681 - Logithèque Muon planté au démarage
Summary: Logithèque Muon planté au démarage
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-16 18:35 UTC by pellat.j-c
Modified: 2012-01-16 19:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pellat.j-c 2012-01-16 18:35:15 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Quand je lance la logithèque Muon, il plante au démarage.
Après plusieurs redémarage de l'application il plante a chaque fois, m^eme après le reboot de la machine.

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe2f5896780 (LWP 1935))]

Thread 2 (Thread 0x7fe2e0d3f700 (LWP 1939)):
#0  0x00007fe2f2465773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe2eecdaf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe2eecdb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe2f4622f3e in QEventDispatcherGlib::processEvents (this=0xc8afb0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe2f45f6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe2f45f6ef7 in QEventLoop::exec (this=0x7fe2e0d3edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe2f450e27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe2f45d9cbf in QInotifyFileSystemWatcherEngine::run (this=0xb078f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe2f4510d05 in QThreadPrivate::start (arg=0xb078f0) at thread/qthread_unix.cpp:331
#9  0x00007fe2ef7bcefc in start_thread (arg=0x7fe2e0d3f700) at pthread_create.c:304
#10 0x00007fe2f247189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe2f5896780 (LWP 1935)):
[KCrash Handler]
#6  0x00007fe2f455ea5e in QtPrivate::QStringList_contains (that=0x7fff0f9b7f80, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff0f9b7f80) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xabc380) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xabc380, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0f9b8550) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fe2f460aeba in QMetaObject::activate (sender=0xb4c740, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xb4c740, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0f9b86b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fe2f460aeba in QMetaObject::activate (sender=0xabc380, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0f9b86b0) at kernel/qobject.cpp:3278
#13 0x00007fe2f547de7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x9d6880) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fe2f547df8e in MuonMainWindow::initObject (this=0xabc380) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xabc380) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xabc380, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0f9b8780) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fe2f460aeba in QMetaObject::activate (sender=0xb48320, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fe2f4612f7f in QSingleShotTimer::timerEvent (this=0xb48320) at kernel/qtimer.cpp:308
#19 0x00007fe2f460e789 in QObject::event (this=0xb48320, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fe2f2c32424 in notify_helper (e=0x7fff0f9b8cf0, receiver=0xb48320, this=0x94aac0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x94aac0, receiver=0xb48320, e=0x7fff0f9b8cf0) at kernel/qapplication.cpp:4458
#22 0x00007fe2f2c37291 in QApplication::notify (this=0x7fff0f9b8ff0, receiver=0xb48320, e=0x7fff0f9b8cf0) at kernel/qapplication.cpp:4365
#23 0x00007fe2f3e16126 in KApplication::notify (this=0x7fff0f9b8ff0, receiver=0xb48320, event=0x7fff0f9b8cf0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fe2f45f7afc in QCoreApplication::notifyInternal (this=0x7fff0f9b8ff0, receiver=0xb48320, event=0x7fff0f9b8cf0) at kernel/qcoreapplication.cpp:787
#25 0x00007fe2f4624d62 in sendEvent (event=0x7fff0f9b8cf0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x948290) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fe2f4622514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fe2eecdaa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fe2eecdb258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fe2eecdb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fe2f4622ed6 in QEventDispatcherGlib::processEvents (this=0x9236f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fe2f2cda07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fe2f45f6cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fe2f45f6ef7 in QEventLoop::exec (this=0x7fff0f9b8f80, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fe2f45fb789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff0f9b9268) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291626, bug 291605, bug 291602, bug 291599, bug 291592.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2012-01-16 19:51:24 UTC

*** This bug has been marked as a duplicate of bug 291262 ***