Bug 291602 - Muon crashes every time I open it
Summary: Muon crashes every time I open it
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-15 18:47 UTC by cantonop76
Modified: 2012-01-15 18:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cantonop76 2012-01-15 18:47:52 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Muon crashes every time I open it

Muon crashes every time I open it

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0999475780 (LWP 7876))]

Thread 2 (Thread 0x7f0984864700 (LWP 7879)):
#0  0x00007f0996050773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f09928c5f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f09928c6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f099820df3e in QEventDispatcherGlib::processEvents (this=0x1efc760, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f09981e1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f09981e1ef7 in QEventLoop::exec (this=0x7f0984863dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f09980f927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f09981c4cbf in QInotifyFileSystemWatcherEngine::run (this=0x1f72200) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f09980fbd05 in QThreadPrivate::start (arg=0x1f72200) at thread/qthread_unix.cpp:331
#9  0x00007f09933a7efc in start_thread (arg=0x7f0984864700) at pthread_create.c:304
#10 0x00007f099605c89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0999475780 (LWP 7876)):
[KCrash Handler]
#6  0x00007f0998149a5e in QtPrivate::QStringList_contains (that=0x7fff84b66a40, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff84b66a40) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1f0ef70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1f0ef70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff84b67010) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f09981f5eba in QMetaObject::activate (sender=0x1f50840, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1f50840, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff84b67170) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f09981f5eba in QMetaObject::activate (sender=0x1f0ef70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff84b67170) at kernel/qobject.cpp:3278
#13 0x00007f0999068e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1f88150) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f0999068f8e in MuonMainWindow::initObject (this=0x1f0ef70) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1f0ef70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1f0ef70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff84b67240) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f09981f5eba in QMetaObject::activate (sender=0x20c0260, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f09981fdf7f in QSingleShotTimer::timerEvent (this=0x20c0260) at kernel/qtimer.cpp:308
#19 0x00007f09981f9789 in QObject::event (this=0x20c0260, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f099681d424 in notify_helper (e=0x7fff84b677b0, receiver=0x20c0260, this=0x1e23140) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1e23140, receiver=0x20c0260, e=0x7fff84b677b0) at kernel/qapplication.cpp:4458
#22 0x00007f0996822291 in QApplication::notify (this=0x7fff84b67ab0, receiver=0x20c0260, e=0x7fff84b677b0) at kernel/qapplication.cpp:4365
#23 0x00007f0997a01126 in KApplication::notify (this=0x7fff84b67ab0, receiver=0x20c0260, event=0x7fff84b677b0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f09981e2afc in QCoreApplication::notifyInternal (this=0x7fff84b67ab0, receiver=0x20c0260, event=0x7fff84b677b0) at kernel/qcoreapplication.cpp:787
#25 0x00007f099820fd62 in sendEvent (event=0x7fff84b677b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1e1e4f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f099820d538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f09928c5a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f09928c6258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f09928c6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f099820ded6 in QEventDispatcherGlib::processEvents (this=0x1df96f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f09968c507e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f09981e1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f09981e1ef7 in QEventLoop::exec (this=0x7fff84b67a40, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f09981e6789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff84b67d28) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291599, bug 291592, bug 291590, bug 291588, bug 291581.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 18:54:09 UTC

*** This bug has been marked as a duplicate of bug 291262 ***