Bug 291683 - Muon crashed
Summary: Muon crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: muon
Classification: Unclassified
Component: muon (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 291684 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-16 18:58 UTC by Aurélien57
Modified: 2012-01-16 19:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aurélien57 2012-01-16 18:58:19 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I was opened Muhon when it was crached.I just could see the widows. Please help-me, because the problem was often produced.
j'ai ouvert Muhon quand il a craché. j'ai pu voir la fenêtre. Aidez moi car cela arrive souvent

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7767930 (LWP 3751))]

Thread 2 (Thread 0xb53b5b70 (LWP 3755)):
#0  0x00169416 in __kernel_vsyscall ()
#1  0x00ddc40e in __GI___poll (fds=0x9725700, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x036aa34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0369b896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0369bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00471b37 in QEventDispatcherGlib::processEvents (this=0x9647d00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x004421dd in QEventLoop::processEvents (this=0xb53b52b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00442421 in QEventLoop::exec (this=0xb53b52b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0034590b in QThread::exec (this=0x9706c78) at thread/qthread.cpp:498
#9  0x00422e2d in QInotifyFileSystemWatcherEngine::run (this=0x9706c78) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x003487b3 in QThreadPrivate::start (arg=0x9706c78) at thread/qthread_unix.cpp:331
#11 0x00707d31 in start_thread (arg=0xb53b5b70) at pthread_create.c:304
#12 0x00deb0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7767930 (LWP 3751)):
[KCrash Handler]
#7  0x0039ce11 in QtPrivate::QStringList_contains (that=0xbfc04e14, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc04e14) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x958f910) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x958f910, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc05034) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00449b7d in metacall (argv=0xbfc05034, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x958f910) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x958f910, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc05034) at kernel/qmetaobject.cpp:232
#13 0x00458a6a in QMetaObject::activate (sender=0x961e710, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x961e710) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x961e710, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc05178) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00449b7d in metacall (argv=0xbfc05178, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x961e710) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x961e710, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc05178) at kernel/qmetaobject.cpp:232
#18 0x00458a6a in QMetaObject::activate (sender=0x958f910, m=0x80950c0, local_signal_index=0, argv=0xbfc05178) at kernel/qobject.cpp:3278
#19 0x00ce57c5 in MuonMainWindow::backendReady (this=0x958f910, _t1=0x966e500) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00ce5933 in MuonMainWindow::initObject (this=0x958f910) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x958f910) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x958f910, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc052a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00449b7d in metacall (argv=0xbfc052a4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x958f910) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x958f910, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc052a4) at kernel/qmetaobject.cpp:232
#25 0x00458a6a in QMetaObject::activate (sender=0x972aa00, m=0x579238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00460375 in QSingleShotTimer::timeout (this=0x972aa00) at .moc/release-shared/qtimer.moc:82
#27 0x0046042c in QSingleShotTimer::timerEvent (this=0x972aa00) at kernel/qtimer.cpp:308
#28 0x0045b994 in QObject::event (this=0x972aa00, e=0xbfc0569c) at kernel/qobject.cpp:1181
#29 0x03ac2d84 in notify_helper (e=0xbfc0569c, receiver=0x972aa00, this=0x958efd0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x958efd0, receiver=0x972aa00, e=0xbfc0569c) at kernel/qapplication.cpp:4458
#31 0x03ac8133 in QApplication::notify (this=0xbfc0569c, receiver=0x972aa00, e=0xbfc0569c) at kernel/qapplication.cpp:3886
#32 0x01197971 in KApplication::notify (this=0xbfc059b0, receiver=0x972aa00, event=0xbfc0569c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0044319e in QCoreApplication::notifyInternal (this=0xbfc059b0, receiver=0x972aa00, event=0xbfc0569c) at kernel/qcoreapplication.cpp:787
#34 0x00473c10 in sendEvent (event=0xbfc0569c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x958bf34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00471122 in timerSourceDispatch (source=0x958bf00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0369b25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0369b990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0369bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00471ada in QEventDispatcherGlib::processEvents (this=0x956d238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03b7ae7a in QGuiEventDispatcherGlib::processEvents (this=0x956d238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x004421dd in QEventLoop::processEvents (this=0xbfc05914, flags=...) at kernel/qeventloop.cpp:149
#43 0x00442421 in QEventLoop::exec (this=0xbfc05914, flags=...) at kernel/qeventloop.cpp:201
#44 0x0044719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x03ac0924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291681, bug 291626, bug 291605, bug 291602, bug 291599.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2012-01-16 19:45:34 UTC
*** Bug 291684 has been marked as a duplicate of this bug. ***
Comment 2 Anne-Marie Mahfouf 2012-01-16 19:47:50 UTC

*** This bug has been marked as a duplicate of bug 291262 ***