Bug 291549 - rekonq web browser crahed when I tried to open a radio station live audio link
Summary: rekonq web browser crahed when I tried to open a radio station live audio link
Status: RESOLVED DUPLICATE of bug 291111
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.8.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 21:43 UTC by alex_esquivelg
Modified: 2012-01-14 23:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alex_esquivelg 2012-01-14 21:43:22 UTC
Application: rekonq (0.8.0)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Rekonq rekonq web browser crahed when I tried to open a radio station live audio link. It is supossed to be opened with windows media player plugin. But since I'm ussing linux I think that clicking on that link would make the browser to give me some alternatives to reproduce the audio, just like VLC media pluging or some other.

The crash can be reproduced every time.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa0d6a50780 (LWP 4221))]

Thread 12 (Thread 0x7fa0b854d700 (LWP 4222)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa0d5322c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fa0d5322d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fa0d0a56efc in start_thread (arg=0x7fa0b854d700) at pthread_create.c:304
#4  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7fa0b7d4c700 (LWP 4223)):
#0  0x00007fa0d6275773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa0cee89f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa0cee8a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa0d110af3e in QEventDispatcherGlib::processEvents (this=0x1a8ff00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fa0d10decf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa0d10deef7 in QEventLoop::exec (this=0x7fa0b7d4be00, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fa0d0ff627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fa0d0ff8d05 in QThreadPrivate::start (arg=0x1a92790) at thread/qthread_unix.cpp:331
#8  0x00007fa0d0a56efc in start_thread (arg=0x7fa0b7d4c700) at pthread_create.c:304
#9  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7fa0b6ed4700 (LWP 4224)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa0d5e83fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fa0d5e84019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fa0d0a56efc in start_thread (arg=0x7fa0b6ed4700) at pthread_create.c:304
#4  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fa0b5a11700 (LWP 4225)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa0d0ff91ab in wait (time=18446744073709551615, this=0x1959140) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x194efe0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa0d3009864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1958570, th=0x1e5f120) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa0d300be0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1959fe0, th=0x1e5f120) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa0d300accf in ThreadWeaver::ThreadRunHelper::run (this=0x7fa0b5a10e20, parent=0x1958570, th=0x1e5f120) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa0d300ad5b in ThreadWeaver::Thread::run (this=0x1e5f120) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa0d0ff8d05 in QThreadPrivate::start (arg=0x1e5f120) at thread/qthread_unix.cpp:331
#8  0x00007fa0d0a56efc in start_thread (arg=0x7fa0b5a11700) at pthread_create.c:304
#9  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fa0aefbf700 (LWP 4226)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fa0aefbeaf0 in ?? ()
#2  0x00007fff1e5d47e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 7 (Thread 0x7fa06a8d4700 (LWP 4238)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa0d0ff91ab in wait (time=18446744073709551615, this=0x1959140) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x194efe0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa0d3009864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1958570, th=0x2303390) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa0d300be0b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1959fe0, th=0x2303390) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa0d300accf in ThreadWeaver::ThreadRunHelper::run (this=0x7fa06a8d3e20, parent=0x1958570, th=0x2303390) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa0d300ad5b in ThreadWeaver::Thread::run (this=0x2303390) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa0d0ff8d05 in QThreadPrivate::start (arg=0x2303390) at thread/qthread_unix.cpp:331
#8  0x00007fa0d0a56efc in start_thread (arg=0x7fa06a8d4700) at pthread_create.c:304
#9  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fa066f2e700 (LWP 4259)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa0695a81f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007fa0d0a56efc in start_thread (arg=0x7fa066f2e700) at pthread_create.c:304
#3  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fa06672d700 (LWP 4260)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa0695a81f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007fa0d0a56efc in start_thread (arg=0x7fa06672d700) at pthread_create.c:304
#3  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fa065f2c700 (LWP 4261)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa0695a81f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007fa0d0a56efc in start_thread (arg=0x7fa065f2c700) at pthread_create.c:304
#3  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa058eee700 (LWP 4313)):
#0  0x00007fa0cee8989b in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fa0cee8a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa0cee8a792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa0573a29cb in ?? () from /usr/lib/gio/modules/libdconfsettings.so
#4  0x00007fa0ceeaf2b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa0d0a56efc in start_thread (arg=0x7fa058eee700) at pthread_create.c:304
#6  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa056b9c700 (LWP 4316)):
#0  0x00007fa0d6275773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa0cee89f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa0cee8a792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa068106516 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fa0ceeaf2b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa0d0a56efc in start_thread (arg=0x7fa056b9c700) at pthread_create.c:304
#6  0x00007fa0d628189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa0d6a50780 (LWP 4221)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fa0d32527ee in KParts::StatusBarExtension::statusBar (this=0x5694c10) at ../../kparts/statusbarextension.cpp:149
#8  0x00007fa0d3252cf4 in KParts::StatusBarExtension::~StatusBarExtension (this=0x5694c10, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:99
#9  0x00007fa0d32530a9 in KParts::StatusBarExtension::~StatusBarExtension (this=0x5694c10, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:110
#10 0x00007fa0d10f1d75 in QObjectPrivate::deleteChildren (this=0x56979c0) at kernel/qobject.cpp:1955
#11 0x00007fa0d10f7349 in QObject::~QObject (this=0x5698020, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007fa0d3237688 in KParts::Part::~Part (this=0x5698020, __vtt_parm=0x7fa0631da890, __in_chrg=<optimized out>) at ../../kparts/part.cpp:190
#13 0x00007fa062fd5edc in ?? () from /usr/lib/kde4/dragonpart.so
#14 0x00007fa0d32378f0 in KParts::Part::slotWidgetDestroyed (this=0x5698020) at ../../kparts/part.cpp:353
#15 0x00007fa0d3238ed4 in KParts::Part::qt_metacall (this=0x5698020, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1e4b7210) at ./part.moc:82
#16 0x00007fa0d323aab5 in KParts::ReadOnlyPart::qt_metacall (this=0x5698020, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1e4b7210) at ./part.moc:168
#17 0x00007fa062fd5d15 in ?? () from /usr/lib/kde4/dragonpart.so
#18 0x00007fa0d10f2eba in QMetaObject::activate (sender=0x5697540, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1e4b7210) at kernel/qobject.cpp:3278
#19 0x00007fa0d10f336f in QObject::destroyed (this=<optimized out>, _t1=0x5697540) at .moc/release-shared/moc_qobject.cpp:149
#20 0x00007fa0d10f6ef7 in QObject::~QObject (this=0x5697540, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#21 0x00007fa0d165c162 in QWidget::~QWidget (this=0x5697540, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#22 0x00007fa0d165c379 in QWidget::~QWidget (this=0x5697540, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#23 0x00007fa0d10f6a88 in QObject::event (this=0x5697540, e=<optimized out>) at kernel/qobject.cpp:1200
#24 0x00007fa0d16606eb in QWidget::event (this=0x5697540, event=0x5400f10) at kernel/qwidget.cpp:8754
#25 0x00007fa0d1610424 in notify_helper (e=0x5400f10, receiver=0x5697540, this=0x17b8930) at kernel/qapplication.cpp:4486
#26 QApplicationPrivate::notify_helper (this=0x17b8930, receiver=0x5697540, e=0x5400f10) at kernel/qapplication.cpp:4458
#27 0x00007fa0d1615291 in QApplication::notify (this=0x7fff1e4b7d30, receiver=0x5697540, e=0x5400f10) at kernel/qapplication.cpp:4365
#28 0x00007fa0d3b48126 in KApplication::notify (this=0x7fff1e4b7d30, receiver=0x5697540, event=0x5400f10) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007fa0d10dfafc in QCoreApplication::notifyInternal (this=0x7fff1e4b7d30, receiver=0x5697540, event=0x5400f10) at kernel/qcoreapplication.cpp:787
#30 0x00007fa0d10e351f in sendEvent (event=0x5400f10, receiver=0x5697540) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1785430) at kernel/qcoreapplication.cpp:1428
#32 0x00007fa0d110aa73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007fa0cee89a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007fa0cee8a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007fa0cee8a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007fa0d110aed6 in QEventDispatcherGlib::processEvents (this=0x1786f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#38 0x00007fa0d16b807e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007fa0d10decf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007fa0d10deef7 in QEventLoop::exec (this=0x7fff1e4b7cc0, flags=...) at kernel/qeventloop.cpp:201
#41 0x00007fa0d10e3789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#42 0x00007fa0d6633b97 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_rekonq.so
#43 0x00007fa0d61c130d in __libc_start_main (main=0x400630, argc=1, ubp_av=0x7fff1e4b86c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff1e4b86b8) at libc-start.c:226
#44 0x0000000000400661 in _start ()

Possible duplicates by query: bug 291111, bug 290480, bug 290329, bug 287007, bug 283657.

Reported using DrKonqi
Comment 1 Andrea Diamantini 2012-01-14 23:10:19 UTC

*** This bug has been marked as a duplicate of bug 291111 ***