Bug 290480 - It does not help
Summary: It does not help
Status: RESOLVED DUPLICATE of bug 291111
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.8.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-03 10:40 UTC by Keijo
Modified: 2012-01-14 23:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keijo 2012-01-03 10:40:10 UTC
Application: rekonq (0.8.0)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I pressed the update button to refresh the page.

- Custom settings of the application:
Distribution: Kubuntu 11.10
It does not help korjatkaa defects, and laws to ensure a proper bug report voipi as a windos when a fault appears on the label of the weighs you only need to send the data does not change.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f29c2195780 (LWP 2259))]

Thread 11 (Thread 0x7f29add79700 (LWP 2260)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f29c0a71c2c in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f29c1428220) at wtf/FastMalloc.cpp:2495
#2  0x00007f29c0a71d59 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f29bc1a5efc in start_thread (arg=0x7f29add79700) at pthread_create.c:304
#4  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f29ad468700 (LWP 2261)):
#0  0x00007f29c19c4773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f29ba5d8f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f29ba5d9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f29bc859f3e in QEventDispatcherGlib::processEvents (this=0x12edef0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f29bc82dcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f29bc82def7 in QEventLoop::exec (this=0x7f29ad467e00, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f29bc74527f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f29bc747d05 in QThreadPrivate::start (arg=0x1240280) at thread/qthread_unix.cpp:331
#8  0x00007f29bc1a5efc in start_thread (arg=0x7f29ad468700) at pthread_create.c:304
#9  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f29ac5e0700 (LWP 2262)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f29c15d2fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f29c15d3019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f29bc1a5efc in start_thread (arg=0x7f29ac5e0700) at pthread_create.c:304
#4  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f29ab100700 (LWP 2263)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f29bc7481ab in wait (time=18446744073709551615, this=0xfaa550) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xfaa760, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f29be758864 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xfac2e0, th=0x134ca20) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f29be75ae0b in ThreadWeaver::WorkingHardState::applyForWork (this=0xfaa8c0, th=0x134ca20) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f29be759ccf in ThreadWeaver::ThreadRunHelper::run (this=0x7f29ab0ffe20, parent=0xfac2e0, th=0x134ca20) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f29be759d5b in ThreadWeaver::Thread::run (this=0x134ca20) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f29bc747d05 in QThreadPrivate::start (arg=0x134ca20) at thread/qthread_unix.cpp:331
#8  0x00007f29bc1a5efc in start_thread (arg=0x7f29ab100700) at pthread_create.c:304
#9  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f2963fff700 (LWP 2265)):
#0  0x00007f29c19c4773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f29ba5d8f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f29ba5d9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f29bc859f3e in QEventDispatcherGlib::processEvents (this=0x12adda0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f29bc82dcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f29bc82def7 in QEventLoop::exec (this=0x7f2963ffedd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f29bc74527f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f29bc810cbf in QInotifyFileSystemWatcherEngine::run (this=0x158bb20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f29bc747d05 in QThreadPrivate::start (arg=0x158bb20) at thread/qthread_unix.cpp:331
#9  0x00007f29bc1a5efc in start_thread (arg=0x7f2963fff700) at pthread_create.c:304
#10 0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f29601f6700 (LWP 2275)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2962a8b1f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007f29bc1a5efc in start_thread (arg=0x7f29601f6700) at pthread_create.c:304
#3  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f295f9f5700 (LWP 2276)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2962a8b1f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007f29bc1a5efc in start_thread (arg=0x7f295f9f5700) at pthread_create.c:304
#3  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f295f1f4700 (LWP 2277)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2962a8b1f1 in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00007f29bc1a5efc in start_thread (arg=0x7f295f1f4700) at pthread_create.c:304
#3  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f295167e700 (LWP 2294)):
#0  0x00007f29c19c4773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f29ba5d8f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f29ba5d9792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f294fb329cb in ?? () from /usr/lib/gio/modules/libdconfsettings.so
#4  0x00007f29ba5fe2b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f29bc1a5efc in start_thread (arg=0x7f295167e700) at pthread_create.c:304
#6  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f294fb2d700 (LWP 2296)):
#0  0x00007f29ba5d83b2 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f29ba5d8e6a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f29ba5d9792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f29615e9516 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f29ba5fe2b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f29bc1a5efc in start_thread (arg=0x7f294fb2d700) at pthread_create.c:304
#6  0x00007f29c19d089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f29c2195780 (LWP 2259)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f29be9a17ee in KParts::StatusBarExtension::statusBar (this=0x1527200) at ../../kparts/statusbarextension.cpp:149
#8  0x00007f29be9a1cf4 in KParts::StatusBarExtension::~StatusBarExtension (this=0x1527200, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:99
#9  0x00007f29be9a20a9 in KParts::StatusBarExtension::~StatusBarExtension (this=0x1527200, __in_chrg=<optimized out>) at ../../kparts/statusbarextension.cpp:110
#10 0x00007f29bc840d75 in QObjectPrivate::deleteChildren (this=0x192ef60) at kernel/qobject.cpp:1955
#11 0x00007f29bc846349 in QObject::~QObject (this=0x192f6e0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#12 0x00007f29be986688 in KParts::Part::~Part (this=0x192f6e0, __vtt_parm=0x7f295b2ec890, __in_chrg=<optimized out>) at ../../kparts/part.cpp:190
#13 0x00007f295b0e7edc in ?? () from /usr/lib/kde4/dragonpart.so
#14 0x00007f29be9868f0 in KParts::Part::slotWidgetDestroyed (this=0x192f6e0) at ../../kparts/part.cpp:353
#15 0x00007f29be987ed4 in KParts::Part::qt_metacall (this=0x192f6e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2a7e3550) at ./part.moc:82
#16 0x00007f29be989ab5 in KParts::ReadOnlyPart::qt_metacall (this=0x192f6e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2a7e3550) at ./part.moc:168
#17 0x00007f295b0e7d15 in ?? () from /usr/lib/kde4/dragonpart.so
#18 0x00007f29bc841eba in QMetaObject::activate (sender=0x134df00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff2a7e3550) at kernel/qobject.cpp:3278
#19 0x00007f29bc84236f in QObject::destroyed (this=<optimized out>, _t1=0x134df00) at .moc/release-shared/moc_qobject.cpp:149
#20 0x00007f29bc845ef7 in QObject::~QObject (this=0x134df00, __in_chrg=<optimized out>) at kernel/qobject.cpp:843
#21 0x00007f29bcdab162 in QWidget::~QWidget (this=0x134df00, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#22 0x00007f29bcdab379 in QWidget::~QWidget (this=0x134df00, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#23 0x00007f29bc845a88 in QObject::event (this=0x134df00, e=<optimized out>) at kernel/qobject.cpp:1200
#24 0x00007f29bcdaf6eb in QWidget::event (this=0x134df00, event=0x1511420) at kernel/qwidget.cpp:8754
#25 0x00007f29bcd5f424 in notify_helper (e=0x1511420, receiver=0x134df00, this=0xe569b0) at kernel/qapplication.cpp:4486
#26 QApplicationPrivate::notify_helper (this=0xe569b0, receiver=0x134df00, e=0x1511420) at kernel/qapplication.cpp:4458
#27 0x00007f29bcd64291 in QApplication::notify (this=0x7fff2a7e4070, receiver=0x134df00, e=0x1511420) at kernel/qapplication.cpp:4365
#28 0x00007f29bf297126 in KApplication::notify (this=0x7fff2a7e4070, receiver=0x134df00, event=0x1511420) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007f29bc82eafc in QCoreApplication::notifyInternal (this=0x7fff2a7e4070, receiver=0x134df00, event=0x1511420) at kernel/qcoreapplication.cpp:787
#30 0x00007f29bc83251f in sendEvent (event=0x1511420, receiver=0x134df00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xe23430) at kernel/qcoreapplication.cpp:1428
#32 0x00007f29bc859a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f29ba5d8a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f29ba5d9258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f29ba5d9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f29bc859ed6 in QEventDispatcherGlib::processEvents (this=0xe24f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#38 0x00007f29bce0707e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f29bc82dcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007f29bc82def7 in QEventLoop::exec (this=0x7fff2a7e4000, flags=...) at kernel/qeventloop.cpp:201
#41 0x00007f29bc832789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#42 0x00007f29c1d82b97 in kdemain (argc=1, argv=<optimized out>) at /build/buildd/rekonq-0.8.0/src/main.cpp:215
#43 0x00007f29c191030d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=1, ubp_av=0x7fff2a7e4a08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff2a7e49f8) at libc-start.c:226
#44 0x0000000000400661 in _start ()

Possible duplicates by query: bug 290329, bug 287007, bug 283657.

Reported using DrKonqi
Comment 1 Andrea Diamantini 2012-01-14 23:10:11 UTC

*** This bug has been marked as a duplicate of bug 291111 ***