Bug 291266 - Muhon is crached est craché
Summary: Muhon is crached est craché
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-11 13:45 UTC by Aurélien57
Modified: 2012-01-16 12:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aurélien57 2012-01-11 13:45:21 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I was starting the application when it was crached. I could see the windows.

J'ai démaré l'application quand elle a craché. J'ai pu voir la fenêtre

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77a7930 (LWP 3550))]

Thread 2 (Thread 0xb53d8b70 (LWP 3554)):
#0  0x00cf6d10 in __GI_clock_gettime (clock_id=1, tp=0xb53d8028) at ../sysdeps/unix/clock_gettime.c:116
#1  0x006ac7d5 in do_gettime (frac=0xb53d8020, sec=0xb53d8018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x0077f4b6 in QTimerInfoList::updateCurrentTime (this=0x86750cc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0077f80a in QTimerInfoList::timerWait (this=0x86750cc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0077e053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb53d812c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0077e0ed in timerSourcePrepare (source=0x8675098, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x06b3688c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06b37637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06b37c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0077eb37 in QEventDispatcherGlib::processEvents (this=0x84e40b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x0074f1dd in QEventLoop::processEvents (this=0xb53d82b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x0074f421 in QEventLoop::exec (this=0xb53d82b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0065290b in QThread::exec (this=0x851dda8) at thread/qthread.cpp:498
#14 0x0072fe2d in QInotifyFileSystemWatcherEngine::run (this=0x851dda8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x006557b3 in QThreadPrivate::start (arg=0x851dda8) at thread/qthread_unix.cpp:331
#16 0x00cded31 in start_thread (arg=0xb53d8b70) at pthread_create.c:304
#17 0x00a3c0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77a7930 (LWP 3550)):
[KCrash Handler]
#7  0x006a9e11 in QtPrivate::QStringList_contains (that=0xbf840a04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf840a04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x846a860) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x846a860, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf840c24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00756b7d in metacall (argv=0xbf840c24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x846a860) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x846a860, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf840c24) at kernel/qmetaobject.cpp:232
#13 0x00765a6a in QMetaObject::activate (sender=0x8394fc0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8394fc0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8394fc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf840d68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00756b7d in metacall (argv=0xbf840d68, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8394fc0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8394fc0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf840d68) at kernel/qmetaobject.cpp:232
#18 0x00765a6a in QMetaObject::activate (sender=0x846a860, m=0x80950c0, local_signal_index=0, argv=0xbf840d68) at kernel/qobject.cpp:3278
#19 0x009367c5 in MuonMainWindow::backendReady (this=0x846a860, _t1=0x852bec0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00936933 in MuonMainWindow::initObject (this=0x846a860) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x846a860) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x846a860, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf840e94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00756b7d in metacall (argv=0xbf840e94, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x846a860) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x846a860, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf840e94) at kernel/qmetaobject.cpp:232
#25 0x00765a6a in QMetaObject::activate (sender=0x84f31f8, m=0x886238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0076d375 in QSingleShotTimer::timeout (this=0x84f31f8) at .moc/release-shared/qtimer.moc:82
#27 0x0076d42c in QSingleShotTimer::timerEvent (this=0x84f31f8) at kernel/qtimer.cpp:308
#28 0x00768994 in QObject::event (this=0x84f31f8, e=0xbf84128c) at kernel/qobject.cpp:1181
#29 0x027a9d54 in notify_helper (e=0xbf84128c, receiver=0x84f31f8, this=0x839ef40) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x839ef40, receiver=0x84f31f8, e=0xbf84128c) at kernel/qapplication.cpp:4458
#31 0x027af103 in QApplication::notify (this=0xbf84128c, receiver=0x84f31f8, e=0xbf84128c) at kernel/qapplication.cpp:3886
#32 0x01071681 in KApplication::notify (this=0xbf8415a0, receiver=0x84f31f8, event=0xbf84128c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0075019e in QCoreApplication::notifyInternal (this=0xbf8415a0, receiver=0x84f31f8, event=0xbf84128c) at kernel/qcoreapplication.cpp:787
#34 0x00780c10 in sendEvent (event=0xbf84128c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x83a1bcc) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0077e122 in timerSourceDispatch (source=0x83a1b98) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06b3725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06b37990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06b37c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0077eada in QEventDispatcherGlib::processEvents (this=0x8381238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02861e3a in QGuiEventDispatcherGlib::processEvents (this=0x8381238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0074f1dd in QEventLoop::processEvents (this=0xbf841504, flags=...) at kernel/qeventloop.cpp:149
#43 0x0074f421 in QEventLoop::exec (this=0xbf841504, flags=...) at kernel/qeventloop.cpp:201
#44 0x0075419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x027a78f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-11 13:49:10 UTC

*** This bug has been marked as a duplicate of bug 291262 ***