Bug 290007 - Power down > Plasma screen bug ? ...
Summary: Power down > Plasma screen bug ? ...
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 266545 290079 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-28 11:56 UTC by Boilley Adrien
Modified: 2012-01-09 08:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Boilley Adrien 2011-12-28 11:56:10 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Each time i want to power down my computer, i have bug rapport opened up on my desktop. I don't know why, plasma screen bug, i think...

(I have a netbook PC - HP Pav DV9000 - Kubuntu 11.10)

- Unusual behavior I noticed:

The crash can be reproduced every time.

-- Backtrace:
Application: Outil de gestion de fenêtres Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1134730 (LWP 1557))]

Thread 8 (Thread 0xa9d4fb70 (LWP 1563)):
#0  0xb2f6ad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb63567d5 in do_gettime (frac=0xa9d4f000, sec=0xa9d4eff8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb64294b6 in QTimerInfoList::updateCurrentTime (this=0x9e15bb4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb642980a in QTimerInfoList::timerWait (this=0x9e15bb4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6428053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa9d4f10c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb64280ed in timerSourcePrepare (source=0x9e15b80, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb2eaf88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2eb0637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb2eb0c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6428b37 in QEventDispatcherGlib::processEvents (this=0x9e15c40, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb63f91dd in QEventLoop::processEvents (this=0xa9d4f290, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63f9421 in QEventLoop::exec (this=0xa9d4f290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb62fc90b in QThread::exec (this=0x9e15490) at thread/qthread.cpp:498
#14 0xb63d9e2d in QInotifyFileSystemWatcherEngine::run (this=0x9e15490) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb62ff7b3 in QThreadPrivate::start (arg=0x9e15490) at thread/qthread_unix.cpp:331
#16 0xb2fcad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb75dd0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 7 (Thread 0xa8221b70 (LWP 1564)):
#0  0xb2f6ad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb63567d5 in do_gettime (frac=0xa8221000, sec=0xa8220ff8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb64294b6 in QTimerInfoList::updateCurrentTime (this=0x9fb0634) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb642980a in QTimerInfoList::timerWait (this=0x9fb0634, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6428053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa822110c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb64280ed in timerSourcePrepare (source=0x9fb0600, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb2eaf88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2eb0637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb2eb0c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6428b37 in QEventDispatcherGlib::processEvents (this=0x9d12e38, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb63f91dd in QEventLoop::processEvents (this=0xa8221290, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63f9421 in QEventLoop::exec (this=0xa8221290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb62fc90b in QThread::exec (this=0x9f865d0) at thread/qthread.cpp:498
#14 0xb63d9e2d in QInotifyFileSystemWatcherEngine::run (this=0x9f865d0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb62ff7b3 in QThreadPrivate::start (arg=0x9f865d0) at thread/qthread_unix.cpp:331
#16 0xb2fcad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb75dd0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 6 (Thread 0xa6521b70 (LWP 1567)):
#0  0xa6d8492e in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#1  0xb2eaf88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2eb0637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2eb0f9b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xa6de3cea in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#5  0xb2ed75f4 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb2fcad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#7  0xb75dd0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 5 (Thread 0xa5187b70 (LWP 2807)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb2fcea5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75eacfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb62ffcc0 in wait (time=4294967295, this=0x9e9e848) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9e75db0, mutex=0x9e5d3e8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0xb379e406 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9e75d98, th=0xbbe2d00) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb37a0ecb in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9e5d5b8, th=0xbbe2d00) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb379e03a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9e75d98, th=0xbbe2d00) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb37a0fcc in ThreadWeaver::WorkingHardState::applyForWork (this=0x9e5d5b8, th=0xbbe2d00) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb379df93 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9e75d98, th=0xbbe2d00, previous=0xa0f4770) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb379fb14 in ThreadWeaver::ThreadRunHelper::run (this=0xa51872f4, parent=0x9e75d98, th=0xbbe2d00) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb379fbca in ThreadWeaver::Thread::run (this=0xbbe2d00) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb62ff7b3 in QThreadPrivate::start (arg=0xbbe2d00) at thread/qthread_unix.cpp:331
#13 0xb2fcad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0xb75dd0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 4 (Thread 0xa7669b70 (LWP 2808)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb2fcea5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75eacfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb62ffcc0 in wait (time=4294967295, this=0x9e9e848) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9e75db0, mutex=0x9e5d3e8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0xb379e406 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9e75d98, th=0xa167f20) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb37a0ecb in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9e5d5b8, th=0xa167f20) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb379e03a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9e75d98, th=0xa167f20) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb37a0fcc in ThreadWeaver::WorkingHardState::applyForWork (this=0x9e5d5b8, th=0xa167f20) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb379df93 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9e75d98, th=0xa167f20, previous=0x9979648) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb379fb14 in ThreadWeaver::ThreadRunHelper::run (this=0xa76692f4, parent=0x9e75d98, th=0xa167f20) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb379fbca in ThreadWeaver::Thread::run (this=0xa167f20) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb62ff7b3 in QThreadPrivate::start (arg=0xa167f20) at thread/qthread_unix.cpp:331
#13 0xb2fcad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0xb75dd0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xa6d22b70 (LWP 2809)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb2fcea5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75eacfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb62ffcc0 in wait (time=4294967295, this=0x9e9e848) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9e75db0, mutex=0x9e5d3e8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0xb379e406 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9e75d98, th=0xacf9f38) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb37a0ecb in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9e5d5b8, th=0xacf9f38) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb379e03a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9e75d98, th=0xacf9f38) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb37a0fcc in ThreadWeaver::WorkingHardState::applyForWork (this=0x9e5d5b8, th=0xacf9f38) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb379df93 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9e75d98, th=0xacf9f38, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb37a0fe8 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9e5d5b8, th=0xacf9f38) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#11 0xb379df93 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9e75d98, th=0xacf9f38, previous=0xa09bcf0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#12 0xb379fb14 in ThreadWeaver::ThreadRunHelper::run (this=0xa6d222f4, parent=0x9e75d98, th=0xacf9f38) at ../../../threadweaver/Weaver/Thread.cpp:87
#13 0xb379fbca in ThreadWeaver::Thread::run (this=0xacf9f38) at ../../../threadweaver/Weaver/Thread.cpp:142
#14 0xb62ff7b3 in QThreadPrivate::start (arg=0xacf9f38) at thread/qthread_unix.cpp:331
#15 0xb2fcad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#16 0xb75dd0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa2e0ab70 (LWP 2810)):
#0  0xb771b424 in __kernel_vsyscall ()
#1  0xb2fcea5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75eacfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb62ffcc0 in wait (time=4294967295, this=0x9e9e848) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9e75db0, mutex=0x9e5d3e8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0xb379e406 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9e75d98, th=0xa0e09b0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb37a0ecb in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9e5d5b8, th=0xa0e09b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb379e03a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9e75d98, th=0xa0e09b0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb37a0fcc in ThreadWeaver::WorkingHardState::applyForWork (this=0x9e5d5b8, th=0xa0e09b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb379df93 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9e75d98, th=0xa0e09b0, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb37a0fe8 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9e5d5b8, th=0xa0e09b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#11 0xb379df93 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9e75d98, th=0xa0e09b0, previous=0xa0072a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#12 0xb379fb14 in ThreadWeaver::ThreadRunHelper::run (this=0xa2e0a2f4, parent=0x9e75d98, th=0xa0e09b0) at ../../../threadweaver/Weaver/Thread.cpp:87
#13 0xb379fbca in ThreadWeaver::Thread::run (this=0xa0e09b0) at ../../../threadweaver/Weaver/Thread.cpp:142
#14 0xb62ff7b3 in QThreadPrivate::start (arg=0xa0e09b0) at thread/qthread_unix.cpp:331
#15 0xb2fcad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#16 0xb75dd0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb1134730 (LWP 1557)):
[KCrash Handler]
#7  0xb5b4524b in QRasterWindowSurface::~QRasterWindowSurface (this=0xacd3230, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#8  0xb5b452e2 in QRasterWindowSurface::~QRasterWindowSurface (this=0xacd3230, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#9  0xb5b614b4 in QWidgetBackingStore::~QWidgetBackingStore (this=0xaceea60, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#10 0xb597874c in QWidgetBackingStoreTracker::destroy (this=0xa147138) at kernel/qwidget.cpp:210
#11 0xb59788a8 in QWidgetPrivate::deleteExtra (this=0x9c411f8) at kernel/qwidget.cpp:1796
#12 0xb5978abc in QWidgetPrivate::~QWidgetPrivate (this=0x9c411f8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:341
#13 0xb5978dd2 in QWidgetPrivate::~QWidgetPrivate (this=0x9c411f8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:346
#14 0xb6413491 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x9bdaafc, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x9bdaaf8, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#17 0xb597b02f in QWidget::~QWidget (this=0x9bdaaf8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#18 0xb597b262 in QWidget::~QWidget (this=0x9bdaaf8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#19 0xb5f755e8 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0xb6293270, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1825
#20 0xb753d981 in ?? () from /lib/i386-linux-gnu/libc.so.6
#21 0xb753da0d in exit () from /lib/i386-linux-gnu/libc.so.6
#22 0xb752411b in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#23 0x08048531 in _start ()

Possible duplicates by query: bug 289825, bug 288670, bug 288669, bug 288190, bug 287750.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-12-29 11:25:37 UTC
*** Bug 290079 has been marked as a duplicate of this bug. ***
Comment 2 Thijs 2012-01-09 08:43:15 UTC
*** Bug 266545 has been marked as a duplicate of this bug. ***
Comment 3 Thijs 2012-01-09 08:45:14 UTC

*** This bug has been marked as a duplicate of bug 261539 ***