Bug 289030 - Kmail2 crash after apply filters
Summary: Kmail2 crash after apply filters
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-15 09:23 UTC by Nikita Bige
Modified: 2011-12-17 11:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Bige 2011-12-15 09:23:53 UTC
Application: kmail (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.5-1.fc16.x86_64 x86_64
Distribution: "RFRemix release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
After apgrade from kmail1, create new filters
Manually apply filters on inbox

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f9e3a5c69c0 (LWP 16570))]

Thread 3 (Thread 0x7f9e2d9df700 (LWP 16655)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003d58b973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3d59590f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003d58b974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x000000353a007d90 in start_thread (arg=0x7f9e2d9df700) at pthread_create.c:309
#4  0x00000035398ef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f9e2d0c6700 (LWP 16656)):
#0  0x000000353a009dd5 in __pthread_mutex_lock (mutex=0x7f9e280009a8) at pthread_mutex_lock.c:65
#1  0x000000353b844043 in g_main_context_prepare (context=0x7f9e280009a0, priority=0x7f9e2d0c5a98) at gmain.c:2748
#2  0x000000353b844e1d in g_main_context_iterate (context=0x7f9e280009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3053
#3  0x000000353b84544c in g_main_context_iteration (context=0x7f9e280009a0, may_block=1) at gmain.c:3136
#4  0x0000003d4c7a79c6 in QEventDispatcherGlib::processEvents (this=0x7f9e280008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003d4c777dc2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003d4c778017 in QEventLoop::exec (this=0x7f9e2d0c5bc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003d4c678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003d4c67bb1b in QThreadPrivate::start (arg=0x11ea3a0) at thread/qthread_unix.cpp:298
#9  0x000000353a007d90 in start_thread (arg=0x7f9e2d0c6700) at pthread_create.c:309
#10 0x00000035398ef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f9e3a5c69c0 (LWP 16570)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x59731a0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x0000003d4d0f4e99 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x59731a0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003d4c791b26 in QObject::event (this=0x59731a0, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x0000003d4dfc96f4 in notify_helper (e=0x7f9dcc001be0, receiver=0x59731a0, this=0xd88670) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0xd88670, receiver=0x59731a0, e=0x7f9dcc001be0) at kernel/qapplication.cpp:4490
#11 0x0000003d4dfce573 in QApplication::notify (this=0x7fff9a8ae7f0, receiver=0x59731a0, e=0x7f9dcc001be0) at kernel/qapplication.cpp:4379
#12 0x0000003d4f250766 in KApplication::notify (this=0x7fff9a8ae7f0, receiver=0x59731a0, event=0x7f9dcc001be0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x0000003d4c778c8c in QCoreApplication::notifyInternal (this=0x7fff9a8ae7f0, receiver=0x59731a0, event=0x7f9dcc001be0) at kernel/qcoreapplication.cpp:876
#14 0x0000003d4c77c71a in sendEvent (event=0x7f9dcc001be0, receiver=0x59731a0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xd2e210) at kernel/qcoreapplication.cpp:1500
#16 0x0000003d4c7a7533 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0xd8bf00) at kernel/qeventdispatcher_glib.cpp:279
#18 0x000000353b844a7d in g_main_dispatch (context=0xd8ad10) at gmain.c:2425
#19 g_main_context_dispatch (context=0xd8ad10) at gmain.c:2995
#20 0x000000353b845278 in g_main_context_iterate (context=0xd8ad10, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x000000353b84544c in g_main_context_iteration (context=0xd8ad10, may_block=1) at gmain.c:3136
#22 0x0000003d4c7a795f in QEventDispatcherGlib::processEvents (this=0xd2faf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x0000003d4e06c2ce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003d4c777dc2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003d4c778017 in QEventLoop::exec (this=0x7fff9a8ae6c0, flags=...) at kernel/qeventloop.cpp:204
#26 0x0000003d4c77ca15 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x0000000000402d23 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.7.4/kmail/main.cpp:145

Possible duplicates by query: bug 287990, bug 287970, bug 286635.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-17 11:00:39 UTC

*** This bug has been marked as a duplicate of bug 286307 ***