Bug 286635 - Kmail crashes (segfault) after upgrade to Kmail2
Summary: Kmail crashes (segfault) after upgrade to Kmail2
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-14 22:45 UTC by Roberto Zedda
Modified: 2011-12-04 10:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto Zedda 2011-11-14 22:45:53 UTC
Application: kmail (4.7.2)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-7.fc16.i686.PAE i686
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

Apertura della mailbox "inbox". Disattivando Nepomuk pare non presentarsi l'errore....

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb7889780 (LWP 2701))]

Thread 3 (Thread 0xb6790b40 (LWP 2705)):
#0  0x00719416 in __kernel_vsyscall ()
#1  0x426fc84c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x485682b3 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x48cbbc40) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#3  0x485683d0 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x48cbbc40) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#4  0x426f8cd3 in start_thread (arg=0xb6790b40) at pthread_create.c:309
#5  0x426034de in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xb5e67b40 (LWP 2706)):
#0  0x42732001 in __GI_clock_gettime (clock_id=1, tp=0xb5e66ff8) at ../sysdeps/unix/clock_gettime.c:116
#1  0x432d8056 in do_gettime (frac=0xb5e66ff0, sec=0xb5e66fe8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x433c0aa7 in QTimerInfoList::updateCurrentTime (this=0xb5501abc) at kernel/qeventdispatcher_unix.cpp:343
#4  0x433c06fe in timerSourceCheckHelper (src=0xb5501a88) at kernel/qeventdispatcher_glib.cpp:150
#5  timerSourceCheckHelper (src=0xb5501a88) at kernel/qeventdispatcher_glib.cpp:144
#6  0x42a2427c in g_main_context_check (context=0xb55004e0, max_priority=2147483647, fds=0xb5500de8, n_fds=1) at gmain.c:2943
#7  0x42a24c60 in g_main_context_iterate (context=0xb55004e0, block=1117992864, dispatch=1, self=0xb5500d70) at gmain.c:3070
#8  0x42a24faf in g_main_context_iteration (context=0xb55004e0, may_block=1) at gmain.c:3136
#9  0x433c01c7 in QEventDispatcherGlib::processEvents (this=0xb5500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#10 0x4338c3ae in QEventLoop::processEvents (this=0xb5e67230, flags=...) at kernel/qeventloop.cpp:149
#11 0x4338c659 in QEventLoop::exec (this=0xb5e67230, flags=...) at kernel/qeventloop.cpp:204
#12 0x4327603c in QThread::exec (this=0x88a27b0) at thread/qthread.cpp:501
#13 0x4327612c in QThread::run (this=0x88a27b0) at thread/qthread.cpp:568
#14 0x432795c1 in QThreadPrivate::start (arg=0x88a27b0) at thread/qthread_unix.cpp:298
#15 0x426f8cd3 in start_thread (arg=0xb5e67b40) at pthread_create.c:309
#16 0x426034de in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7889780 (LWP 2701)):
[KCrash Handler]
#7  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x908cb28, hm=) at access/qnetworkaccesshttpbackend.cpp:827
#8  0x437ded1d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x908cb28, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xadad8b0) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0x4339f612 in QMetaCallEvent::placeMetaCall (this=0xa200610, object=0x908cb28) at kernel/qobject.cpp:524
#10 0x433a82db in QObject::event (this=0x908cb28, e=0xa200610) at kernel/qobject.cpp:1194
#11 0x43ddca34 in notify_helper (e=0xa200610, receiver=0x908cb28, this=0x85110e0) at kernel/qapplication.cpp:4518
#12 QApplicationPrivate::notify_helper (this=0x85110e0, receiver=0x908cb28, e=0xa200610) at kernel/qapplication.cpp:4490
#13 0x43de1ed3 in QApplication::notify (this=0xa200610, receiver=0x908cb28, e=0xa200610) at kernel/qapplication.cpp:4247
#14 0x449dbfa2 in KApplication::notify (this=0xbfa7fb0c, receiver=0x908cb28, event=0xa200610) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#15 0x4338d4be in QCoreApplication::notifyInternal (this=0xbfa7fb0c, receiver=0x908cb28, event=0xa200610) at kernel/qcoreapplication.cpp:876
#16 0x43391418 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x84d8148) at kernel/qcoreapplication.cpp:1500
#18 0x4339174d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#19 0x433bfd65 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x85135d0) at kernel/qeventdispatcher_glib.cpp:279
#21 0x42a245bf in g_main_dispatch (context=0x8513200) at gmain.c:2425
#22 g_main_context_dispatch (context=0x8513200) at gmain.c:2995
#23 0x42a24d00 in g_main_context_iterate (context=0x8513200, block=1117992864, dispatch=1, self=0x8511230) at gmain.c:3073
#24 0x42a24faf in g_main_context_iteration (context=0x8513200, may_block=1) at gmain.c:3136
#25 0x433c0168 in QEventDispatcherGlib::processEvents (this=0x84d8ea0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0x43e9138b in QGuiEventDispatcherGlib::processEvents (this=0x84d8ea0, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#27 0x4338c3ae in QEventLoop::processEvents (this=0xbfa7fa24, flags=...) at kernel/qeventloop.cpp:149
#28 0x4338c659 in QEventLoop::exec (this=0xbfa7fa24, flags=...) at kernel/qeventloop.cpp:204
#29 0x433917fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x43dda835 in QApplication::exec () at kernel/qapplication.cpp:3779
#31 0x0804a3d2 in main (argc=3, argv=0xbfa7fcb4) at /usr/src/debug/kdepim-4.7.2/kmail/main.cpp:145

Reported using DrKonqi
Comment 1 Laurent Montel 2011-11-15 10:34:42 UTC
Apertura della mailbox "inbox". Disattivando Nepomuk pare non presentarsi
l'errore...." don't understand.
Please english.
Comment 2 Roberto Zedda 2011-11-15 11:04:00 UTC
Hi 
sorry.. :-)
I just pointed out that the problem seemed fixed deactivating Nepomuk... but it happened again a while later...
Please tell me if I can help further.
Regards
Roberto
Comment 3 Christophe Giboudeaux 2011-12-04 10:56:08 UTC

*** This bug has been marked as a duplicate of bug 286307 ***