Bug 287970 - Crashed when opening message
Summary: Crashed when opening message
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 08:48 UTC by Dave Gordon
Modified: 2011-12-04 10:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gordon 2011-12-01 08:48:01 UTC
Application: kmail (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
I had just finished applying a couple of new rules - simply moving files with a particular from address to their relevant folders.
I then selected a new email that was received
It was HTML and I had to click on the first show HTML link prior to the show images link
When the crash occurred.

The crash does not seem to be reproducible.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f6aae000840 (LWP 1036))]

Thread 6 (Thread 0x7f6aa1dc2700 (LWP 1040)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000031a61973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x31a6b90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000031a61974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003181207d90 in start_thread (arg=0x7f6aa1dc2700) at pthread_create.c:309
#4  0x00000031806eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7f6aa14c1700 (LWP 1041)):
#0  g_main_context_prepare (context=0x7f6a9c0009a0, priority=0x7f6aa14c0c18) at gmain.c:2674
#1  0x0000003182a44e1d in g_main_context_iterate (context=0x7f6a9c0009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3053
#2  0x0000003182a4544c in g_main_context_iteration (context=0x7f6a9c0009a0, may_block=1) at gmain.c:3136
#3  0x000000318b7a6896 in QEventDispatcherGlib::processEvents (this=0x7f6a9c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x000000318b776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x000000318b776ed7 in QEventLoop::exec (this=0x7f6aa14c0d40, flags=...) at kernel/qeventloop.cpp:204
#6  0x000000318b678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x000000318b67bb1b in QThreadPrivate::start (arg=0x21d6a80) at thread/qthread_unix.cpp:298
#8  0x0000003181207d90 in start_thread (arg=0x7f6aa14c1700) at pthread_create.c:309
#9  0x00000031806eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f6a58ec3700 (LWP 1762)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000318b67bf8f in wait (time=30000, this=0x7f6a54006150) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6a540060f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000318b66f55f in QThreadPoolThread::run (this=0x7f6a540063a0) at concurrent/qthreadpool.cpp:141
#4  0x000000318b67bb1b in QThreadPrivate::start (arg=0x7f6a540063a0) at thread/qthread_unix.cpp:298
#5  0x0000003181207d90 in start_thread (arg=0x7f6a58ec3700) at pthread_create.c:309
#6  0x00000031806eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f6a53fff700 (LWP 1763)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000318b67bf8f in wait (time=30000, this=0x7f6a54006150) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6a540060f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000318b66f55f in QThreadPoolThread::run (this=0x7f6a5400a310) at concurrent/qthreadpool.cpp:141
#4  0x000000318b67bb1b in QThreadPrivate::start (arg=0x7f6a5400a310) at thread/qthread_unix.cpp:298
#5  0x0000003181207d90 in start_thread (arg=0x7f6a53fff700) at pthread_create.c:309
#6  0x00000031806eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f6a537fe700 (LWP 1764)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000318b67bf8f in wait (time=30000, this=0x7f6a54006150) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6a540060f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000318b66f55f in QThreadPoolThread::run (this=0x7f6a5400e2f0) at concurrent/qthreadpool.cpp:141
#4  0x000000318b67bb1b in QThreadPrivate::start (arg=0x7f6a5400e2f0) at thread/qthread_unix.cpp:298
#5  0x0000003181207d90 in start_thread (arg=0x7f6a537fe700) at pthread_create.c:309
#6  0x00000031806eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f6aae000840 (LWP 1036)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3660040, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x000000318d0f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3660040, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x000000318b7909e6 in QObject::event (this=0x3660040, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x000000318e7c96f4 in notify_helper (e=0x7f6a5400add0, receiver=0x3660040, this=0x1c9c220) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x1c9c220, receiver=0x3660040, e=0x7f6a5400add0) at kernel/qapplication.cpp:4490
#11 0x000000318e7ce573 in QApplication::notify (this=0x7fff20503610, receiver=0x3660040, e=0x7f6a5400add0) at kernel/qapplication.cpp:4379
#12 0x0000003190250396 in KApplication::notify (this=0x7fff20503610, receiver=0x3660040, event=0x7f6a5400add0) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x000000318b777b4c in QCoreApplication::notifyInternal (this=0x7fff20503610, receiver=0x3660040, event=0x7f6a5400add0) at kernel/qcoreapplication.cpp:876
#14 0x000000318b77b5da in sendEvent (event=0x7f6a5400add0, receiver=0x3660040) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1c59210) at kernel/qcoreapplication.cpp:1500
#16 0x000000318b7a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x1cb1400) at kernel/qeventdispatcher_glib.cpp:279
#18 0x0000003182a44a7d in g_main_dispatch (context=0x1caf9e0) at gmain.c:2425
#19 g_main_context_dispatch (context=0x1caf9e0) at gmain.c:2995
#20 0x0000003182a45278 in g_main_context_iterate (context=0x1caf9e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x0000003182a4544c in g_main_context_iteration (context=0x1caf9e0, may_block=1) at gmain.c:3136
#22 0x000000318b7a682f in QEventDispatcherGlib::processEvents (this=0x1c5aaf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x000000318e86c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x000000318b776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x000000318b776ed7 in QEventLoop::exec (this=0x7fff205034e0, flags=...) at kernel/qeventloop.cpp:204
#26 0x000000318b77b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x0000000000402d23 in ?? ()
#28 0x000000318062169d in __libc_start_main (main=0x4022f0, argc=3, ubp_av=0x7fff20503a68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff20503a58) at libc-start.c:226
#29 0x0000000000403205 in _start ()

Possible duplicates by query: bug 286635.

Reported using DrKonqi
Comment 1 Bogdan Udrescu 2011-12-02 13:03:53 UTC
duplicate of bug 286635 if I'm not wrong
Comment 2 Christophe Giboudeaux 2011-12-04 10:55:51 UTC

*** This bug has been marked as a duplicate of bug 286307 ***