Bug 287990 - Kmail crash when delete messages from some sites
Summary: Kmail crash when delete messages from some sites
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 15:08 UTC by Christian Ortega
Modified: 2011-12-04 10:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
website example konqueror (and rekonq and kmail) crash which (679.84 KB, application/octet-stream)
2011-12-02 17:03 UTC, Christian Ortega
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ortega 2011-12-01 15:08:34 UTC
Application: kmail (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
I was deleting a html message when kmail crash. This ocurrs always that I delete messages of this sender (groupon.com.co) and some others senders that I can't remember in this moment, but all are html messages. Konqueror crash with this page too (groupon.com.co, youtube, others), so they may be related.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fca431fc840 (LWP 11505))]

Thread 3 (Thread 0x7fca36fd5700 (LWP 11531)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003994b973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3995590f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003994b974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003971207d90 in start_thread (arg=0x7fca36fd5700) at pthread_create.c:309
#4  0x00000039706eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fca366d4700 (LWP 11532)):
#0  0x00000039706e6373 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003972644f88 in g_main_context_poll (n_fds=1, fds=0x7fca300013e0, priority=<optimized out>, timeout=825, context=0x7fca300009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7fca300009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x000000397264544c in g_main_context_iteration (context=0x7fca300009a0, may_block=1) at gmain.c:3136
#4  0x000000397b7a6896 in QEventDispatcherGlib::processEvents (this=0x7fca300008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000397b776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000397b776ed7 in QEventLoop::exec (this=0x7fca366d3d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000397b678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000397b67bb1b in QThreadPrivate::start (arg=0x17c7190) at thread/qthread_unix.cpp:298
#9  0x0000003971207d90 in start_thread (arg=0x7fca366d4700) at pthread_create.c:309
#10 0x00000039706eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fca431fc840 (LWP 11505)):
[KCrash Handler]
#6  0x000000397d47053c in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x1d882b0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x000000397d4f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x1d882b0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x000000397b7909e6 in QObject::event (this=0x1d882b0, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x000000397efc96f4 in notify_helper (e=0x7fc9e000ca60, receiver=0x1d882b0, this=0x122f990) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x122f990, receiver=0x1d882b0, e=0x7fc9e000ca60) at kernel/qapplication.cpp:4490
#11 0x000000397efce573 in QApplication::notify (this=0x7fffde2c03b0, receiver=0x1d882b0, e=0x7fc9e000ca60) at kernel/qapplication.cpp:4379
#12 0x0000003980250396 in KApplication::notify (this=0x7fffde2c03b0, receiver=0x1d882b0, event=0x7fc9e000ca60) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x000000397b777b4c in QCoreApplication::notifyInternal (this=0x7fffde2c03b0, receiver=0x1d882b0, event=0x7fc9e000ca60) at kernel/qcoreapplication.cpp:876
#14 0x000000397b77b5da in sendEvent (event=0x7fc9e000ca60, receiver=0x1d882b0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x11e9210) at kernel/qcoreapplication.cpp:1500
#16 0x000000397b7a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x12408f0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x0000003972644a7d in g_main_dispatch (context=0x1240800) at gmain.c:2425
#19 g_main_context_dispatch (context=0x1240800) at gmain.c:2995
#20 0x0000003972645278 in g_main_context_iterate (context=0x1240800, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x000000397264544c in g_main_context_iteration (context=0x1240800, may_block=1) at gmain.c:3136
#22 0x000000397b7a682f in QEventDispatcherGlib::processEvents (this=0x11eaaf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x000000397f06c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x000000397b776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x000000397b776ed7 in QEventLoop::exec (this=0x7fffde2c0280, flags=...) at kernel/qeventloop.cpp:204
#26 0x000000397b77b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x0000000000402d23 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.7.3/kmail/main.cpp:145

Possible duplicates by query: bug 287970, bug 286635.

Reported using DrKonqi
Comment 1 Blagovest Zlatev 2011-12-01 16:06:42 UTC
I can't reproduce the bug and I can't find duplicates.
Comment 2 Blagovest Zlatev 2011-12-02 16:28:14 UTC
You must provide information if you're using POP or IMAP and also there is nothing in the C++ traceback to suggest problems with KDE.
Comment 3 Christian Ortega 2011-12-02 17:03:52 UTC
Created attachment 66313 [details]
website example konqueror (and rekonq and kmail) crash which

Open this website in some html-kde render app (kmail, konqueror, rekonq) and then close the window or tab, then the app crash. I believe that it is related with pair kde-flash (other html renders apps as Firefox or Chromium not crash).
Comment 4 Christian Ortega 2011-12-02 17:05:53 UTC
I am using IMAP. I beleave that the problem is related with flash, but only with KDE; flash objects in firefox and chromium work fine, but when render them in kmail, konqueror and rekonq, they apps crash. For exalmple, when I close (tab or window) the website attached (which contains a swf file), konqueror crash.
Comment 5 Christophe Giboudeaux 2011-12-04 10:54:58 UTC

*** This bug has been marked as a duplicate of bug 286307 ***