Bug 281285 - Plasma
Summary: Plasma
Status: RESOLVED DUPLICATE of bug 278141
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-03 20:03 UTC by Selviro
Modified: 2011-10-31 02:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Selviro 2011-09-03 20:03:08 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: travou misteriosamente, enquanto usava a internet, nem ao menos ativei o serviço, apenas surgiu o erro

-- Backtrace:
Application: Shell da área de trabalho do Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7860ad0 (LWP 1388))]

Thread 3 (Thread 0xaf6ffb70 (LWP 1392)):
#0  0x01757d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x04ea8dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x04f754f2 in updateCurrentTime (this=0xa1bcd7c, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xa1bcd7c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x04f73d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaf6ff0cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x04f73dcd in timerSourcePrepare (source=0xa1bcd48, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x018cbfd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x018cce63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x018cd524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x04f74577 in QEventDispatcherGlib::processEvents (this=0xa1bd0a8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x04f46289 in QEventLoop::processEvents (this=0xaf6ff280, flags=...) at kernel/qeventloop.cpp:149
#12 0x04f46522 in QEventLoop::exec (this=0xaf6ff280, flags=...) at kernel/qeventloop.cpp:201
#13 0x04e502a0 in QThread::exec (this=0xa1b95b8) at thread/qthread.cpp:492
#14 0x04f27fdb in QInotifyFileSystemWatcherEngine::run (this=0xa1b95b8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x04e52da2 in QThreadPrivate::start (arg=0xa1b95b8) at thread/qthread_unix.cpp:320
#16 0x01740e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00e3473e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xae0bdb70 (LWP 1393)):
#0  0x00e42620 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0x018cd0b4 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x018cd524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x04f74577 in QEventDispatcherGlib::processEvents (this=0xa22b2e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x04f46289 in QEventLoop::processEvents (this=0xae0bd280, flags=...) at kernel/qeventloop.cpp:149
#5  0x04f46522 in QEventLoop::exec (this=0xae0bd280, flags=...) at kernel/qeventloop.cpp:201
#6  0x04e502a0 in QThread::exec (this=0xa229b40) at thread/qthread.cpp:492
#7  0x04f27fdb in QInotifyFileSystemWatcherEngine::run (this=0xa229b40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x04e52da2 in QThreadPrivate::start (arg=0xa229b40) at thread/qthread_unix.cpp:320
#9  0x01740e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00e3473e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7860ad0 (LWP 1388)):
[KCrash Handler]
#7  0x00cc7755 in ~QExplicitlySharedDataPointer (this=0xa8494c4, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#8  Solid::Device::~Device (this=0xa8494c4, __in_chrg=<value optimized out>) at ../../../solid/solid/device.cpp:85
#9  0x04c21087 in ~QHashNode (this=0xa264d7c, akey=...) at /usr/include/qt4/QtCore/qhash.h:217
#10 deleteNode2 (this=0xa264d7c, akey=...) at /usr/include/qt4/QtCore/qhash.h:519
#11 deleteNode (this=0xa264d7c, akey=...) at /usr/include/qt4/QtCore/qhash.h:507
#12 QHash<QString, Solid::Device>::remove (this=0xa264d7c, akey=...) at /usr/include/qt4/QtCore/qhash.h:795
#13 0x04c1e3d3 in HotplugEngine::onDeviceRemoved (this=0xa264d68, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:243
#14 0x04c206a5 in HotplugEngine::qt_metacall (this=0xa264d68, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa58dd8) at ./hotplugengine.moc:81
#15 0x04f4d6ba in QMetaObject::metacall (object=0xa264d68, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbfa58dd8) at kernel/qmetaobject.cpp:237
#16 0x04f5d4ff in QMetaObject::activate (sender=0xa1bc8b8, m=0xd55c68, local_signal_index=1, argv=0xbfa58dd8) at kernel/qobject.cpp:3287
#17 0x00cc8dd3 in Solid::DeviceNotifier::deviceRemoved (this=0xa1bc8b8, _t1=...) at ./devicenotifier.moc:94
#18 0x00cc9ddc in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0xa1bc8b8, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#19 0x00cca585 in Solid::DeviceManagerPrivate::qt_metacall (this=0xa1bc8b8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa58f68) at ./devicemanager_p.moc:80
#20 0x04f4d6ba in QMetaObject::metacall (object=0xa1bc8b8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfa58f68) at kernel/qmetaobject.cpp:237
#21 0x04f5d4ff in QMetaObject::activate (sender=0xaf701c08, m=0xd56d40, local_signal_index=1, argv=0xbfa58f68) at kernel/qobject.cpp:3287
#22 0x00cde223 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0xaf701c08, _t1=...) at ./ifaces/devicemanager.moc:94
#23 0x00d2517a in slotDeviceRemoved (this=0xaf701c08, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa591ec) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#24 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0xaf701c08, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa591ec) at ./backends/upower/upowermanager.moc:78
#25 0x04f4d6ba in QMetaObject::metacall (object=0xaf701c08, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfa591ec) at kernel/qmetaobject.cpp:237
#26 0x04f5d4ff in QMetaObject::activate (sender=0xaf701c14, m=0xa1c3488, local_signal_index=4, argv=0xbfa591ec) at kernel/qobject.cpp:3287
#27 0x007be9e3 in QDBusInterfacePrivate::metacall (this=0xaf701d50, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbfa591ec) at qdbusinterface.cpp:278
#28 0x007a9acd in QDBusConnectionPrivate::deliverCall (this=0x9cedf08, object=0xaf701c14, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:942
#29 0x007b41d7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xa863cb8, object=0xaf701c14) at qdbusintegrator_p.h:103
#30 0x04f5c3b7 in QObject::event (this=0xaf701c14, e=0xa863cb8) at kernel/qobject.cpp:1226
#31 0x03548d24 in QApplicationPrivate::notify_helper (this=0x9c562d8, receiver=0xaf701c14, e=0xa863cb8) at kernel/qapplication.cpp:4462
#32 0x0354d8ce in QApplication::notify (this=0x9c4b7e0, receiver=0xaf701c14, e=0xa863cb8) at kernel/qapplication.cpp:3862
#33 0x011c23ca in KApplication::notify (this=0x9c4b7e0, receiver=0xaf701c14, event=0xa863cb8) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x04f470bb in QCoreApplication::notifyInternal (this=0x9c4b7e0, receiver=0xaf701c14, event=0xa863cb8) at kernel/qcoreapplication.cpp:731
#35 0x04f4ac79 in sendEvent (receiver=0x0, event_type=0, data=0x9bfdf50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9bfdf50) at kernel/qcoreapplication.cpp:1372
#37 0x04f4ae0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#38 0x04f743c4 in sendPostedEvents (s=0x9c55ff8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#39 postEventSourceDispatch (s=0x9c55ff8) at kernel/qeventdispatcher_glib.cpp:277
#40 0x018ccaa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x018cd270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#42 0x018cd524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#43 0x04f7453c in QEventDispatcherGlib::processEvents (this=0x9bfdaa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#44 0x035ff1e5 in QGuiEventDispatcherGlib::processEvents (this=0x9bfdaa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x04f46289 in QEventLoop::processEvents (this=0xbfa599d4, flags=...) at kernel/qeventloop.cpp:149
#46 0x04f46522 in QEventLoop::exec (this=0xbfa599d4, flags=...) at kernel/qeventloop.cpp:201
#47 0x04f4aecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#48 0x035468e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#49 0x006a45a5 in kdemain (argc=1, argv=0xbfa59be4) at ../../../../plasma/desktop/shell/main.cpp:118
#50 0x080485cb in main (argc=1, argv=0xbfa59be4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 279287, bug 278141, bug 277964, bug 276944, bug 276585.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-10-31 02:41:39 UTC

*** This bug has been marked as a duplicate of bug 278141 ***